cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1151
Views
0
Helpful
3
Replies

QoS on 3560, 2960 and 3750 does not work (Policy-map).

Ccoria1989
Level 1
Level 1

Hi

I am tryng to configure QoS on 3 switches (2960, 3560 and 3750) with this configuration:

 

mls qos

!
!
class-map match-all QOS_DATA_CLASS
  match access-group name QOS-DATA
class-map match-all QOS_DEFAULT_CLASS
  match access-group name QOS-DEFAULT
class-map match-all QOS_VOICE_CLASS
  match access-group name QOS-VOICE
class-map match-all QOS_SIGNALING_CLASS
  match access-group name QOS-SIGNALING
!
policy-map QOS-SOFTPHONE-POLICY
 class QOS_DEFAULT_CLASS
   set dscp default
 class QOS_SIGNALING_CLASS
   set dscp cs2
 class QOS_DATA_CLASS
   set dscp cs1
 class QOS_VOICE_CLASS
   set dscp cs3
!

!
interface GigabitEthernet0/34
 no switchport
 ip address 10.10.11.1 255.255.255.252
 ip ospf network point-to-point
 priority-queue out 
 service-policy input QOS-SOFTPHONE-POLICY

!

!

interface GigabitEthernet0/47
 switchport access vlan 150
 spanning-tree portfast
 service-policy input QOS-SOFTPHONE-POLICY

!
ip access-list extended QOS-DATA
 permit tcp any any eq 22
 permit tcp any any eq 465
 permit tcp any any eq 143
 permit tcp any any eq 993
 permit tcp any any eq 995
 permit tcp any any eq 1914
 permit tcp any any eq ftp
 permit tcp any any eq ftp-data
 permit tcp any any eq smtp
 permit tcp any any eq pop3
ip access-list extended QOS-DEFAULT
 permit ip any any
ip access-list extended QOS-SIGNALING
 permit tcp any any range 2000 2002
 permit tcp any any range 5060 5061
 permit udp any any range 5060 5061
ip access-list extended QOS-VOICE
 permit udp any any range 16384 32767
!

but when I check the show commands I see that QoS is not working.

CoreA#sh policy-map interface g0/34   
 GigabitEthernet0/34 

  Service-policy input: QOS-SOFTPHONE-POLICY

    Class-map: QOS_DEFAULT_CLASS (match-all)
      3 packets, 198 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-DEFAULT

    Class-map: QOS_SIGNALING_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-SIGNALING

    Class-map: QOS_DATA_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-DATA

    Class-map: QOS_VOICE_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-VOICE

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any 

CoreA#sh policy-map interface g0/47 
 GigabitEthernet0/47 

  Service-policy input: QOS-SOFTPHONE-POLICY

    Class-map: QOS_DEFAULT_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-DEFAULT

    Class-map: QOS_SIGNALING_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-SIGNALING

    Class-map: QOS_DATA_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-DATA

    Class-map: QOS_VOICE_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS-VOICE

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any 

 

What do I do bad?

 

The flow is the next:

 

Computer with CIPC --------> Switch 2960 or 3560 or 3750 ------------------> switch core ---------------> CIPC

 

I have wireshark in a port mirror on switch 2960, 3560 and 3750. In wireshark I always see the packets marked with default label.

 

I hope you can help me.

 

Regards.

 

3 Replies 3

Please, see this post: https://supportforums.cisco.com/discussion/11079636/c2960s-qos

The show policy-map interface doesn't work on these switches.

 

Regards.

Hi Daniele

Thanks for your help, I understand that but why when I use Wireshark in a span port on switches all packets are marked with default label?

Regards.

 

Try this config:

 

policy-map QOS-SOFTPHONE-POLICY

 class QOS_VOICE_CLASS
   set dscp cs3

 class QOS_SIGNALING_CLASS
   set dscp cs2

 class QOS_DATA_CLASS
   set dscp cs1

 class class-default
   set dscp default

 

 

BR