cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2396
Views
25
Helpful
18
Replies

Quick question for you all on SRST in CUCM 9

Tracy Larson
Enthusiast
Enthusiast

So I pull up a doc on cisco's website about SRST in call manager version 9 and it shows that 28XX and 38XX series routers are not supported. Now it didnt say incompatible, so I put it together in a lab and it still works fine. Basically what I read is just saying that if you have issues with SRST while running version 9 with a 28 or 38xx series router cisco wont support it? Seems strange to me.

http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs90spc.html                  

1 Accepted Solution

Accepted Solutions

ronpatel
Collaborator
Collaborator

Hi

Cisco Unified Survivable Remote Site Telephon y (SRST) does not depend upon Cisco Unified  Communications Manager, but supports phone loads. You can use ISR 28/38XX for SRST with CUCM 9.x

Check section "Cisco Unified Survivable Remote Site Telephony"

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr1.pdf

Regards
Ronak Patel

Rate all helpful post by clicking stars below the answer.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.

View solution in original post

18 Replies 18

ronpatel
Collaborator
Collaborator

Hi

Cisco Unified Survivable Remote Site Telephon y (SRST) does not depend upon Cisco Unified  Communications Manager, but supports phone loads. You can use ISR 28/38XX for SRST with CUCM 9.x

Check section "Cisco Unified Survivable Remote Site Telephony"

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr1.pdf

Regards
Ronak Patel

Rate all helpful post by clicking stars below the answer.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.

Hi,

Just to be clear,

Which SRST version is compatible with CUCM 9.x ?

In order to support SRST on a 28/38XX the max SRST version is 8.6, since this supports IOS 15.1(4)M4, the latest version for the 28/38XX. (higher SRST versions need IOS 15.2.x)

looking at http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs86spc.htm , i do not see that SRST8.6 is supported by CUCM 9.x

Did i miss something here ?

Many thanks !

Hi,

You can refer the link

http://tools.cisco.com/ITDIT/vtgsca/VTGServlet

regds,

aman

Hi Aman,

Thanks for the link,

but when looking at the 9.x compatibility table, i don't find SRST. (only survivable voicemail, with only 8.6 support ?)

what did i miss ?

thanks again.

Ton

You are right, there is no reference to SRST. The original link posted by Tracy is correct. SRST for CUCM9.X is not supported n 28xx/38xx routers

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

My aplogizes.

I unread the word VoiceMail.

regds,

aman

Ronak...

I am not so sure about that. It is well documented that 28XX/38XX are not supported for SRST on CUCM9.X. This is Cisco saying this...

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

Hi,

I was just seeing the DOCs and found this TECH TIP

https://supportforums.cisco.com/docs/DOC-16481

regds,

aman

Cisco does a great job of confusing, thank God we dont need a license to understand what they are saying. I would need Advanced IP Services when my little brain can only support Lite. Anyway, 28XX and 38XX series ISR's will work fine running in SRST while being a gateway connected to CUCM 9. I did lab this to verify.

What does matter is the types of phones connected to that gateway. Lets say you have a bunch of 6945's at the location and the gateway is running an IOS prior to that of 15.2.1T. This IOS would not be capable of talking to these phones while in SRST mode because SRST/CME 8.8 has the required loads for those phones running as SCCP. IOS 15.2.1T was the first rev I think that had SRST/CME 8.8 to support that model of phone. SIP support for these phones wasnt added until IOS release 15.2.2T.

If you have a bunch of 7965's there, they would work just fine while running in SRST/CME mode with IOS prior to 15.2.1T.

So it really doesnt matter what rev of CUCM is running and connected to what gateway, it depends on the type of phones that are connected to said gateway and what version of SRST/CME that gateway can support that contains the required loads.

Tracy

Hi Tracy,

thanks for confirmation.

regds,

aman

Tracy,

In practical that sounds right, but in reality if you have any issues,you will not get any support from Cisco. Until their documentation shows that it is supported, I will not deploy it for any high profile customer. Thats my own take on it.

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

Confusing indeed,

I guess this is the old difference between tested and not tested/documented (yet) by Cisco.

Is this a risk ? on the other hand, at this time in the customer's project, i would not like to tell the customer to replace all of his 28/38xx remote voice gateways... (although it is good for the business...)

sure we need to mention issue of not supporting the new devices with SRST.

Best Regards,

Ton

You are right and the first time I had this I was surprised. \it doesnt make sense to have to shell out a few thousand pounds/dollars just to abide to a document! I suggest you open a TAC case and get a written word from Cisco. I also suggest you inform your customer so they can be prepared to upgrade to the 29XX/39XX series gateways

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

In meantime i received official answer from Cisco:

Hi Ton,

I went ahead and asked the BU because it is my understanding that the SRST compatibility document is not updated to include CUCM versions 9.x as supported, please refer to:

http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs91spc.html

Besides I wanted to give you a definite answer. The response I got is the following, as I previously mentioned SRST is not dependent on the CUCM version, but in the phones supported and firmwares.

"There is no relationship between SRST and CUCM versions. SRST and CUCM never talk to each other. The only relationship that matters is between SRST and phone firmware versions. A phone running a later firmware version, but registering to an older SRST version, will be restricted to whatever feature set is in that SRST.

The only reason I would push the customer to upgrade hardware simply to get a later SRST version, would be for specific phone support... For example if they require Jabber (10.0) or 9971 (9.1) or 6945 (9.0) phones in SRST mode.

Other than that, just ensure the customer realizes that their SRST feature set will be dependent on what IOS version they are running. The BU does not back-test new firmware with old SRST loads."

I hope this clears things up, basically you'll be able to use CUCM 9.X with SRST 8.X on the current hardware as long as you need newer SRST features on newer phones, in that case an SRST upgrade (therefore IOS upgrade) and hardware replacement will be required.

Best Regards,

Ton

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: