cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
131
Views
0
Helpful
2
Replies
Beginner

Reboot loop after firmware upgrade

I have set up a very basic lab with new install of CUCM. It is single publisher with CUCM 8.6.2.1 and have just registered a 6941 and attempted to upgrade the firmware but the phone gets stuck in a loop.

I have tried installing 69xx-SIP.9-2-2-7 (current on 9-2-1-0) and after installing, checking device defaults have updated and restarting the TFTP my phone gets stuck in a loop rebooting. It boots up, downloads and install the new firmware, then reboots and downloads and install the old firmware and then repeats this loop infinitely. I have tried 9-4-1-3 and same issue happens (tried this first but then read that some phones have to go incrementally so tried 9-2-2-7).

Have tried messing around with device defaults and specifying the firmware on the actual device configuration for that phone. At times I have managed to get the phone booted up with the newer firmware actually loaded on it but the phone never registers again until I roll back the firmware on CUCM and reboot everything.

Only potential issue I can think of is I am currently using the alternate TFTP setting on the phone to point to TFTP/CUCM as I haven't got round to setting up a DHCP server as the solution I have currently needs some extra config to offer TFTP options so figured just for this I would be fine with manually configuring on the phone itself. The phone works fine otherwise just can't upgrade, am I missing something?

Cheers.

2 REPLIES 2
Highlighted
Cisco Employee

Hi,

Hi,

Did you try also putting the firmware on the phone load name?

Link:

https://supportforums.cisco.com/document/9873946/upgrade-downgrade-firmware-specific-ip-phone

I don't think pointing manually to the TFTP has something to do with this. I will assume CUCM server with it is registered is also TFTP server.

It is a direct upgrade to 9-4-1-3 from any 9.X version (check documentation below)

http://www.cisco.com/web/software/282074288/106919/cmterm-6921_6941_6961-sip.9-4-1-3-readme.html

I would ask if you are trying to upgrade with COP file or ZIP file.

Best regards,

Beginner

Hi, yes did try changing the

Hi, yes did try changing the load name for the specific phone and still had issues.

I am using the cop files for install.

The TFTP is the publisher.

My previous experience is from live systems and this is first time I have gone through deployment of CUCM so I wonder if I am maybe missing some other things that need upgrading or configuring after install? Are there any CUCM updates or dependencies the firmware upgrade might need? As far as I could see the 6941 firmware I am trying is compatible with 7.5+ or somewhere around that version of CUCM.

Thanks.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards