cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
249
Views
0
Helpful
3
Replies
etechexperts
Beginner

Restrict or adjust codecs presented in SDP Header

I'm setting up a SIP trunk to the ITSP with the typcial topology.

 

CUCM -- SIP Trunk -- CUBE -- SIP Trunk -- ITSP

 

The issue that I'm having is that when I send an invite from CUBE it appears to send 4 invites in rapid succession and the ITSP returns a 408 Request Timeout. The cause code is Reason Q.850;cause=102.

 

In talking with the ITSP they say that the INVITE header looks correct with all of the relevant IP addresses showing as our public IP address. They say that the reason for failure is that in the SDP packet we are showing every single codec possible and they are only looking for G711ulaw and G729R8.

 

I am needing some guidance on how to adjust the m=audio field in the SDP header. I have tried many different ways and nothing seems to change it.

 

I have tried the following:

1. voice-class sip profile containing only G711ulaw. Applied it to the outgoing ITSP dial peer
2. hard coded codec G711ulaw on the outgoing ITSP dial peer.
3. Set media termination point required on the CUCM sip trunk and specified G711ulaw as mtp preferred.

 

I'm not sure what I'm missing. Here is the current SDP packet from CUBE:

 

v=0
o=CiscoSystemsCCM-SIP 106 1 IN IP4 x.x.x.1
s=SIP Call
c=IN IP4 x.x.x.1
b=TIAS:64000
b=AS:64
t=0 0
m=audio 16620 RTP/AVP 114 9 124 113 115 0 8 116 18 101
b=TIAS:64000
a=rtpmap:114 opus/48000/2
a=fmtp:114 maxplaybackrate=16000;sprop-maxcapturerate=16000;maxaveragebitrate=64000;stereo=0;sprop-stereo=0;usedtx=0
a=rtpmap:9 G722/8000
a=rtpmap:124 iSAC/16000
a=rtpmap:113 AMR-WB/16000
a=fmtp:113 mode-change-capability=2
a=rtpmap:115 AMR-WB/16000
a=fmtp:115 octet-align=1;mode-change-capability=
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:116 iLBC/8000
a=maxptime:20
a=fmtp:116 mode=20
a=rtpmap:18 G729/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15

3 REPLIES 3
Anthony Holloway
Cisco Employee

I don't know about anyone else, but I'll need to see your configuration in order to comment. Can you post your show run?

Sorry.  That would probably help.  Sometimes you get so caught up in the details you forget the little things.  Here it is:

 

version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
service sequence-numbers
!
hostname CUBE
!
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.156-3.M6.bin
boot-end-marker
!
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
!
aaa session-id common
clock timezone CST -6 0
clock summer-time CDT recurring
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 172.27.199.1 172.27.199.31
!
ip dhcp pool VOICE
network 172.27.199.0 255.255.255.0
default-router 172.27.199.1
option 150 ip 172.27.199.10
dns-server 172.27.199.1
lease 7
!
!
!
ip domain name domain.com
ip name-server 172.16.11.110
ip multicast-routing
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group ALL_PSTN
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
ip address trusted list
ipv4 172.27.199.10
ipv4 172.27.199.11
ipv4 172.27.199.12
ipv4 2.2.2.182
ipv4 2.2.2.180
mode border-element license capacity 10
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
no fax-relay sg3-to-g3
modem passthrough nse codec g711ulaw
sip
bind control source-interface BVI1
bind media source-interface BVI1
rel1xx supported "rel100"
header-passing
asserted-id pai
asymmetric payload full
early-offer forced
midcall-signaling passthru
privacy-policy passthru
pass-thru content sdp
!
!
voice class uri ucm sip
host ^172.27.199.1[012]$
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
voice class sip-profiles 100
request INVITE sip-header From modify "<sip:(.*)@(.*)>" "<sip:\1@x.x.x.1>"
request INVITE sip-header Contact modify "<sip:(.*)@(.*):5060>" "<sip:\1@x.x.x.1:5060>"
request INVITE sip-header P-Asserted-Identity modify "<sip:(.*)@(.*)>" "<sip:\1@x.x.x.1>"
request INVITE sip-header Via modify "SIP/2.0/UDP 172.27.199.1:5060" "SIP/2.0/UDP x.x.x.1:5060"
response 200 sdp-header Connection-Info modify "c=IN IP4 172.27.199.1" "c=IN IPV4 x.x.x.1"
request INVITE sdp-header Session-Owner modify "172.27.199.10" "x.x.x.1"
request INVITE sdp-header Connection-Info modify "172.27.199.1" "x.x.x.1"
!
!
!
!
!
voice translation-rule 10
rule 1 /^.*/ /250/
!
voice translation-rule 15
rule 1 /^\([2-9].*\)/ /+1\1/
rule 2 /^\(1.*\)/ /+\1/
!
!
voice translation-profile PLUS-DIALING
translate called 15
!
voice translation-profile PSTN-to-UCM
translate called 10
!
!
!
fax interface-type fax-mail
vxml logging-tag
hw-module pvdm 0/0
!
hw-module sm 1
!
!
!
archive
log config
logging enable
logging size 600
hidekeys
!
redundancy
!
!
bridge irb
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address dhcp
shutdown
ip pim sparse-dense-mode
ip igmp version 3
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
bridge-group 1
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface ucse1/0
description Internal interface connected to UCSE Port 0
ip unnumbered BVI1
service-module heartbeat-reset disable
imc ip address 172.27.199.2 255.255.255.192 default-gateway 172.27.199.1
imc access-port shared-lom console
bridge-group 1
!
interface ucse1/1
description Internal switch interface connected to UCSE Port 1
no ip address
!
interface Vlan1
no ip address
!
interface BVI1
description Bridge interface providing access to router and UCSE module.
ip address 172.27.199.5 255.255.255.192 secondary
ip address 172.27.199.1 255.255.255.192
ip pim sparse-dense-mode
ip igmp version 3
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns server
ip route 0.0.0.0 0.0.0.0 172.27.199.8
!
!
!
access-list 23 permit 10.0.0.0 0.255.255.255
access-list 23 permit 172.16.0.0 0.15.255.255
access-list 23 permit 192.168.0.0 0.0.255.255
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local BVI1
sccp ccm 172.27.199.10 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface BVI1
associate ccm 1 priority 1
associate profile 4 register G729MTP
associate profile 3 register G711MTP
associate profile 2 register TRANSCODE
associate profile 1 register CONFERENCE
!
!
!
dspfarm profile 2 transcode
codec g711alaw
codec g711ulaw
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
!
dspfarm profile 1 conference
codec g729br8
codec g729r8
codec g711alaw
codec g711ulaw
maximum sessions 1
associate application SCCP
!
dspfarm profile 3 mtp
codec g711ulaw
maximum sessions software 2
associate application SCCP
!
dspfarm profile 4 mtp
codec g729r8
maximum sessions software 2
associate application SCCP
!
dial-peer voice 10 voip
description Inbound calls from CUCM to CUBE
translation-profile incoming PLUS-DIALING
session protocol sipv2
incoming called-number .T
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 20 voip
description Outgoing calls from CUBE to CUCM
destination-pattern 250
session protocol sipv2
session target ipv4:172.27.199.10
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 30 voip
description Incoming from ITSP
translation-profile incoming PSTN-to-UCM
session protocol sipv2
incoming called-number +12125551234
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 40 voip
description Outgoing to ITSP
destination-pattern +1[2-9]..[2-9]......$
session protocol sipv2
session target ipv4:2.2.2.182
voice-class codec 1
voice-class sip profiles 100
dtmf-relay rtp-nte
no vad
!
!
sip-ua
retry invite 3
timers trying 200
!
!
!
gatekeeper
shutdown

I'm bumping this.  Anyone have any ideas?  

 

The SDP header from CUCM to CUBE looks correct.  Somehow when the invite is being sent from CUBE to ITSP it is adding all of the codecs.

Content for Community-Ad

Spotlight Awards 2021