cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
309
Views
0
Helpful
5
Replies
Highlighted
Beginner

SCCP extension internal call to internal SIP extension go to public ip

PROBLEM

1. I can call from SIP (ext 812 Zoiper) to SCCP (Cisco Soft Phone ext 803) but not vice versa
From debug ccsip message shown, if I call from ext 803 SCCP to ext 812 SIP. It goes to external ip address.
It should go to internal ip instead.
How to fix that?
 
thanks
 

INFO:

-2811

-7912

-Zoiper

-Cisco Soft Phone
 

#debug ccsip message
#term mon
Sep  4 04:26:29.716: //136/E90D33C980FD/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:812@118.136.227.177:43123 SIP/2.0
Via: SIP/2.0/UDP 10.0.10.206:5060;branch=z9hG4bK7921B9
Remote-Party-ID: <sip:803@10.0.10.206>;party=calling;screen=no;privacy=off
From: <sip:803@10.0.10.206>;tag=1CEFC8-19AB
To: <sip:812@118.136.227.177>
Date: Fri, 04 Sep 2015 04:26:29 GMT
Call-ID: E99109FF-51F311E5-8102AC05-BB277C0A@10.0.10.206
Supported: 100rel,timer,resource-priority,replaces
Min-SE:  1800
Cisco-Guid: 3909956553-1374884325-2164108293-3139927050
User-Agent: Cisco-SIPGateway/IOS-12.x
 
#sh run
version 15.1
voice service voip
ip address trusted list
  ipv4 192.170.159.194 255.255.255.255
  ipv4 54.251.255.196 255.255.255.255
  ipv4 10.0.10.0 255.255.255.0
  ipv4 10.0.20.0 255.255.255.0
  ipv4 10.0.30.0 255.255.255.0
  ipv4 10.0.40.0 255.255.255.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
  registrar server
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice register global
mode cme
source-address 10.0.10.206 port 5060
max-dn 144
max-pool 35
tftp-path flash:
file text
create profile sync 0004537381553201
!
voice register dn  1
number 812
name 812
!
voice register pool  1
id mac 0000.0000.0812
number 1 dn 1
username 812 password 123
codec g711ulaw
no vad
!
voice translation-rule 9
rule 1 /\(^9\)/ //
!
voice translation-rule 628
rule 1 /^628/ /08/
!
voice translation-rule 9628
rule 1 /^9/ //
rule 2 /^\(.+62\)/ /0/
!
voice translation-profile 9
translate called 9
!
voice translation-profile 9628
translate called 9628
voice-card 0
!
license udi pid CISCO2811 sn FTX0918A0PF
archive
log config
  hidekeys
username admin privilege 15 secret 5 $1$XeEC$YORXhK8ZUtFjwabnYoHpS0
username cisco secret 5 $1$nFBH$Q6uWzeOmiu20v0UFFhqzY1
redundancy
no ip ftp passive
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.10.206 255.255.255.0
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.31.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
router eigrp 1
network 1.1.1.1 0.0.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http secure-port 8443
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip pim rp-address 1.1.1.1
ip nat inside source list 101 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 10.0.10.1
!
ip access-list standard blockedhost
deny   46.165.249.4
deny   118.136.227.177
permit any
tftp-server flash:CP7912080004SCCP080108A.sbin alias CP7912080004SCCP080108A.sbin
!
control-plane
call threshold global cpu-avg low 68 high 75
call threshold global total-mem low 75 high 85
ccm-manager music-on-hold
mgcp fax t38 ecm
mgcp profile default
!
dial-peer voice 1 voip
description Outgoing SIP DIDLogic
translation-profile outgoing 9
destination-pattern [+,9]1[2-9]..[2-9]......
session protocol sipv2
session target dns:sip.sg.didlogic.net
voice-class codec 1
voice-class sip bind control source-interface FastEthernet0/0
voice-class sip bind media source-interface FastEthernet0/0
dtmf-relay sip-notify
!
dial-peer voice 10 voip
answer-address 801
destination-pattern 14159172008
session target dns:sip.sg.didlogic.net
voice-class codec 1
voice-class sip bind control source-interface FastEthernet0/0
voice-class sip bind media source-interface FastEthernet0/0
!
dial-peer voice 20 voip
answer-address 801
destination-pattern 85258010007
session protocol sipv2
session target dns:sip1.hoiio.com
voice-class codec 1
voice-class sip bind media source-interface FastEthernet0/0
!
dial-peer voice 6 voip
description Outgoing SIP Hoiio
translation-profile outgoing 9
destination-pattern [+,9]852........
session protocol sipv2
session target dns:sip1.hoiio.com
voice-class codec 1
voice-class sip bind control source-interface FastEthernet0/0
voice-class sip bind media source-interface FastEthernet0/0
dtmf-relay sip-notify
!
dial-peer voice 11 voip
description Outgoing SIP Planet
translation-profile outgoing 9628
destination-pattern [+628,908]........T
session protocol sipv2
session target ipv4:10.0.10.87
voice-class sip bind media source-interface FastEthernet0/0
codec g711ulaw
!
dial-peer voice 30 voip
voice-class sip bind control source-interface FastEthernet0/0
voice-class sip bind media source-interface FastEthernet0/0
!
num-exp 85258010007 801
num-exp 14159172008 801
num-exp 081298998288 801
sip-ua
credentials username 1001 password 7 025756085F5123 realm 10.0.10.87
credentials username 08845 password 7 01232617481C561123 realm sip.sg.didlogic.net
credentials username sip7228256 password 7 044A04030475786A254809033B2123 realm sip1.hoiio.com
authentication username 08845 password 7 15222B1F173D7B3123 realm sip.sg.didlogic.net
authentication username sip7228256 password 7 06170024471A3D3D29461E1F252123 realm sip1.hoiio.com
authentication username 1001 password 7 00554155500123 realm 10.0.10.87
registrar 1 dns:sip.sg.didlogic.net expires 3600
registrar 2 dns:sip1.hoiio.com expires 3600
registrar 3 ipv4:10.0.10.87 expires 3600
sip-server dns:sip.didlogic.net
!
telephony-service
no auto-reg-ephone
max-ephones 35
max-dn 144
ip source-address 10.0.10.206 port 2000
max-redirect 5
cnf-file location flash:
date-format dd-mm-yy
max-conferences 8 gain -6
moh flash:/Wave.au
multicast moh 239.1.1.1 port 2000 route 10.0.10.1
web admin system name admin secret 5 $1$JGDo$afA54af/90u3S4gnt0s123
transfer-system full-consult
create cnf-files version-stamp 7960 Sep 04 2015 02:04:12
!
ephone-dn  1  dual-line
number 801 no-reg both
label Operator (x801)
name user delapannolsatu
!
ephone-dn  2  dual-line
number 802 no-reg both
label Sales (x802)
!
!
ephone-dn  3  dual-line
number 803 no-reg both
label CS (x803)
mobility
snr +6287809777430 delay 10 timeout 30
!
ephone-dn  4
number 888 no-reg both
name POC-Paging
paging ip 239.1.1.2 port 2000
!
!
ephone  1
device-security-mode none
mac-address 000B.BE3B.9E9C
username "u801" password 123
paging-dn 4
type 7912
button  1:1
!
ephone  2
device-security-mode none
mac-address 0012.0127.A14A
paging-dn 4
type 7912
button  1:2
!
ephone  3
device-security-mode none
mac-address E0DB.55A9.B3D5
paging-dn 4
type CIPC
button  1:3
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Please check if STUN (or any other NAT option) is enabled in Zoiper or not. Ensure it's disabled and share the REGISTER meesage.

View solution in original post

5 REPLIES 5
Highlighted
Beginner

I got different behaviour if I use X-Lite.

 

Here if using Zoiper. Its contact is DIDLogic ip

#sh sip-ua status registrar
Line          destination      expires(sec)  contact
transport     call-id
              peer
============================================================
812           10.0.10.112      263           118.137.204.179
TCP           bhUmyW41HflFVs8pXfeCag..
              40001

 

Here if using X-Lite.

Its contact is X-Lite ip

RTR2811a#sh sip-ua status registrar
Line          destination      expires(sec)  contact
transport     call-id
              peer
============================================================
812           10.0.10.112      292           10.0.10.112
TCP           76589NDIwOWIwOGNmMTgwYTZhYWFhYzAwNTUwZTVlZGNkY
              40001

 

Tried both application but still can't call SIP from SCCP 7912

 

thanks

Highlighted

Please check if STUN (or any other NAT option) is enabled in Zoiper or not. Ensure it's disabled and share the REGISTER meesage.

View solution in original post

Highlighted

SIP CLIENT SETTINGS:
Zoiper
Settings/Preferences/Accounts/General
Domain: 10.0.10.206
Username: 812
Password:
Caller ID Name: 812
Auth. username: 812
tick Use outbound proxy
Outbound proxy: 10.0.10.206
Settings/Preferences/Accounts/Extra
tick Register on startup
Settings/Preferences/Accounts/Codec
Selected codecs: u-law first
Settings/Preferences/Accounts/Advanced
Use DTMF RFC-2833
Use UDP transport
TLS with no SRTP
Don't use STUN

CSipSimple
Account name: Cisco
User: 812
Server: 10.0.10.206
Password:

 

I can't make X-Lite working, but Zoiper working all the time

Highlighted
VIP Advisor

Hi,

 

Check you nat statements. Try to exclude voip subnets from NAT
 

Highlighted

isp modem (dynamic ip)-> my TPLink -> cme ip 10.0.10.206

 

I am not really using NAT in the router.

-CME f0/0 10.0.10.206

-7912, Cisco Soft phone, Zoiper and X-Lite are in 10.0.10.x

So both CME and client in the same subnet.

Just for test in my POC, I am using the same subnet