cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
595
Views
0
Helpful
3
Replies
Highlighted
Beginner

Separate Voice and Data VLAN DHCP Scopes

Hi  Everyone

I have 3560 PoE switches with both data and voice vlans configured on each port:

interface FastEthernet0/1
switchport access vlan 150
switchport mode access
switchport voice vlan 151
no logging event link-status
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
service-policy input AutoQoS-Police-CiscoPhone

Both Vlans have an IP address

interface Vlan150
ip address 10.1.150.1 255.255.255.0
ip helper-address 10.1.0.13
ip helper-address 10.1.0.12
!
interface Vlan151
ip address 10.1.151.1 255.255.255.0
ip helper-address 10.1.0.13
ip helper-address 10.1.0.12
ip pim sparse-mode

My issue is, that whether the PC is plugged into the phone or not, the phones are getting their IP address from the data vlan DHCP scope.  Why would this be and if so, how can it be fixed so that the phones get IPs from the the 10.1.151.0 subnet?

Thanks

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Enthusiast

Re: Separate Voice and Data VLAN DHCP Scopes

I wonder if CDP is turned off.  Can you post the full "show run"?

View solution in original post

Enthusiast

Re: Separate Voice and Data VLAN DHCP Scopes

I believe the phones use CDP to tell the switch that they belong on the voice VLAN.  Are you receiving Voice network addresses on your phones now?

View solution in original post

3 REPLIES 3
Highlighted
Enthusiast

Re: Separate Voice and Data VLAN DHCP Scopes

I wonder if CDP is turned off.  Can you post the full "show run"?

View solution in original post

Highlighted
Beginner

Re: Separate Voice and Data VLAN DHCP Scopes

Actually CDP was off and I enabled it.  Would that

contribute to the issue?

Enthusiast

Re: Separate Voice and Data VLAN DHCP Scopes

I believe the phones use CDP to tell the switch that they belong on the voice VLAN.  Are you receiving Voice network addresses on your phones now?

View solution in original post

CreatePlease to create content