ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
Showing results for 
Search instead for 
Did you mean: 

Services Button does not send 'Get' message to server


This is a weird one!

Last night one of our distribution switches failed and was replaced. We have a Call Manager Cluster running 6.1.3 with around 5000 IP phones with 1 Publisher, 7 Subscribers and 2 TFTP Servers. (Split over 2 Data Centres).

Most phones / users use extension mobility and this morning when many user tried to log on, when pressing the 'Services' button on their phones, only brought up a blank screen with no Services shown.

I can't say what was lost last night, but the remote data centre might not have been available, so that many devices might have tried to re-register to the main data centre, and one of the TFTP servers might have been available. This is supposition!

The problem can easily be resolved either by resetting the phone; either by **#**, or from CCM Admin or by unpluging / replugging the lead to the phone.
The problem was not tied down to any particular CM-Group or Device Pool, so we took 2 phones - 1 OK, 1 NOTOK and this is what we found.
Both phones are registered
Both phones have their config files.
The services URL is on both phones.
Both phones are connected to the same access switch & same blade.
Web access to each phone shows no difference in any settings - (Apart from MAC address, IP address etc.)
The only thing different is that in the 'Status'  log, the 'bad' phone shows 'DHCP Timeout'
We took a 'Sniffer' trace from the 'good' phone and we can see the URL 'Get' request when we press the Services Button', but when we take a Sniffer trace from the 'Bad' phone, when we press the 'Services Button, no URL ' Get' request is sent from the phone.
It is almost if the phone is stuck in a process cycle. You can make calls on it normally and 'Messages', 'Directories' and 'Settings' button all work fine.
We also use an application called 'Remote Phone' which allows us to connect to an Ip Phone which alows us to see the phone in a GUI and control it remotely, but that will not connect to a 'bad' phone until it is reset, so again it seems like the phone doesn't want to respond.
The phones affected seem to be 7940s and 7960s. We haven't seen this issue on any 7912s. (Yet).
App load is P00308000900
Boot Load ID is PC0303010200
I've check CCO and cannot find any bugs or any thing related.
I guess this may have been a one off event and we can reset the phones to fix it, but would like to know if anyone has experienced anything liek this before.