cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
423
Views
0
Helpful
2
Replies

Setup QoS between phone servers over P2P

james.1052
Level 1
Level 1

I've got a digital phone system but it goes VoIP across our P2P T1's. I am having quality issues between our 2 sites only and have decided to setup QoS on the Cisco 1841 P2P routers. Since it is only 1 phone server on each side that does the voice traffic, I would like to do QoS by IP address, instead of by protocol. So if I understand correctly, I will need an access-list, a class-map and a policy-map and need to point the interface to the policy-map. I'm drafting a config but have hit a few mental bumps in the road so can anybody give me an example config based on best practices? Thanks!

2 Replies 2

james.1052
Level 1
Level 1

Okay, so how about this?:

ip access-list extended voip-qos

remark Phone Server QoS

permit host 1.1.1.1

class-map match-all voip

match access-group name voip-qos

policy-map qos

class voip

priority percent 80

class class-default

fair queue

int fa0/0

bandwidth 1544

bandwidth receive 1544

service-policy output qos

How does this look? Anybody have anything to add/corrections? Do you recommend bandwidth or priority as the appropriate method?

Ended up using this, which seems to have resolved it...

ip access-list extended voip-qos

remark This is for Site A and should be reversed for site B

remark These are the IP addresses of the phone servers

permit ip host 1.1.1.1 host 2.2.2.2

class-map match-all voip

match access-group name voip-qos

policy-map qos

class voip

priority percent 75

class class-default

fair-queue

int ser0/0/0

service-policy output qos