cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
750
Views
4
Helpful
12
Replies
KonradStepniewski
Participant

SIP outgoing call problem

Testing outgoing calls with SIP provider and getting quite odd result.

My topology:

CUCM 6.1 - trunk - CUBE-- (FW) -- inet -- SIP provider -- PSTN

When I call PSTN number via my SIP provider PSTN phone rings. When I answer the call is ended on PSTN end but my phone keeps ringing.

My Config:

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol cisco

h323

no h225 timeout keepalive

sip

!

dial-peer voice 99 voip

answer-address .T

destination-pattern .T

session protocol sipv2

session target ipv4:83.140.41.61

dtmf-relay rtp-nte

codec g711alaw

CUBE is registered with SIP provider and I'm sending correct number as CLID.

Looks like problem with signaling but not sure where is problem. Between CUBE and internet there is firewall doing NAT but tried different options and same results.

Any help really appreciated.

12 REPLIES 12
KonradStepniewski
Participant

Full debug ccsip all from one call.

You're receiving a 200 OK but it's not getting through.

Add this:

voice service voip

sip

midcall-signaling passthru

And upgrade to 12.4(24)T1

hth,

nick

Upgraded and added command to configuration but this has changed nothing.

I will open case with TAC to solve this issue.

Hi

I do have the same problem.

Please post if you are able to solve the issue.

Thank you in advance

Yes, but problem was on Juniper firewall and SIP ALG enabled. Cisco side was fine.

Seems like I'm dealing with the same issue. However, I've upgraded my 1760 to IOS release 12.4(25b) but I still don't have the option "midcall-signaling" in the SIP configuration part of voice service voip. Is this command only available on the 28xx platform?

Hi Dave,

This is in 12.4(20)T and later. 12.4(25) is still mainline (not T-train) code.

You may not be able to get this command on the 1760, as I believe IOS stopped at 12.4(15)T. You may try 12.4(15)XZ if it's available.

-nick

Hi Nick,

You're right: according to CCO the last available IOS for the 1760 platform in the T-train is 12.4(15)T10, which according to the release notes contains some new features and bugfixes but not the SIP commmands needed. Apparently the mainline releases don't include them either... Any suggestions apart from upgrading to a 28xx platform?

Cheers, dave.

IP-to-IP GW not passing messages mid-call is a serious bug and cisco should fix it in all releases no matter what.

I wonder why it has not surfaced until now.

Hi Dave,

The reason for this is because H323-SIP / SIP-SIP supplementary features weren't added until 12.4(20)T. They mostly worked, but they had not been tested and had all of the right things developed yet.

Unfortunately, there's a good chance you may not be able to get SIP-SIP / SIP-H323 features on the 12.4(15)T throttle. It's much more than a bug - there were 2 or 3 full projects to getting these features to work correctly, and they were added in 12.4(20)T.

You may have better luck with SIP-H323 than SIP-SIP, as it takes use of the H323 code which was a little more mature in the 12.4(15)T train.

-nick

Hi Nick,

I've changed the implementation to H323-SIP, now ringback tone is working fine. Thanks for your help!

Cheers, dave.

Hi Dave,

Glad I could help!

-nick

Content for Community-Ad

Spotlight Awards 2021