cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
5137
Views
1
Helpful
9
Replies
Highlighted

SIP Profile to enable Caller ID anonymous@anonymous.invalid calls

Hi Guys,

One of my customer is sending no caller ID on SIP Invite.

The "From" part on SIP INVITE Message looks like below

From: Anonymous <sip:anonymous@anonymous.invalid>;tag=XXXX

How can i covert this to From: 916850 <sip:916850@72.69.12.2>

I Tried below SIP Profile config on CUBE. 

voice class sip-profiles 100
  request INVITE sip-header From modify "Anonymous <sip:anonymous@anonymous.invalid>" "916850 <sip:916850@72.69.12.2>"

voice service voip
sip
 sip-profiles 100

But does not seems to work. Any inputs will be of great assistance.

9 REPLIES 9
Highlighted
Beginner

Try applying in the outbound VOIP dial peer instead of applying Globally. That should work

Regards

Devan

Please rate useful posts!!!

Highlighted

there is only one voip dial peer on router.. i tried to apply it there.. still does not work..

how can we debug voice class sip profile?

Highlighted

Did you try like below, cause i don't see a ":" in your syntax

request INVITE sip-header From: modify "Anonymous <sip:anonymous@anonymous.invalid>" "916850 <sip:916850@72.69.12.2>"

Regards

Devan

Please rate useful posts!!!

Highlighted

thats not even right syntax.. 

(config-class)#request INVITE sip-header From: modify "Anonymous <sip:anonymous@anonymous.invalid>" "916850 <sip:916850@72.69.12.2>"


^
% Invalid input detected at '^' marker.

right syntax thats accepted by router is 

#request INVITE sip-header From modify "Anonymous <sip:anonymous@anonymous.invalid>" "916850 <sip:916850@72.69.12.2>"

And does not work..

Highlighted
Beginner

I had the same thing. The INVITE from CUCM to CUBE looked good, but from CUBE to our provider it was similar to what you saw:

From: "anonymous" <sip:anonymous@...etc.

I saw that the number was present in the P-Asserted-Identity: header, so in the SIP profile I copied it from there:

request INVITE sip-header P-Asserted-Identity copy "<sip:(.*)@" u01

And then copied it into the From: header as both name and number:

request INVITE sip-header From modify "\".*\"" "\"\u01\""
request INVITE sip-header From modify "<sip:.*@" "<sip:\u01@"

I don't really like this solution. I'd rather have it pass along whatever CUCM sends. I'm still looking for another way to do it. But it works.

Also, if you're like me, and it takes you twelve tries to get the regex right, I recommend the online SIP-Profile Test Tool. It let me futz with the syntax for as long as it took without messing with the actual gateway, making test calls with debug on, etc.

Highlighted

Can you paste the complete SIP INVITE that you get from CUCM ? Also, can you attach your CUBE config ?

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Highlighted
Cisco Employee

Highlighted
Beginner

Hi,

 

try this:

 

Voice service voip

sip

sip-profiles inbound
sip-profiles 10 inbound

exit

 

voice class sip-profiles 10
request ANY sip-header From modify "<sip:anonymous@Anonymous.invalid" "<sip:916850@72.69.12.2"

exit

 

Regards,

Ahmad Kefaya

 

 

Highlighted

I had the same issue and had to enable it under global settings to modify the incoming invite from the SP. I tried under all DP's and it wouldn't work even enabling the function globally. It wasn't until I added the 

sip profiles 1 inbound 

Command in Global 

 

Content for Community-Ad