Showing results for 
Search instead for 
Did you mean: 


SIP SRST issue with registration

Hello all,


I would like to share with you my problem and look for the solution. Since a couple of days I'm trying to bring my ISR G2 2901 in my lab to be capable of handling SRST for SIP phones and it driving me crazy - btw I've successfully done it for SCCP phones.


I went through a couple of other problems described here in this community, and I finally reached this point.


Phones are sending REGISTER message to the SRST reference, and the router even responds to that message. However phones keeps sending REGISTER message. It looks like the phone is registered and shows for a couple of seconds message "SRST Mode" which is my failover text, but then it turns to keep showing "Registering". What's more interesting is that after some time it attempts to register for a second time and it even successfully doing that, but router start responding with 500 Internal Server Error.


You can clearly see that when looking at pcap and router console debug. In the text file there is also at the end part of my related SRST configuration.


I have even tried to upgrade IOS to one of the latest to exclude some defect, but it's still beahaving the same.


Lab Topology:

Router - (SRST Reference)

CUCM - (ver 10.5.2 SU8 with latest DevicePack)

SIP Phones 7975 and 7962 - and


Enabled debug:

CCSIP SPI: SIP Call Message tracing is enabled (filter is OFF)
CCSIP SPI: SIP Call Events tracing is enabled (filter is OFF)
CCSIP SPI: SIP error debug tracing is enabled (filter is OFF)
CCSIP SPI: SIP Out-of-Dialog tracing is enabled (filter is OFF)

voice-register error debugging is on
voice-register events debugging is on


LAB-HQ-RTRV-01#show sip-ua status registrar
Line destination expires(sec) contact
transport call-id
+48220001001 844
UDP 00235e17-ed4c15d6-91dd2e25-5327cf6f@

+48220001001 1112
UDP 00235e17-ed4c1602-653cb99b-1fc9a42c@

+48220001003 761
UDP c8f9f968-6da215b5-23a5574c-a5a2c363@

+48220001003 1036
UDP c8f9f968-6da215dc-248b67fe-66b3e7fa@


LAB-HQ-RTRV-01#sh voice register global
CONFIG [Version=12.0]
Version 12.0
Mode is srst
Max-pool is 5
Max-dn is 5
Outbound-proxy is enabled and will use global configured value
Security Policy: DEVICE-DEFAULT
Allow-hash-in-dn is enabled
Forced Authorization Code Refer is enabled
System message is SRST Mode
timeout interdigit 4
timeout transfer recall 0
network-locale[0] US (This is the default network locale for this box)
network-locale[1] US
network-locale[2] US
network-locale[3] US
network-locale[4] US
user-locale[0] US (This is the default user locale for this box)
user-locale[1] US
user-locale[2] US
user-locale[3] US
user-locale[4] US
MWI unsolicited notify is disabled
Active registrations : 4

Total SIP phones registered: 2
Total Registration Statistics
Registration requests : 52
Registration success : 52
Registration failed : 0
unRegister requests : 48
unRegister success : 48
unRegister failed : 0
Auto-Register requests : 0
Attempts to register
after last unregister : 0
Last register request time : 12:42:43.719 CET Sun Jun 30 2019
Last unregister request time : 12:34:06.292 CET Sun Jun 30 2019
Register success time : 12:42:43.719 CET Sun Jun 30 2019
Unregister success time : 12:34:06.293 CET Sun Jun 30 2019


Looking forward to your ideas.

Thanks you in advance.

Best regards,


Everyone's tags (2)
Cisco Employee

Re: SIP SRST issue with registration

if you look at your REGISTER messages closely, you will see that they have expires value as 0. If this was a legit REGISTER request from a phone who is actually trying to register with SRST, i would see expires value as 3600.
Value 0 means that it is not a register request but a keepalive message that phones usually send to their SRST router while being registered to the CUCM.

for one case i see the expires value come in as 3600 and the SRST router sends 200 ok for the register and does register it.
check SIP callid c8f9f968-6da215b5-23a5574c-a5a2c363@

However eventually i see REGISTER requests coming to the SRST router all over again.
your config seems OK. it is less about config and more about the stability of your connection between phone and CUCM and the phone and SRST router
i would check and make sure that the phones have completely lost IP connectivity with the CUCM because it seems they are toggling between CUCM and SRST router.
for testing just shut down the CCM service on your CUCM servers and then test.


Re: SIP SRST issue with registration

Hello Ishan,


Thank you very much for your prompt reponse. 


I'll shut CCM services today/tomorrow and revert to you with my findings. Should I collect any packet capture or debug? If packet capture where should I collect it - packet capture on router or session monitor of the phone LAN port?


Best regards,


Cisco Employee

Re: SIP SRST issue with registration

collect :

debug ccsip verbose
and the "show tech voice" of the router

packet captures you can run a monitor session on the switch port where the phones are connected.

Re: SIP SRST issue with registration

Hello Ishan,


My apologize for the delay, something has stopped me at work and I couldn't really access my lab and execute your request. But it is done - requested files are attached to this message.


Same behavior :(

Best regards,


Cisco Employee

Re: SIP SRST issue with registration

There is something wrong going on with the SRST testing.


almost all events i see the phone sending the REGISTER message with expires value as 0. This will make the SRST router not register the phone.

as soon as the REGISTER message arrives from the phone with expires value 3600, we can clearly see the SRST router registering the phone by sending a 200 ok which is how it should work.


Via: SIP/2.0/UDP;branch=z9hG4bK4e89d0b5
From: <sip:+48220001001@>;tag=00235e17ed4c01c749b8174c-df41091f
To: <sip:+48220001001@>
Call-ID: 00235e17-ed4c015d-9d8e196b-cfa847fc@
Max-Forwards: 70
Date: Wed, 03 Jul 2019 19:52:54 GMT
User-Agent: Cisco-CP7975G/9.4.2
Contact: <sip:519c34d5-c179-6ed3-85b3-6ded98a8d35a@;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-00235e17ed4c>";+u.sip!"SEP00235E17ED4C";+u.sip!"437"
Supported: extended-refer,norefersub,X-cisco-srtp-fallback,X-cisco-config,X-cisco-sis-6.0.0,X-cisco-xsi-8.5.1
Content-Length: 0
Reason: SIP;cause=200;text="cisco-alarm:10 Name=SEP00235E17ED4C Load=SIP75.9-4-2SR3-1S Last=tcp_timeout"
Expires: 3600


//SRST router sends 200 ok for this//


Jul 3 21:53:11: //1049/FC263CA18420/SIP/Msg/ccsipDisplayMsg:

LAB-HQ-RTRV-01#SIP/2.0 200 OK
Via: SIP/2.0/UDP;branch=z9hG4bK4e89d0b5
From: <sip:+48220001001@>;tag=00235e17ed4c01c749b8174c-df41091f
To: <sip:+48220001001@>;tag=C6D1A8-2026
Date: Wed, 03 Jul 2019 19:53:11 GMT
Call-ID: 00235e17-ed4c015d-9d8e196b-cfa847fc@
Server: Cisco-SIPGateway/IOS-15.7.3.M4b
Supported: X-cisco-srst-sis-1.0.0
Supported: X-cisco-srtp-fallback
Contact: <sip:+48220001001@>;expires=1200;x-cisco-newreg
Expires: 1200
Content-Length: 0


the only thing that is noticeable here is the difference in expires value which you can probably correct by doing


voice service voip
registrar server expires max 3600 min 300


  • however the weird part is that we receive the REGISTER message from the phone all over again which is not right
  • from the PCAPs i see that there is a small window during which the phone does register fine
  • however after a few minutes, i start to see the same REGISTER/200 ok transaction happening again and again as if the phone never received the 200 ok from the SRST router.

are the packet captures from the back of the phone or the SRST router?

is the srst router and the phone in the same location or different locations?


a few things that you can try is by defaulting the configs to simplify things


voice register global
default mode
timeouts interdigit 4
system message SRST Mode
max-dn 5
max-pool 5
timezone 28

voice register pool 1
id network


voice service voip
registrar server expires





Re: SIP SRST issue with registration

Hello Ishan,


My apologize for late feedback. I was preparing for my CIPTV2 exam which I took 11th of July.


I have used your commands and for 79xx series it still doesn't work. I have recently purchased for my lab 8845 and these registered in within few seconds with a router.


Right now I'm having 7961 registered to SRST with SCCP and 2x 8845 registered to SRST with SIP. 2 phones is not registering with SIP SRST and these are 7962 and 7975. What's for me most important it's the fact that it's working at least for 8845, although I think I might be facing some sort of a bug and that's why it's not working.


Nevertheless thank you very much for your effort and time. I'm glad I could learn some more stuff about SRST registration in depth which will definitely payback in my professional career :)


Best regards,


CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey