cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
20508
Views
38
Helpful
49
Replies

SIP trunk, CUBE and CUCM 8.5

pjiracek
Level 1
Level 1

I have a SIP trunk from a TSP terminated on the CUBE. - c2901 gateway connected via H323 to a CUCM 8.5 cluster. The signalling looks OK but I have no voice. The provider seems to support only G.729br8 codec and my phones (c6901 and c6921) seem to talk G.729r8 only so I need to do some transcoding. I'm in the UK btw.Now, I can do it on the CUBE and utilize dspfarm but that is I think only possible with SCCP. How do I register the gateway in CUCM, if it's already there as the H323 gateway?

Is there any way to do the transcoding on the CUCM? Any general advise would be much appreciated.

Cheers

3 Accepted Solutions

Accepted Solutions

Ok,

You still have not configured the dial-peer to CUCM to use SIP. But here is what I see..

Sent:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 146.191.243.4:6280;branch=z9hG4bK7kljtp2088b0cmgv34l0.1

From: ;tag=536c8c54

To: <5811>;tag=44F7878-C23

Date: Wed, 27 Jun 2012 09:38:06 GMT

Call-ID: ODE1Y2E4ZTlhZDg1NjM0MmRhZDE4YmNhNTRiMjhkN2M.

CSeq: 1 INVITE

Require: 100rel

RSeq: 650

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

Allow-Events: telephone-event

Remote-Party-ID: "Michelle  Walters" <5811>;party=called;screen=no;privacy=off

Contact: <5811>

Supported: sdp-anat

Server: Cisco-SIPGateway/IOS-12.x

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 262


v=0

o=CiscoSystemsSIP-GW-UserAgent 5886 9981 IN IP4 146.191.201.41

s=SIP Call

c=IN IP4 146.191.201.41

t=0 0

m=audio 20748 RTP/AVP 18 96

c=IN IP4 146.191.201.41

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:96 telephone-event/8000

a=fmtp:96 0-16

You are sending G729br8 to your provider but they do not support annexb because in their invite we do not see annexb.

INVITE sip:5811@UniWestScot:5060 SIP/2.0

Via: SIP/2.0/UDP 146.191.243.4:6280;branch=z9hG4bK7kljtp2088b0cmgv34l0.1

Max-Forwards: 68

Contact:

To: <5811>

From: ;tag=536c8c54

Call-ID: ODE1Y2E4ZTlhZDg1NjM0MmRhZDE4YmNhNTRiMjhkN2M.

CSeq: 1 INVITE

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, REFER, PRACK

Content-Type: application/sdp

Supported: 100rel

P-Asserted-Identity:

Content-Length: 278


v=0

o=Redwood_INX 347015 347015 IN IP4 146.191.243.4

s=Redwood Media Server

c=IN IP4 146.191.243.4

t=0 0

m=audio 50002 RTP/AVP 8 18 96

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=rtpmap:96 telephone-event/8000

a=sendrecv

a=silenceSupp:off

a=ecan:on

a=fmtp:96 0-15

So either configure your cube to transcode from g729br8 to g729r8 or send your provider g729r8

Here is the document to use to setup xcoding on your cube..

http://www.cisco.com/en/US/products/sw/voicesw/ps5640/products_configuration_example09186a008092d6b3.shtml

Ensure you add g729br8 in your list of codecs

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

View solution in original post

Hi,

I have looked at the trace in detail and I have an idea why this is not working..

Can you please remove this from your dial-peers to cucm. Please ensure you remove from all dial-peers to cucm and sip provider.

progress_ind setup enable 3

progress_ind alert enable 8

Please do another test call and send me debug ccsip messages.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

View solution in original post

The reason why this is not working is because the called number is not 5811 from the sip provider..

Your dial-peer 1 is like this..

dial-peer voice 1 voip

  incoming called-number 5[8-9].. (this is not the incoming called number)

it should be this..

dial-peer voice 1 voip

incoming called-number 01387345[8-9]..

Then when this dial-peer is matched, the xlation will be applied.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

View solution in original post

49 Replies 49

Ayodeji Okanlawon
VIP Alumni
VIP Alumni

Hi,

I doubt if yourprovide ronly support G729br8. Most providers support a variety of codecs. You can turn on "debug ccsip messages" on your cube and see what codecs your provider is sending to you..

I will suggest you start with this before going down the xcoding route

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

Have had a look already. The provider offers PCMA/8000 and G729/8000 codecs which seem to translate to g711a and g729br8 in cisco speak. And the flavour g729br8 is not liked by our phones.

OK, I've progressed a bit - our phones should do g729br8 so no transcoding needed.

I still cannot get any voice. I have the right codec set up on the CUBE for the SIP trunk and for the CUCM.(g729br8)

I have the CUBE and the phones in regions set up for G.729.

One thing - my CUBE is just an IP host (with 1 ethernet interface) and I have no ip routing. It's on a remote site so I cannot easily turn it on - but I cannot think it would make a difference.

So now I have only g729br8 codec on the CUBE gateway. I make a inbound call over the SIP trunk, phone rings, when I pick it up (no audio) I can check the Sender codec = G711u and RCVR codec =G711u on the phone. What's going on? The phone is in a different region than the CUBE and the Max Audio bit rate between the 2 regions is 8kbps -> G729. Why does the phone insist on G711u?

Hi pijaracek,

Look like is not a CODEC negotiation problem because the call is established. Are you using Media Flow around or Passtrought?

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

No media flow,

I have only

fax protocol pass-through g711ulaw

I'm starting to suspect the config of the gateway in CUCM needs some change

Please post your show run

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

Here is the sh run on the CUBE:

I am not sure why you want help but you dont want to send over the things that can be used to help. I asked earlier for "debug ccsip messages". If you want us to help..please send the debug and your sh run.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

Sorry, I didn't get yoy asked for the debug. Here it is:

pjiracek
Level 1
Level 1

I suspect now the SIP trunk and the CUBE configuration is OK.

For inbound calls over the SIP trunk I cannot hear the ringing tone although the phone is ringing and then if I redirect in CUCM using

Forward No Answer External

to Voicemail or another internal number, suddenly it works - the redirected call is ringing and there is audio after pick up.

Anything I should try to change in CUCM H323 gateway configuration?

It looks like this:

Hi first of all I will advise to tidy up your configuration. This two dial-peers are not right.

dial-peer voice 2 voip

description *** INBOUND VOIP PEER ***

incoming called-number .

voice-class codec 1

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 1 voip

description *** INBOUND SIP TRUNK PEER ***

translation-profile incoming SIP-TRUNK-IN

session protocol sipv2

session target ipv4:XXX.XXX.243.4

incoming called-number .

voice-class codec 2

dtmf-relay rtp-nte

no vad

Both dial-peers are used for inbound calls from CUCM and from your SIP provider. Your sip provider sends a sip leg and one of these dial-peers is doing a h323 leg. I will advise that you either configure a specific dial-peer to match incoming calls from your sip provider and configure sip protocol on that dial-peer or you configure a single dial-peer with incoming called number. and session protocl sip. Then configure a sip trunk from your cucm to your cube.

So before we troubleshoot further, please do what I suggest.

The best scenario is to have an and to end sip solution like this..

CUCM-----SIP Trunk--->CUBE------>ITSP.

To do this, you need to configure a sip trunk on cucm to CUBE and then configure this interface like this..(make the IP on the destination siup trunk to be=ip of gig0/1)

voice service voip

sip

  bind control source-interface GigabitEthernet0/1

  bind media source-interface GigabitEthernet0/1

After configuring this then configure the ff:

dial-peer voice 1 voip

description *** INBOUND DIAL-PEER ***

translation-profile incoming SIP-TRUNK-IN

session protocol sipv2

incoming called-number .

voice-class codec 2

dtmf-relay rtp-nte

no vad

no dial-peer voice 2 voip (remove this dial-peer).

Do a test call and send debug ccsip messages.

If you want to stick with the h323 scenario, your call flow will look like this..

cucm----h323----CUBE---sip--->ITSP

You need to configure the ff: in addition to what you have now

interface GigabitEthernet0/1

h323-gateway voip interface

dial-peer voice 1 voip

description *** INBOUND SIP TRUNK DIAL-PEER ***

translation-profile incoming SIP-TRUNK-IN

session protocol sipv2

incoming called-number 5[8-9]..

voice-class codec 2

dtmf-relay rtp-nte

no vad

dial-peer voice 2 voip

description *** INBOUND VOIP PEER ***

incoming called-number .

voice-class codec 1

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs3 signaling

no vad

 

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

Thanks for the reply.

I'd like to keep the h323 - sip scenario. So I changed the config as you suggested (I think in dial-peer voice 2 voip you missed session target clause). It still doesn't work. There is no dial tone for the inbound calls, although the phone rings and the call can even be successfully redirected and it rings once for the outbound calls and then the CUBE cancels the call and there is busy tone.

Here is the inbound call debug:

Need to check the config but the symptoms are like the call is matching default dial peer

Sent from Cisco Technical Support iPad App

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: