cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6939
Views
5
Helpful
9
Replies

SIP Trunk Diversion Header Issue

Hi Team,

We have got an issue at our new 10.5.1 cluster. We have SIP Trunks provided by Verizon at Leeds UK. We have enabled the Enterprise Mobility (Single Number Reach) for our executives. But Mobility feature is working fine for internal calls but not for external calls. As Verizon is rejecting the calls because of caller ID. Verizon asked us to change the P-Asserted-Identity with the DID in their range to accept the calls. I have no idea how to do the same. Can you please let me know how to do the same. Verizon’s DID range is 441133015XXX. They expect for outgoing calls, caller id should be in 441133015XXXX. I am also pasting debugs from our SIP Gateway for your reference. 

As per the logs, customer with calling number +914066164069 called Mobility enabled IP Phone with DID 441133015196, which then sent to users mobile +919948242667 through Mobility feature. We see call terminated through Verizon SIP Trunk from SIP traces, but get SIP/2.0 403 Forbidden message from Verizon, as they have rejected our call.

Need your help on achieving this, as I need to implement the same to our Business Executives.

 

Thanks,
Solomon.

9 REPLIES 9
Cisco Employee

Hi Solomon,As per the

Hi Solomon,

As per the Features and services guide for cucm:

 

Example RDNIS/Diversion Header Use Case

Consider a user that has the following setup:

Desk phone number specifies 89012345.

Enterprise number specifies 4089012345.

Remote destination number specifies 4088810001.

User gets a call on desk phone number (89012345) that causes the remote destination (4088810001) to ring as well.

If the user gets a call from a nonenterprise number (5101234567) on the enterprise number (4089012345), the user desk phone (89012345) rings, and the call gets extended to the remote destination (4088810001) as well.

Prior to the implementation of the RDNIS/diversion header capability, the fields populated as follows:

Calling Party Number (From header in case of SIP): 5101234567

Called Party Number (To header in case of SIP): 4088810001

After implementation of the RDNIS/diversion header capability, the Calling Party Number and Called Party Number fields populate as before, but the following additional field gets populated as specified:

Redirect Party Number (Diversion Header in case of SIP): 4089012345

Thus, the RDNIS/diversion header specifies the enterprise number that is associated with the remote destination.

Configuration of RDNIS/Diversion Header in Cisco Unified Communications Manager Administration

To enable the RDNIS/diversion header capability for Mobile Connect calls, ensure the following configuration takes place in Cisco Unified Communications Manager Administration:

All gateways and trunks must specify that the Redirecting Number IE Delivery — Outbound check box gets checked.

In Cisco Unified Communications Manager Administration, you can find this check box by following the following menu paths:

For H.323 and MGCP gateways, execute Device > Gateway and find the gateway that you need to configure. In the Call Routing Information - Outbound calls pane, ensure that the Redirecting Number IE Delivery - Outbound check box gets checked. For T1/E1 gateways, check the Redirecting Number IE Delivery - Outbound check box in the PRI Protocol Type Information pane.

For SIP trunks, execute Device > Trunk and find the SIP trunk that you need to configure. In the Outbound Calls pane, ensure that the Redirecting Diversion Header Delivery - Outbound check box gets checked.

 

HTH

Manish

Cisco Employee

Here is the link for

Here is the link for reference

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/admin/8_6_1/ccmfeat/fsgd-861-cm/fsmobmgr.html

HTH

Manish

Highlighted

Outbound CallsCalled Party

Outbound Calls

Required Field
Required Field
Required Field
Required Field

 

Please find the out put from CUCM, I did enabled redirecting diversion header delivery - outbound under Outbound calls section of my SIP Trunk. But calls are not rolling over to my mobile. I ran the SIP Traces in the gateway and pasted below (also attached). Actually Service Provider said that they look P-Asserted-Identity as UK number 441133015191 instead of +914066164039, to allow the outgoing calls from Verizon's soft switch.

 

INVITE sip:900919959470707@10.199.0.253:5060 SIP/2.0
Via: SIP/2.0/TCP 10.199.14.22:5060;branch=z9hG4bK2ac6c2d8fd2
From: <sip:+914066164039@10.199.14.22>;tag=54437~b00d5e83-0416-4694-8957-d52f1f3c809f-18905874
To: <sip:900919959470707@10.199.0.253>
Date: Thu, 19 Feb 2015 09:44:38 GMT
Call-ID: ea200c80-4e51b086-ba9-160ec70a@10.199.14.22
Supported: 100rel,timer,resource-priority,replaces
Min-SE:  1800
User-Agent: Cisco-CUCM10.5
Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY
CSeq: 101 INVITE
Expires: 180
Allow-Events: presence
Supported: X-cisco-srtp-fallback
Supported: Geolocation
Cisco-Guid: 3927968896-0000065536-0000001710-0370067210
Session-Expires:  1800
Diversion: "Solomon Kavala - 4105191" <sip:901133015191@10.199.14.22>;reason=follow-me;privacy=off;screen=yes
P-Asserted-Identity: <sip:+914066164039@10.199.14.22>
Remote-Party-ID: <sip:+914066164039@10.199.14.22>;party=calling;screen=yes;privacy=off
Contact: <sip:+914066164039@10.199.14.22:5060;transport=tcp>
Max-Forwards: 67
Content-Type: application/sdp
Content-Length: 201

Seems CUCM output is not

Seems CUCM output is not copied correct, so i took a snapshot of outbound calls section in my SIP Trunk and attached.

Solomon

Cisco Employee

Hi Solomon,Looks like you

Hi Solomon,

Looks like you need to configure SIP profile with a valid DID for your provider as explained in the following link

https://supportforums.cisco.com/document/74586/configure-and-troubleshoot-call-forward-pstn-using-sip-trunks

HTH

Manish

 

Hi Manish, As per the

Hi Manish,

 

As per the document, I have added the Diversion Header in the gateway. But no luck. I still see the PAI show external number instead of Carrier DID. Please see my configuration from Gateway:

voice class sip-profiles 100
 request INVITE sip-header Remote-Party-ID modify "sip:(.*)@[172.30.152.24]+\"" "sip:\1@leeds.dieboldemea.globalipcom.com" 
 request INVITE sip-header Remote-Party-ID modify "sip:(.*)@[172.30.152.24]+\"" "sip:\1@london.dieboldemea.globalipcom.com" 
 request INVITE sip-header Diversion modify "<sip:(.*)@(.*)>" "<441133015000@leeds.dieboldemea.globalipcom.com>"

 

External number: +914066164039

Mobility enabled DID where incoming call received - 441133015191

Call suppose to send to Mobile number 900919959470707 with calling number 441133015000, as per the configuration. But it is still sending +914066164039.

 

Need your help in configuring the Service Providers DID under PAI.

Team, Still My incoming calls

Team,

 

Still My incoming calls are not rerouting to my mobile. As per the config, If PSTN Caller +914066164039 call Mobility enabled IP Phone user with DID 441133015191, call has to reroute to my mobile phone +919959470707. I still see external PSTN users calling number +914066164039 under PAI, but not the Verizon's DID 441133015000, though I have configured the diversion header and applied the same under my outgoing dial-peer. Please find the config below:

SIP Profile

voice class sip-profiles 100
 request INVITE sip-header Remote-Party-ID modify "sip:(.*)@[172.30.152.24]+\"" "sip:\1@leeds.dieboldemea.globalipcom.com" 
 request INVITE sip-header Remote-Party-ID modify "sip:(.*)@[172.30.152.24]+\"" "sip:\1@london.dieboldemea.globalipcom.com" 
 request INVITE sip-header Diversion modify "<sip:(.*)@(.*)>" "<441133015000@leeds.dieboldemea.globalipcom.com>" 
!

Outgoing Dial-peer

dial-peer voice 100 voip
 description OUTBOUND G711 Voice SIP calls from London to VzB
 translation-profile outgoing Outgoing-Translate
 destination-pattern 9T
 session protocol sipv2
 session target ipv4:172.30.152.24:5076
 voice-class codec 1  
 voice-class sip early-offer forced
 voice-class sip profiles 100
 dtmf-relay rtp-nte
 no vad

 

In CUCM, under SIP Trunk ->Outbound calls->Under Calling party Selection, I have selected Last Number Redirect and also checked Redirecting Diversion Header Delivery-Outbound.

But I do not see any change in the behavior over SIP debugs.

Need your help on this Issue, as we have tight deadline on customer sign-off.

 

Regards,

Solomon.

Team, Finally I have achieved

Team,

 

Finally I have achieved Enterprise Mobility on Verizon SIP Trunk with out Diversion Header configured under SIP Profile. I have managed this setup, by configuring the Service Providers DID Main Line number 441133015000 under Calling Party Transform Mask of Route List details. 

Now Verizon see calling number for incoming call invite from PSTN User as 441133015000, so they route the call out through our SIP Trunk. But the problem over here is, other outgoing calls also show the same calling-number for outgoing calls. I just want all other calls show their Originated number as their Calling number, when called out. Please let me know how this can be achieved.

 

Thanks in advance,

Solomon.

Rising star

will Verizon validate the

will Verizon validate the Diversion header if PAI is not present? or PAI is must for all calls for them?

//Suresh Please rate all the useful posts.
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards