cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
788
Views
0
Helpful
6
Replies
Aws Al-Dabbagh
Beginner

SIP trunk from CME to 3CX

hi all,IP Telephony and Phones, Unified Communications

 

I have a CME with several IP Phones

I installed a 3CX server for a small team to make outgoing calls.

 

I need to add a SIP trunk between the systems to allow CME users to call 3CX users, as well as use the 3CX to aIP Telephony and Phones, Unified Communicationsllow  CME users to reach outside the 3CX.

 

I found a lot of topics but I couldn't find one about this specific case.

 

please help.

6 REPLIES 6
Chris Deren
Hall of Fame Master

On CME to create a SIP trunk you just create SIP dial-peers pointing to the other side with proper destination defined on them via destination-pattern or e164-map. I cannot speak to 3CX and you would need to refer to their documentation.

thanks for the help so far. after a few days of trying, I got to this config:

!
dial-peer voice 101 voip
description for incoming calls from 3CX
session protocol sipv2
session target ipv4:10.10.30.26
!
dial-peer voice 102 voip
description for outgoing calls to 3CX
destination-pattern 3...
session protocol sipv2
session target ipv4:10.10.30.26
codec g711ulaw
!

and I configured 3CX not to require authentication.

 

this allows calls between CME --> to 3CX and 3CX --> CME

I tried enabling authentication with the config below on my CME:

 

!
dial-peer voice 1 voip
description this is necessary to register with 3CX
destination-pattern 10004
!
!
sip-ua
credentials username 10004 password 7 00554155500E5D realm 3CXPhoneSystem
authentication username 10004 password 7 06575D72181B5F
no remote-party-id
registrar ipv4:10.10.30.26 expires 3600
sip-server ipv4:10.10.30.26
!
!

 

but authentication is not coming up.

 

tried adding the command:

authentication username 10004 password 7 06575D72181B5F

 

in the dial peers 101 and 102. again. again, authentication is rejected.

 

any other suggestions?

Aws Al-Dabbagh
Beginner

OK guys.

I got the bridge Trunk up. now I'm calling 3CX-->CME again. but CME-->3CX gets a busy tone with "407 Proxy Authentication Required".

 

how do I send this Proxy Authentication from the CME?

error packet and CME config below:

 

User Datagram Protocol, Src Port: 5060, Dst Port: 5060
Source Port: 5060
Destination Port: 5060
Length: 424
Checksum: 0x51ed [unverified]
[Checksum Status: Unverified]
[Stream index: 10]
[Timestamps]
Session Initiation Protocol (407)
Status-Line: SIP/2.0 407 Proxy Authentication Required
Status-Code: 407
[Resent Packet: False]
Message Header
Via: SIP/2.0/UDP 10.10.30.6:5060;branch=z9hG4bK27325636
Transport: UDP
Sent-by Address: 10.10.30.6
Sent-by port: 5060
Branch: z9hG4bK27325636
Proxy-Authenticate: Digest nonce="414d53595ddb758811:5f701776b8a7212b0396d47fc6bd8bb9",algorithm=MD5,realm="3CXPhoneSystem"
Authentication Scheme: Digest
Nonce Value: "414d53595ddb758811:5f701776b8a7212b0396d47fc6bd8bb9"
Algorithm: MD5
Realm: "3CXPhoneSystem"
To: <sip:001@10.10.30.26>;tag=06655140
SIP to address: sip:001@10.10.30.26
SIP to address User Part: 001
SIP to address Host Part: 10.10.30.26
SIP to tag: 06655140
From: "IT Dept" <sip:6666@10.10.30.6>;tag=36004104-B7D
SIP Display info: "IT Dept"
SIP from address: sip:6666@10.10.30.6
SIP from address User Part: 6666
SIP from address Host Part: 10.10.30.6
SIP from tag: 36004104-B7D
Call-ID: 2649BF32-E8411EA-982F93E7-E0F7021D@10.10.30.6
[Generated Call-ID: 2649BF32-E8411EA-982F93E7-E0F7021D@10.10.30.6]
CSeq: 101 INVITE
Sequence Number: 101
Method: INVITE
Content-Length: 0

 

CME config:

 


ANK-IT-CME#sh run
Building configuration...


Current configuration : 20358 bytes
!
! Last configuration change at 09:19:38 AST Mon Nov 25 2019 by it.admin
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ANK-IT-CME
!
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.155-1.TT2.bin
boot system flash:c2900-universalk9-mz.SPA.155-1.T2.bin
boot system flash0 c2900-universalk9-mz.SPA.155-1.T2.bin
boot-end-marker
!
!
vrf definition mgmt
!
address-family ipv4
exit-address-family
!
logging buffered 51200 warnings
enable secret 5 $1$eZsc$jBxwGcxPBy/HVtp46267S0
enable password 7 1236562317072C2D1E2A20253A3B
!
no aaa new-model
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
clock timezone AST 3 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
no ip domain lookup
ip domain name o3-telecom.com
ip name-server 93.91.201.207
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-2137408457
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2137408457
revocation-check none
rsakeypair TP-self-signed-2137408457
!
!
crypto pki certificate chain TP-self-signed-2137408457
certificate self-signed 01
<redacted>
voice-card 0
!
!
!
voice service voip
ip address trusted list
ipv4 10.10.30.6
ipv4 10.10.30.6 255.255.255.255
ipv4 10.10.30.26
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server
!
!
!
!
voice dnis-map 18
!
voice register pool-type 7800
xml-config maxNumCalls 4
xml-config busyTrigger 2
xml-config custom sshAccess 0
phoneload-support
num-lines 2
reference-pooltype 6921
!
voice register global
mode cme
source-address 10.10.30.6 port 5060
max-dn 100
max-pool 55
authenticate register
authenticate realm all
timezone 31
tftp-path flash:
file text
create profile sync 018401106451978A
!
voice register dn 1
number 10005
name 10005
no-reg
label Mr. Omar Al-Samarraei
!
voice register dn 2
number 6001
name Khalid Faisal
label Khalid Faisal
!
voice register dn 3
number 6002
name Call Center
label Call Center
!
voice register dn 4
number 6006
name Yacoub Safadi
label Yacoub Safadi
!
voice register dn 5
number 6005
name George
label George
!
voice register dn 6
number 6004
name Hawkar Dawood
label Hawkar Dawood
!
voice register dn 7
number 6017
name Development
label Development
!
voice register dn 8
number 6007
name Dana Yonan
label Dana Yonan
!
voice register dn 9
number 6008
name IPcore
label IPcore
!
voice register dn 10
number 6009
name Hawnaz Mohsen
label Hawnaz Mohsen
!
voice register dn 11
number 6010
name Ahmed Rasheed
label Ahmed Rasheed
!
voice register dn 12
number 6011
name Nahid Najim
label Nahid Najim
!
voice register dn 13
number 6013
name Erbil Showroom
label Erbil Showroom
!
voice register dn 14
number 6014
name Omar AlOmari
label Omar AlOmari
!
voice register dn 15
number 6015
name Omar Ghanim
label Omar Ghanim
!
voice register dn 16
number 6019
name Mahmood Abbasi
label Mahmood Abbasi
!
voice register dn 17
number 6016
name Asal Alasaf
label Asal Alasaf
!
voice register dn 18
number 6024
name Zanner Enwan
label Zanner Enwan
!
voice register dn 19
number 6012
name Shiraz Salih
label Shiraz Salih
!
voice register dn 20
number 6018
name Reception
label Reception
!
voice register dn 21
number 6027
name Procurement
label Procurement
!
voice register dn 22
number 6020
name Brwa Bakhtiyar
label Brwa Bakhtiyar
!
voice register dn 23
number 6021
name Ali Haidar
label Ali Haidar
!
voice register dn 24
number 6022
name Parwa Taha
label Parwa Taha
!
voice register dn 25
number 6023
name Muhammed Zakriya
label Muhammed Zakriya
!
voice register dn 26
number 6033
name Mais Muhammed
label Mais Muhammed
!
voice register dn 27
number 6025
name Mariwan Omer
label Mariwan Omer
!
voice register dn 28
number 6026
name Bihist Nazar
label Bihist Nazar
!
voice register dn 29
number 6034
name Mustafa Qais
label Mustafa Qais
!
voice register dn 30
number 6028
name Vinwar Ali
label Vinwar Ali
!
voice register dn 31
number 6029
name Evan Bahnam
label Evan Bahnam
!
voice register dn 32
number 6030
name Nazlin Ali
label Nazlin Ali
!
voice register dn 33
number 6031
name Manar Salih
label Manar Salih
!
voice register dn 34
number 6032
name Ayat Dored
label Ayat Dored
!
voice register dn 35
number 6035
name HR Gazna
label HR Gazna
!
voice register dn 36
number 6060
name Kitchen
label Kitchen
!
voice register dn 37
number 6037
name Design Team
label Design Team
!
voice register dn 38
number 10004
name 10004
!
voice register dn 39
number 6038
name Duhok Showroom 2
label Duhok Showroom 2
!
voice register dn 42
number 6666
name IT Dept
label IT Dept
!
voice register dn 43
number 6050
name O3-Meeting Room
label O3-Meeting Room
!
voice register dn 44
number 6070
name Alan Zangana
label Alan Zangana
!
voice register dn 45
number 6066
name Zainab Kanbaragha
label Zainab Kanbaragha
!
voice register dn 47
number 6041
name Martin Peter
label Martin Peter
!
voice register dn 49
number 6003
name Govand Hamaswr
label Govand Hamaswr
!
voice register dn 50
number 6044
name Wasan Behnam
label Wasan Behnam
!
voice register dn 51
number 6045
name Govan Omer
label Govan Omer
!
voice register pool 1
busy-trigger-per-button 2
id mac 9C57.ADB4.B4DE
type 7821
number 1 dn 1
dtmf-relay rtp-nte
username abc password 12345
codec g711ulaw
!
voice register pool 2
busy-trigger-per-button 2
id mac 9C57.ADB4.A466
type 7821
number 1 dn 2
dtmf-relay rtp-nte
username aaa password 12345
codec g711ulaw
!
voice register pool 3
busy-trigger-per-button 2
id mac DCCE.C1D4.B090
type 7821
number 1 dn 3
dtmf-relay rtp-nte
username q1w password 12345
codec g711ulaw
!
voice register pool 4
busy-trigger-per-button 2
id mac 9C57.ADB4.B601
type 7821
number 1 dn 4
dtmf-relay rtp-nte
username ytg password 12345
codec g711ulaw
!
voice register pool 5
busy-trigger-per-button 2
id mac 006C.BCA9.AA18
type 7821
number 1 dn 5
dtmf-relay rtp-nte
username George password 12345
codec g711ulaw
!
voice register pool 6
busy-trigger-per-button 2
id mac 9C57.ADB4.B5FF
type 7821
number 1 dn 6
dtmf-relay rtp-nte
username hr password 12345
codec g711ulaw
!
voice register pool 7
busy-trigger-per-button 2
id mac 006C.BCA9.AB2A
type 7821
number 1 dn 7
dtmf-relay rtp-nte
username jui password 12345
codec g711ulaw
!
voice register pool 8
busy-trigger-per-button 2
id mac 9C57.ADB4.B4E1
type 7821
number 1 dn 8
dtmf-relay rtp-nte
username lfr password 12345
codec g711ulaw
!
voice register pool 9
busy-trigger-per-button 2
id mac 006C.BCA8.1C20
type 7821
number 1 dn 9
dtmf-relay rtp-nte
username kjn password 12345
codec g711ulaw
!
voice register pool 10
busy-trigger-per-button 2
id mac 9C57.ADB4.A2D6
type 7821
number 1 dn 10
dtmf-relay rtp-nte
username hnf password 12345
codec g711ulaw
!
voice register pool 11
busy-trigger-per-button 2
id mac 9C57.ADB4.B540
type 7821
number 1 dn 11
dtmf-relay rtp-nte
username asw password 12345
codec g711ulaw
!
voice register pool 12
busy-trigger-per-button 2
id mac 006C.BCA8.1C23
type 7821
number 1 dn 12
dtmf-relay rtp-nte
username kiu password 12345
codec g711ulaw
!
voice register pool 13
busy-trigger-per-button 2
id mac 006C.BCA9.AA3B
type 7821
number 1 dn 13
dtmf-relay rtp-nte
username svb password 12345
codec g711ulaw
!
voice register pool 14
busy-trigger-per-button 2
id mac 006C.BCA9.AA1B
type 7821
number 1 dn 14
dtmf-relay rtp-nte
username Omed password 12345
codec g711ulaw
!
voice register pool 15
busy-trigger-per-button 2
id mac 006C.BCA9.AB57
type 7821
number 1 dn 15
dtmf-relay rtp-nte
username Omar password 12345
codec g711ulaw
!
voice register pool 16
busy-trigger-per-button 2
id mac 006C.BCA9.AB23
type 7821
number 1 dn 16
dtmf-relay rtp-nte
username Oma password 12345
codec g711ulaw
!
voice register pool 17
busy-trigger-per-button 2
id mac 006C.BCA9.AA05
type 7821
number 1 dn 17
dtmf-relay rtp-nte
username pol password 12345
codec g711ulaw
!
voice register pool 18
busy-trigger-per-button 2
id mac 006C.BCA9.AB31
type 7821
number 1 dn 18
dtmf-relay rtp-nte
username zan password 12345
codec g711ulaw
!
voice register pool 19
busy-trigger-per-button 2
id mac 006C.BCA9.AD0E
type 7821
number 1 dn 19
dtmf-relay rtp-nte
username she password 12345
codec g711ulaw
!
voice register pool 20
busy-trigger-per-button 2
id mac 006C.BCA9.ABB4
type 7821
number 1 dn 20
dtmf-relay rtp-nte
username rcb password 12345
codec g711ulaw
!
voice register pool 21
busy-trigger-per-button 2
id mac 006C.BCA9.AB54
type 7821
number 1 dn 21
dtmf-relay rtp-nte
username aqeel password 12345
codec g711ulaw
!
voice register pool 22
busy-trigger-per-button 2
id mac 006C.BCA9.AB5D
type 7821
number 1 dn 22
dtmf-relay rtp-nte
username hha password 12345
codec g711ulaw
!
voice register pool 23
busy-trigger-per-button 2
id mac 006C.BCA9.AD45
type 7821
number 1 dn 23
dtmf-relay rtp-nte
username wnz password 12345
codec g711ulaw
!
voice register pool 24
busy-trigger-per-button 2
id mac 006C.BCA9.AB56
type 7821
number 1 dn 24
dtmf-relay rtp-nte
username wal password 12345
codec g711ulaw
!
voice register pool 25
busy-trigger-per-button 2
id mac 006C.BCA9.AB53
type 7821
number 1 dn 25
dtmf-relay rtp-nte
username lel password 12345
codec g711ulaw
!
voice register pool 26
busy-trigger-per-button 2
id mac 006C.BCA9.A9E2
type 7821
number 1 dn 26
dtmf-relay rtp-nte
username Mais password 12345
codec g711ulaw
!
voice register pool 27
busy-trigger-per-button 2
id mac 006C.BCA9.AB30
type 7821
number 1 dn 27
dtmf-relay rtp-nte
username klq password 12345
codec g711ulaw
!
voice register pool 28
busy-trigger-per-button 2
id mac 006C.BCA9.AFA7
type 7821
number 1 dn 28
dtmf-relay rtp-nte
username wwc password 12345
codec g711ulaw
!
voice register pool 29
busy-trigger-per-button 2
id mac 9C57.ADB4.A10B
type 7821
number 1 dn 29
dtmf-relay rtp-nte
username Mustafa password 12345
codec g711ulaw
!
voice register pool 30
busy-trigger-per-button 2
id mac 006C.BCA9.AB15
type 7821
number 1 dn 30
dtmf-relay rtp-nte
username olq password 12345
codec g711ulaw
!
voice register pool 31
busy-trigger-per-button 2
id mac 9C57.ADB4.B4EE
type 7821
number 1 dn 31
dtmf-relay rtp-nte
username evan password 12345
codec g711ulaw
!
voice register pool 32
busy-trigger-per-button 2
id mac 006C.BCA9.AB1F
type 7821
number 1 dn 32
dtmf-relay rtp-nte
username plr password 12345
codec g711ulaw
!
voice register pool 33
busy-trigger-per-button 2
id mac 006C.BCA9.AB59
type 7821
number 1 dn 33
dtmf-relay rtp-nte
username oww password 12345
codec g711ulaw
!
voice register pool 34
busy-trigger-per-button 2
id mac 006C.BCA9.AB13
type 7821
number 1 dn 34
dtmf-relay rtp-nte
username ybp password 12345
codec g711ulaw
!
voice register pool 35
busy-trigger-per-button 2
id mac 006C.BCA9.AB32
type 7821
number 1 dn 35
dtmf-relay rtp-nte
username earth password 12345
codec g711ulaw
!
voice register pool 36
busy-trigger-per-button 2
id mac 006C.BCA9.AB0E
type 7821
number 1 dn 36
dtmf-relay rtp-nte
username haifa password 12345
codec g711ulaw
!
voice register pool 37
busy-trigger-per-button 2
id mac 006C.BCA9.AB27
type 7821
number 1 dn 37
dtmf-relay rtp-nte
username des password 12345
codec g711ulaw
!
voice register pool 38
id mac 0015.5D6F.656B
number 1 dn 1
dtmf-relay rtp-nte
username 10005 password 123456
codec g711ulaw
!
voice register pool 39
busy-trigger-per-button 2
id mac 006C.BCA9.AB95
type 7821
number 1 dn 39
dtmf-relay rtp-nte
username test2 password 12345
codec g711ulaw
!
voice register pool 42
busy-trigger-per-button 2
id mac 9C57.ADB4.A0F9
type 7821
number 1 dn 42
dtmf-relay rtp-nte
username IIT password 12345
codec g711ulaw
!
voice register pool 43
busy-trigger-per-button 2
id mac 9C57.ADB4.B62F
type 7821
number 1 dn 43
dtmf-relay rtp-nte
username room password 12345
codec g711ulaw
!
voice register pool 44
busy-trigger-per-button 2
id mac 9C57.ADB4.A29B
type 7821
number 1 dn 44
dtmf-relay rtp-nte
username hasa password 12345
codec g711ulaw
!
voice register pool 45
busy-trigger-per-button 2
id mac 9C57.ADB4.A287
type 7821
number 1 dn 45
dtmf-relay rtp-nte
username omar password 12345
codec g711ulaw
!
voice register pool 47
busy-trigger-per-button 2
id mac 9C57.ADB4.A107
type 7821
number 1 dn 47
dtmf-relay rtp-nte
username Martin password 12345
codec g711ulaw
!
voice register pool 49
busy-trigger-per-button 2
id mac 006C.BCA9.AA1E
type 7821
number 1 dn 49
dtmf-relay rtp-nte
username Shiraz password 12345
codec g711ulaw
!
voice register pool 50
busy-trigger-per-button 2
id mac 006C.BCA8.1C44
type 7821
number 1 dn 50
dtmf-relay rtp-nte
username Wasan password 12345
codec g711ulaw
!
voice register pool 51
busy-trigger-per-button 2
id mac 006C.BCA9.AB4F
type 7821
number 1 dn 51
dtmf-relay rtp-nte
username Govan password 12345
codec g711ulaw
!
!
!
voice translation-rule 1
rule 1 /^.*\(...\)/ /\1/
!
!
voice translation-profile profile1
translate called 1
!
!
!
license udi pid CISCO2911/K9 sn FGL2015124V
license boot module c2900 technology-package datak9
hw-module pvdm 0/0
!
!
!
username it.admin password 7 032D6F0A020228426E264A31121E
username 10005 password 7 135445415F59526A
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0.5
description MGMT-Interface
encapsulation dot1Q 5
vrf forwarding mgmt
ip address 10.10.5.7 255.255.255.0
!
interface GigabitEthernet0/0.31
description connected to ANK-IT-CoreSwitch
encapsulation dot1Q 31
ip address 10.10.30.6 255.255.255.252
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.10.30.6
!
interface GigabitEthernet0/1
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.10.30.5
ip route 10.10.22.0 255.255.255.0 10.10.30.5
ip route 10.10.56.0 255.255.255.128 10.10.30.5
ip route 10.100.92.0 255.255.255.0 10.10.30.5
ip route 10.100.95.0 255.255.255.0 10.10.30.5
ip route 192.168.200.0 255.255.255.252 10.10.30.5
ip route vrf mgmt 0.0.0.0 0.0.0.0 10.10.5.1
!
!
!
snmp-server community CMEv2c RO
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps ccme
snmp-server enable traps srst
snmp-server enable traps voice
snmp-server host 10.10.111.111 version 2c CMEv2c voice
tftp-server flash:kern2.78xx.11-0-1-11.sbn
tftp-server flash:kern78xx.11-0-1-11.sbn
tftp-server flash:rootfs2.78xx.11-0-1-11.sbn
tftp-server flash:rootfs78xx.11-0-1-11.sbn
tftp-server flash:sboot2.78xx.11-0-1-11.sbn
tftp-server flash:sboot78xx.11-0-1-11.sbn
tftp-server flash:sip78xx.11-0-1-11.loads
!
control-plane
!
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 voip
description this is necessary to register with 3CX
destination-pattern 10005
session target ipv4:10.10.30.26:5060
authentication username 10005 password 7 135445415F5952
!
dial-peer voice 102 voip
description for outgoing calls to 3CX
translation-profile outgoing profile1
destination-pattern 3...
translate-outgoing calling 1
translate-outgoing called 1
session protocol sipv2
session target ipv4:10.10.30.26
codec g711ulaw
authentication username 10005 password 7 101F5B4A514244
!
dial-peer voice 101 voip
description for incoming calls from 3CX
session protocol sipv2
session target ipv4:10.10.30.26:5060
!
!
sip-ua
credentials username 10005 password 7 135445415F5952 realm all
authentication username 10005 password 7 040A59555B741A
authentication username 10005 password 7 06575D72181B5F realm all
!
!
!
gatekeeper
shutdown
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE PUBLICLY-KNOWN
CREDENTIALS

Here are the Cisco IOS commands.

username <myuser> privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
password 7 072072784B05392C23130F010D24
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
password 7 1236562317072C2D1E2A20253A3B
logging synchronous
login local
transport input ssh
line vty 5 15
privilege level 15
password 7 10615A2D001B322238052E262D26
logging synchronous
login local
transport input ssh
line vty 16 1114
password 7 10615A2D001B322238052E262D26
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp server 62.201.225.9
ntp server time-a.nist.gov
ntp server iq.pool.ntp.org
ntp server 0.tr.pool.ntp.org
!
end


ANK-IT-CME#sh run
Building configuration...


Current configuration : 20358 bytes
!
! Last configuration change at 09:19:38 AST Mon Nov 25 2019 by it.admin
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ANK-IT-CME
!
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.155-1.TT2.bin
boot system flash:c2900-universalk9-mz.SPA.155-1.T2.bin
boot system flash0 c2900-universalk9-mz.SPA.155-1.T2.bin
boot-end-marker
!
!
vrf definition mgmt
!
address-family ipv4
exit-address-family
!
logging buffered 51200 warnings
enable secret 5 $1$eZsc$jBxwGcxPBy/HVtp46267S0
enable password 7 1236562317072C2D1E2A20253A3B
!
no aaa new-model
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
clock timezone AST 3 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
no ip domain lookup
ip domain name o3-telecom.com
ip name-server 93.91.201.207
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-2137408457
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2137408457
revocation-check none
rsakeypair TP-self-signed-2137408457
!
!
crypto pki certificate chain TP-self-signed-2137408457
certificate self-signed 01
<redacted>
voice-card 0
!
!
!
voice service voip
ip address trusted list
ipv4 10.10.30.6
ipv4 10.10.30.6 255.255.255.255
ipv4 10.10.30.26
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server
!
!
!
!
voice dnis-map 18
!
voice register pool-type 7800
xml-config maxNumCalls 4
xml-config busyTrigger 2
xml-config custom sshAccess 0
phoneload-support
num-lines 2
reference-pooltype 6921
!
voice register global
mode cme
source-address 10.10.30.6 port 5060
max-dn 100
max-pool 55
authenticate register
authenticate realm all
timezone 31
tftp-path flash:
file text
create profile sync 018401106451978A
!
voice register dn 1
number 10005
name 10005
no-reg
label Mr. Omar Al-Samarraei
!
voice register dn 2
number 6001
name Khalid Faisal
label Khalid Faisal
!
voice register dn 3
number 6002
name Call Center
label Call Center
!
voice register dn 4
number 6006
name Yacoub Safadi
label Yacoub Safadi
!
voice register dn 5
number 6005
name George
label George
!
voice register dn 6
number 6004
name Hawkar Dawood
label Hawkar Dawood
!
voice register dn 7
number 6017
name Development
label Development
!
voice register dn 8
number 6007
name Dana Yonan
label Dana Yonan
!
voice register dn 9
number 6008
name IPcore
label IPcore
!
voice register dn 10
number 6009
name Hawnaz Mohsen
label Hawnaz Mohsen
!
voice register dn 11
number 6010
name Ahmed Rasheed
label Ahmed Rasheed
!
voice register dn 12
number 6011
name Nahid Najim
label Nahid Najim
!
voice register dn 13
number 6013
name Erbil Showroom
label Erbil Showroom
!
voice register dn 14
number 6014
name Omar AlOmari
label Omar AlOmari
!
voice register dn 15
number 6015
name Omar Ghanim
label Omar Ghanim
!
voice register dn 16
number 6019
name Mahmood Abbasi
label Mahmood Abbasi
!
voice register dn 17
number 6016
name Asal Alasaf
label Asal Alasaf
!
voice register dn 18
number 6024
name Zanner Enwan
label Zanner Enwan
!
voice register dn 19
number 6012
name Shiraz Salih
label Shiraz Salih
!
voice register dn 20
number 6018
name Reception
label Reception
!
voice register dn 21
number 6027
name Procurement
label Procurement
!
voice register dn 22
number 6020
name Brwa Bakhtiyar
label Brwa Bakhtiyar
!
voice register dn 23
number 6021
name Ali Haidar
label Ali Haidar
!
voice register dn 24
number 6022
name Parwa Taha
label Parwa Taha
!
voice register dn 25
number 6023
name Muhammed Zakriya
label Muhammed Zakriya
!
voice register dn 26
number 6033
name Mais Muhammed
label Mais Muhammed
!
voice register dn 27
number 6025
name Mariwan Omer
label Mariwan Omer
!
voice register dn 28
number 6026
name Bihist Nazar
label Bihist Nazar
!
voice register dn 29
number 6034
name Mustafa Qais
label Mustafa Qais
!
voice register dn 30
number 6028
name Vinwar Ali
label Vinwar Ali
!
voice register dn 31
number 6029
name Evan Bahnam
label Evan Bahnam
!
voice register dn 32
number 6030
name Nazlin Ali
label Nazlin Ali
!
voice register dn 33
number 6031
name Manar Salih
label Manar Salih
!
voice register dn 34
number 6032
name Ayat Dored
label Ayat Dored
!
voice register dn 35
number 6035
name HR Gazna
label HR Gazna
!
voice register dn 36
number 6060
name Kitchen
label Kitchen
!
voice register dn 37
number 6037
name Design Team
label Design Team
!
voice register dn 38
number 10004
name 10004
!
voice register dn 39
number 6038
name Duhok Showroom 2
label Duhok Showroom 2
!
voice register dn 42
number 6666
name IT Dept
label IT Dept
!
voice register dn 43
number 6050
name O3-Meeting Room
label O3-Meeting Room
!
voice register dn 44
number 6070
name Alan Zangana
label Alan Zangana
!
voice register dn 45
number 6066
name Zainab Kanbaragha
label Zainab Kanbaragha
!
voice register dn 47
number 6041
name Martin Peter
label Martin Peter
!
voice register dn 49
number 6003
name Govand Hamaswr
label Govand Hamaswr
!
voice register dn 50
number 6044
name Wasan Behnam
label Wasan Behnam
!
voice register dn 51
number 6045
name Govan Omer
label Govan Omer
!
voice register pool 1
busy-trigger-per-button 2
id mac 9C57.ADB4.B4DE
type 7821
number 1 dn 1
dtmf-relay rtp-nte
username abc password 12345
codec g711ulaw
!
voice register pool 2
busy-trigger-per-button 2
id mac 9C57.ADB4.A466
type 7821
number 1 dn 2
dtmf-relay rtp-nte
username aaa password 12345
codec g711ulaw
!
voice register pool 3
busy-trigger-per-button 2
id mac DCCE.C1D4.B090
type 7821
number 1 dn 3
dtmf-relay rtp-nte
username q1w password 12345
codec g711ulaw
!
voice register pool 4
busy-trigger-per-button 2
id mac 9C57.ADB4.B601
type 7821
number 1 dn 4
dtmf-relay rtp-nte
username ytg password 12345
codec g711ulaw
!
voice register pool 5
busy-trigger-per-button 2
id mac 006C.BCA9.AA18
type 7821
number 1 dn 5
dtmf-relay rtp-nte
username George password 12345
codec g711ulaw
!
voice register pool 6
busy-trigger-per-button 2
id mac 9C57.ADB4.B5FF
type 7821
number 1 dn 6
dtmf-relay rtp-nte
username hr password 12345
codec g711ulaw
!
voice register pool 7
busy-trigger-per-button 2
id mac 006C.BCA9.AB2A
type 7821
number 1 dn 7
dtmf-relay rtp-nte
username jui password 12345
codec g711ulaw
!
voice register pool 8
busy-trigger-per-button 2
id mac 9C57.ADB4.B4E1
type 7821
number 1 dn 8
dtmf-relay rtp-nte
username lfr password 12345
codec g711ulaw
!
voice register pool 9
busy-trigger-per-button 2
id mac 006C.BCA8.1C20
type 7821
number 1 dn 9
dtmf-relay rtp-nte
username kjn password 12345
codec g711ulaw
!
voice register pool 10
busy-trigger-per-button 2
id mac 9C57.ADB4.A2D6
type 7821
number 1 dn 10
dtmf-relay rtp-nte
username hnf password 12345
codec g711ulaw
!
voice register pool 11
busy-trigger-per-button 2
id mac 9C57.ADB4.B540
type 7821
number 1 dn 11
dtmf-relay rtp-nte
username asw password 12345
codec g711ulaw
!
voice register pool 12
busy-trigger-per-button 2
id mac 006C.BCA8.1C23
type 7821
number 1 dn 12
dtmf-relay rtp-nte
username kiu password 12345
codec g711ulaw
!
voice register pool 13
busy-trigger-per-button 2
id mac 006C.BCA9.AA3B
type 7821
number 1 dn 13
dtmf-relay rtp-nte
username svb password 12345
codec g711ulaw
!
voice register pool 14
busy-trigger-per-button 2
id mac 006C.BCA9.AA1B
type 7821
number 1 dn 14
dtmf-relay rtp-nte
username Omed password 12345
codec g711ulaw
!
voice register pool 15
busy-trigger-per-button 2
id mac 006C.BCA9.AB57
type 7821
number 1 dn 15
dtmf-relay rtp-nte
username Omar password 12345
codec g711ulaw
!
voice register pool 16
busy-trigger-per-button 2
id mac 006C.BCA9.AB23
type 7821
number 1 dn 16
dtmf-relay rtp-nte
username Oma password 12345
codec g711ulaw
!
voice register pool 17
busy-trigger-per-button 2
id mac 006C.BCA9.AA05
type 7821
number 1 dn 17
dtmf-relay rtp-nte
username pol password 12345
codec g711ulaw
!
voice register pool 18
busy-trigger-per-button 2
id mac 006C.BCA9.AB31
type 7821
number 1 dn 18
dtmf-relay rtp-nte
username zan password 12345
codec g711ulaw
!
voice register pool 19
busy-trigger-per-button 2
id mac 006C.BCA9.AD0E
type 7821
number 1 dn 19
dtmf-relay rtp-nte
username she password 12345
codec g711ulaw
!
voice register pool 20
busy-trigger-per-button 2
id mac 006C.BCA9.ABB4
type 7821
number 1 dn 20
dtmf-relay rtp-nte
username rcb password 12345
codec g711ulaw
!
voice register pool 21
busy-trigger-per-button 2
id mac 006C.BCA9.AB54
type 7821
number 1 dn 21
dtmf-relay rtp-nte
username aqeel password 12345
codec g711ulaw
!
voice register pool 22
busy-trigger-per-button 2
id mac 006C.BCA9.AB5D
type 7821
number 1 dn 22
dtmf-relay rtp-nte
username hha password 12345
codec g711ulaw
!
voice register pool 23
busy-trigger-per-button 2
id mac 006C.BCA9.AD45
type 7821
number 1 dn 23
dtmf-relay rtp-nte
username wnz password 12345
codec g711ulaw
!
voice register pool 24
busy-trigger-per-button 2
id mac 006C.BCA9.AB56
type 7821
number 1 dn 24
dtmf-relay rtp-nte
username wal password 12345
codec g711ulaw
!
voice register pool 25
busy-trigger-per-button 2
id mac 006C.BCA9.AB53
type 7821
number 1 dn 25
dtmf-relay rtp-nte
username lel password 12345
codec g711ulaw
!
voice register pool 26
busy-trigger-per-button 2
id mac 006C.BCA9.A9E2
type 7821
number 1 dn 26
dtmf-relay rtp-nte
username Mais password 12345
codec g711ulaw
!
voice register pool 27
busy-trigger-per-button 2
id mac 006C.BCA9.AB30
type 7821
number 1 dn 27
dtmf-relay rtp-nte
username klq password 12345
codec g711ulaw
!
voice register pool 28
busy-trigger-per-button 2
id mac 006C.BCA9.AFA7
type 7821
number 1 dn 28
dtmf-relay rtp-nte
username wwc password 12345
codec g711ulaw
!
voice register pool 29
busy-trigger-per-button 2
id mac 9C57.ADB4.A10B
type 7821
number 1 dn 29
dtmf-relay rtp-nte
username Mustafa password 12345
codec g711ulaw
!
voice register pool 30
busy-trigger-per-button 2
id mac 006C.BCA9.AB15
type 7821
number 1 dn 30
dtmf-relay rtp-nte
username olq password 12345
codec g711ulaw
!
voice register pool 31
busy-trigger-per-button 2
id mac 9C57.ADB4.B4EE
type 7821
number 1 dn 31
dtmf-relay rtp-nte
username evan password 12345
codec g711ulaw
!
voice register pool 32
busy-trigger-per-button 2
id mac 006C.BCA9.AB1F
type 7821
number 1 dn 32
dtmf-relay rtp-nte
username plr password 12345
codec g711ulaw
!
voice register pool 33
busy-trigger-per-button 2
id mac 006C.BCA9.AB59
type 7821
number 1 dn 33
dtmf-relay rtp-nte
username oww password 12345
codec g711ulaw
!
voice register pool 34
busy-trigger-per-button 2
id mac 006C.BCA9.AB13
type 7821
number 1 dn 34
dtmf-relay rtp-nte
username ybp password 12345
codec g711ulaw
!
voice register pool 35
busy-trigger-per-button 2
id mac 006C.BCA9.AB32
type 7821
number 1 dn 35
dtmf-relay rtp-nte
username earth password 12345
codec g711ulaw
!
voice register pool 36
busy-trigger-per-button 2
id mac 006C.BCA9.AB0E
type 7821
number 1 dn 36
dtmf-relay rtp-nte
username haifa password 12345
codec g711ulaw
!
voice register pool 37
busy-trigger-per-button 2
id mac 006C.BCA9.AB27
type 7821
number 1 dn 37
dtmf-relay rtp-nte
username des password 12345
codec g711ulaw
!
voice register pool 38
id mac 0015.5D6F.656B
number 1 dn 1
dtmf-relay rtp-nte
username 10005 password 123456
codec g711ulaw
!
voice register pool 39
busy-trigger-per-button 2
id mac 006C.BCA9.AB95
type 7821
number 1 dn 39
dtmf-relay rtp-nte
username test2 password 12345
codec g711ulaw
!
voice register pool 42
busy-trigger-per-button 2
id mac 9C57.ADB4.A0F9
type 7821
number 1 dn 42
dtmf-relay rtp-nte
username IIT password 12345
codec g711ulaw
!
voice register pool 43
busy-trigger-per-button 2
id mac 9C57.ADB4.B62F
type 7821
number 1 dn 43
dtmf-relay rtp-nte
username room password 12345
codec g711ulaw
!
voice register pool 44
busy-trigger-per-button 2
id mac 9C57.ADB4.A29B
type 7821
number 1 dn 44
dtmf-relay rtp-nte
username hasa password 12345
codec g711ulaw
!
voice register pool 45
busy-trigger-per-button 2
id mac 9C57.ADB4.A287
type 7821
number 1 dn 45
dtmf-relay rtp-nte
username omar password 12345
codec g711ulaw
!
voice register pool 47
busy-trigger-per-button 2
id mac 9C57.ADB4.A107
type 7821
number 1 dn 47
dtmf-relay rtp-nte
username Martin password 12345
codec g711ulaw
!
voice register pool 49
busy-trigger-per-button 2
id mac 006C.BCA9.AA1E
type 7821
number 1 dn 49
dtmf-relay rtp-nte
username Shiraz password 12345
codec g711ulaw
!
voice register pool 50
busy-trigger-per-button 2
id mac 006C.BCA8.1C44
type 7821
number 1 dn 50
dtmf-relay rtp-nte
username Wasan password 12345
codec g711ulaw
!
voice register pool 51
busy-trigger-per-button 2
id mac 006C.BCA9.AB4F
type 7821
number 1 dn 51
dtmf-relay rtp-nte
username Govan password 12345
codec g711ulaw
!
!
!
voice translation-rule 1
rule 1 /^.*\(...\)/ /\1/
!
!
voice translation-profile profile1
translate called 1
!
!
!
license udi pid CISCO2911/K9 sn FGL2015124V
license boot module c2900 technology-package datak9
hw-module pvdm 0/0
!
!
!
username it.admin password 7 032D6F0A020228426E264A31121E
username 10005 password 7 135445415F59526A
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0.5
description MGMT-Interface
encapsulation dot1Q 5
vrf forwarding mgmt
ip address 10.10.5.7 255.255.255.0
!
interface GigabitEthernet0/0.31
description connected to ANK-IT-CoreSwitch
encapsulation dot1Q 31
ip address 10.10.30.6 255.255.255.252
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.10.30.6
!
interface GigabitEthernet0/1
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
ip virtual-reassembly in
duplex auto
speed auto
!
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.10.30.5
ip route 10.10.22.0 255.255.255.0 10.10.30.5
ip route 10.10.56.0 255.255.255.128 10.10.30.5
ip route 10.100.92.0 255.255.255.0 10.10.30.5
ip route 10.100.95.0 255.255.255.0 10.10.30.5
ip route 192.168.200.0 255.255.255.252 10.10.30.5
ip route vrf mgmt 0.0.0.0 0.0.0.0 10.10.5.1
!
!
!
snmp-server community CMEv2c RO
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps ccme
snmp-server enable traps srst
snmp-server enable traps voice
snmp-server host 10.10.111.111 version 2c CMEv2c voice
tftp-server flash:kern2.78xx.11-0-1-11.sbn
tftp-server flash:kern78xx.11-0-1-11.sbn
tftp-server flash:rootfs2.78xx.11-0-1-11.sbn
tftp-server flash:rootfs78xx.11-0-1-11.sbn
tftp-server flash:sboot2.78xx.11-0-1-11.sbn
tftp-server flash:sboot78xx.11-0-1-11.sbn
tftp-server flash:sip78xx.11-0-1-11.loads
!
control-plane
!
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 voip
description this is necessary to register with 3CX
destination-pattern 10005
session target ipv4:10.10.30.26:5060
authentication username 10005 password 7 135445415F5952
!
dial-peer voice 102 voip
description for outgoing calls to 3CX
translation-profile outgoing profile1
destination-pattern 3...
translate-outgoing calling 1
translate-outgoing called 1
session protocol sipv2
session target ipv4:10.10.30.26
codec g711ulaw
authentication username 10005 password 7 101F5B4A514244
!
dial-peer voice 101 voip
description for incoming calls from 3CX
session protocol sipv2
session target ipv4:10.10.30.26:5060
!
!
sip-ua
credentials username 10005 password 7 135445415F5952 realm all
authentication username 10005 password 7 040A59555B741A
authentication username 10005 password 7 06575D72181B5F realm all
!
!
!
gatekeeper
shutdown
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE PUBLICLY-KNOWN
CREDENTIALS

Here are the Cisco IOS commands.

username <myuser> privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
password 7 072072784B05392C23130F010D24
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
password 7 1236562317072C2D1E2A20253A3B
logging synchronous
login local
transport input ssh
line vty 5 15
privilege level 15
password 7 10615A2D001B322238052E262D26
logging synchronous
login local
transport input ssh
line vty 16 1114
password 7 10615A2D001B322238052E262D26
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp server 62.201.225.9
ntp server time-a.nist.gov
ntp server iq.pool.ntp.org
ntp server 0.tr.pool.ntp.org
!
end

 

Did you see any debug log when making calls from 3CX to CME?

 

debug voice ccapi inout

 


@wkyuen.ricky1 wrote:

Did you see any debug log when making calls from 3CX to CME?

 

debug voice ccapi inout


thanks for replying. no output on this debug command when making or receiving calls.

 

I'm getting the messages by running tcpdump (set to UDP) on the remote PBX (3CX on a Debian server).

thanks for all the replies:

 

the latest update is:

 

3CX--> CME is working

CME-->3CX getting busy tone

 

no logs on "debug ccsip message" nor on "debug ccsip non-call"

 

3CX keeps sending SIP error "407 Proxy authentication required" for any call INVITE sent. that is based on Packet Capture from 3CX server. which means the calls are reaching the 3CX server.

 

how do I get the CME to send authentication?

 

Content for Community-Ad

Spotlight Awards 2021