cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

310
Views
0
Helpful
4
Replies
m.kieffer
Beginner

SNR using FXO and SIP Trunk

I am having an issue with SNR (to cell phone) when an external caller calls in via POTS (FXO) the call is directed to a hunt group, all the extensions ring and the call is received on my cell phone. When I try to answer the call the call does not connect and drops immediately, the other phones in the hunt group keep ringing.

 

Call flow - Inbound

PSTN (FXO) > Gateway 2851 (SIP) > CUCM

 

Call flow - Outbound

CUCM > Gateway 2851 (SIP) > SIP Trunk Provider

 

I've tried the following:

  • Calling the users extension that SNR is enabled for and SNR is working fine. I can answer the call on my cell phone, and move it back to my desk phone.
  • Call the hunt group DN that the external POTS line uses and I can  I can answer the call on my cell phone, and move it back to my desk phone.
  • Changed the FXO port on the gateway to the DN where SNR is enabled and the same problem exists.

 

I've gathered some packet captures from the firewall between the Gateway and the SIP trunk provider and found that the SIP invite appears to contain the wrong source number so I am assuming the provider is rejecting the call.

 

Here is an example of an internal extension calling the hunt pilot dn (1075) - This call is successful

The from sip: ending in 01 is the DID Number that is provided by the SIP provider. The To sip: ending in 44 is my cell phone numberinternal_to_hunt_dn.jpg

 

Here is an example of an external caller, calling inbound on the FXO port and hitting the hunt DN (1075) - This call fails

external_to_hunt_dn.jpg

 

The From sip: ending in 01 is the DID Number that is provided by the SIP provider. The To sip: ending in 44 is my cell phone number

The second line the from sip: ending in 04 is the external caller and the To sip:  is the hunt DN which appears to be why the SIP trunk provider is rejecting the call.

 

After much searching I found this https://community.cisco.com/t5/collaboration-voice-and-video/configure-and-troubleshoot-call-forward-to-the-pstn-using-sip/ta-p/3118287 which indicates we can use the P-Asserted-Identity to resolve this. (The SIP trunk provider confirmed they do support P-Asserted_Identity)

 

After adding this to the outbound sip dial-peer I see that the P-Asserted-Identity is showing up but it doesn’t change the To sip field it still stays as the hunt pilot DN

 

This is and older environment CUCM is 8.6.2 and the gateway is a 2851. but tis what I have in the lab right now.

4 REPLIES 4
Roger Kallberg
VIP Advisor

Adding P-Asserted Identity header to the SIP header will not change the To header. It’s expected that the ITSP should let the call pass if the PAI has a valid number from the assigned range even if the To field contains an out of range number. Can you share the configuration you’ve made for adding PAI to the SIP header?



Response Signature


voice class sip-profiles 1
request INVITE sip-header P-Asserted-Identity add "P-Asserted-Identity:<sip:mydidnumber@toronto.voip.ms>"

 

dial-peer voice 6 voip
voice-class sip profiles 1

Here's the invite from the packet capture as well: 

INVITE sip:mycell@toronto4.voip.ms:5060 SIP/2.0
Via: SIP/2.0/UDP X.X.4.2:5060;branch=z9hG4bKE23895
From: <sip:mydid@X.X.4.2>;tag=196B9220-251C
To: <sip:mycell@toronto4.voip.ms>
Date: Sun, 24 May 2020 22:00:46 GMT
Call-ID: DAA441B7-9D4011EA-80F189D2-A958FA7F@10.0.4.2
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE: 1800
Cisco-Guid: 0054471168-0000065536-0000000042-0168034314
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1590357646
Contact: <sip:mydid@X.X.4.2:5060>
Call-Info: <sip: .4.2:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Expires: 180
Allow-Events: kpml, telephone-event
Max-Forwards: 68
P-Asserted-Identity: <sip:mydid@X.X.4.2>
Session-Expires: 1800
Content-Length: 0
P-Asserted-Identity:<sip:mydid@toronto.voip.ms>

 

In your packet capture you have two PAI.

P-Asserted-Identity: <sip:mydid@X.X.4.2>
Session-Expires: 1800
Content-Length: 0
P-Asserted-Identity:<sip:mydid@toronto.voip.ms>
Change the SIP profile to modify the PAI instead of adding a new one.



Response Signature


Hi Roger, 

I checked the config over and did another packet capture & test call, I think I may have had some other config in place when that capture was taken. The fresh packet capture shows just the one P-Asserted-Identity. 

 

INVITE sip:mycellphone@toronto4.voip.ms:5060 SIP/2.0

Via: SIP/2.0/UDP X.X.4.2:5060;branch=z9hG4bK2058CB4

Remote-Party-ID: <sip:mysipdid@X.X.4.2>;party=calling;screen=no;privacy=off

From: <sip:2mysipdid@X.X.4.2>;tag=243D7DC8-207F

To: <sip:mycellphone@toronto4.voip.ms>

Date: Wed, 27 May 2020 00:26:20 GMT

Call-ID: 85BADA6D-9EE711EA-83CA89D2-A958FA7F@10.0.4.2

Supported: timer,resource-priority,replaces,sdp-anat

Min-SE: 1800

Cisco-Guid: 2928272256-0000065536-0000000095-0168034314

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

CSeq: 101 INVITE

Timestamp: 1590539180

Contact: <sip:mysipdid@X.X.4.2:5060>

Call-Info: <sip:X.X.4.2:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"

Expires: 180

Allow-Events: kpml, telephone-event

Max-Forwards: 68

Session-Expires: 1800

Content-Length: 0

P-Asserted-Identity:<sip:mysipdid@toronto4.voip.ms>

 

In the capture it also shows another invite with the hunt pilot DN it seems like as soon as I answer the call on the cell phone it sends another invite with the hunt DN

 

INVITE sip:1075@toronto4.voip.ms:5060 SIP/2.0

Via: SIP/2.0/UDP X.X.4.2:5060;branch=z9hG4bK205B546

From: <sip:X.X.4.2>;tag=243D8C98-1E29

To: <sip:1075@toronto4.voip.ms>

Date: Wed, 27 May 2020 00:26:24 GMT

Call-ID: 87FCE027-9EE711EA-83CC89D2-A958FA7F@10.0.4.2

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Min-SE: 1800

Cisco-Guid: 2232975115-2665943530-2210367954-2841180799

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

CSeq: 101 INVITE

Max-Forwards: 70

Timestamp: 1590539184

Contact: <sip:X.X.4.2:5060>

Expires: 180

Allow-Events: telephone-event

Session-Expires: 1800

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 292

 

So the same sip profile is in use 

voice class sip-profiles 1
request INVITE sip-header P-Asserted-Identity add "P-Asserted-Identity:<sip:mysipdid@toronto.voip.ms>"

 

Create
Recognize Your Peers
Content for Community-Ad