cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9547
Views
5
Helpful
26
Replies

Some CME 7 questions

voip7372
Level 4
Level 4

Hi,

First of all, go easy on me...I'm not the most proficient when it comes to Cisco telephony, and CME in particular...and for Cisco routers/switches too.  I can get around in them and do common things, but once you dive deep into technical details about network-centric topics, I may get lost.  I have a deep technical telephony background in Avaya (voip and tradtional).   We have a call manager (Windows server) that has been installed for awhile that I'm more familiar with (it was a pilot test from awhile back).  We just got a new 2921 router with CME installed for free from Cisco as a tester because we've bought so much other network gear.  Anyway, I'm trying to configure this CME and I'm having trouble with a few things.  I've tried reading to understand what's going on, but so far I've not been able to figure this out on my own.

What I have working so far is a H.323 link to an Avaya system we use as our main system.   I can call ext's on that system and even use the outside lines to make external calls.   Works fine.   I can call from the Avaya to Cisco CME, no problem.

Here are my questions.

1.  I can't seem to get the web GUI to work.  I can get to the GUI for the main router config (Cisco CP Express)...but I can't get the GUI for the telephony stuff working.  When I go to the web page http://192.168.1.10/ccme.html  (IP address is bogus, but for demonstration purposes...) I get the login prompt.  I type my login/password and then it goes to a blank page.  Nothing there at all.  Just blank.  Any ideas?

2.  I can't seem to get the conference function to work.  When I press Conference, it says 'cannot complete conference'.   The situation is, I have a call live on the phone and then I try to press conference to initiate a conference.  Am I doing it wrong is or there some other issue?  The phone is setup like this:

ephone-dn  1  dual-line
number 61234
name TEST USER

3.  I'm confused about flash: vs. flash0:    I see all the CME 7.1 files are stored in flash0: in my system.  I screwed up and watched some 'how to install CME' video on youtube and I was trying to upgrade it to CME 8 or trying to get it working in the first place, before I realized all the files were already installed at the factory in flash0: and I copied all the new CME 8 files into flash:.   I don't know if this creates any problems other than I'm just wasting that flash memory space now in flash:....but you tell me.  Is this a problem?   I can't find an easy way to delete those files I extracted there in flash:.  I'd like to remove them if possible, without it taking 4 hours of command line typing.   Is there an easy way to do it?   Anyway, what IS the difference between flash: and flash0:?   Is it just two different flash memory sources?

4.  Somewhat related to number 3 above.  I see taht CME 8 is available.  But how do you go about upgrading to that from CME 7.1?   Is there a guide on how to do this without wiping out your existing config, etc?   How do you install CME 8 over top of 7.1 without leaving a bunch of extra 7.1 files in place that just waste space, etc?

5.  I cant' get the correct time to show on the phone (7942).  I have the time zone set and a NTP server assigned in the router.  The phone is exactly 4 hours fast.  The minutes are correct.  It seems like some kind of time zone issue.  Any ideas?

Here is the config you see when you type 'show telephony-service' from the command line.  Any IP's and passwords you see below have been alterered, to protect the innocent ;-) ....

Version 7.1
Cisco Unified Communications Manager Express
For on-line documentation please see:
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support_serie
s_home.html

ip source-address 192.168.1.10 port 2000
ip qos dscp:
ef (the MS 6 bits, 46, in ToS, 0xB8) for media
cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal
af41 (the MS 6 bits, 34, in ToS, 0x88) for video
default (the MS 6 bits, 0, in ToS, 0x0) for serviceservice directed-pickup
max-ephones 25
max-dn 25
max-conferences 10 gain -6
dspfarm units 0
dspfarm transcode sessions 0
conference software
privacy
no privacy-on-hold
hunt-group report delay 1 hours
hunt-group logout DND
max-redirect 10
cnf-file location: system:
cnf-file option: PER-PHONE-TYPE
network-locale[0] US   (This is the default network locale for this box)
network-locale[1] US
network-locale[2] US
network-locale[3] US
network-locale[4] US
user-locale[0] US    (This is the default user locale for this box)
user-locale[1] US
user-locale[2] US
user-locale[3] US
user-locale[4] US
srst mode auto-provision is OFF
srst ephone template is 0
srst dn template is 0
srst dn line-mode single
moh music-on-hold.au
time-format 12
date-format mm-dd-yy
timezone 12 Eastern Standard/Daylight Time
secondary-dialtone 9
no transfer-pattern is configured, transfer is restricted to local SCCP phones o
nly.
keepalive 30 auxiliary 30
timeout interdigit 10
timeout busy 10
timeout ringing 180
timeout transfer-recall 0
timeout ringin-callerid 8
timeout night-service-bell 12
caller-id name-only: enable
web admin system name xxxxx  password xxxxx
web admin customer name Customer
edit DN through Web:  enabled.

edit TIME through web:  enabled.
Log (table parameters):
     max-size: 150
     retain-timer: 15
create cnf-files version-stamp 7960 Aug 11 2010 07:09:37
transfer-system full-consult
transfer-digit-collect new-call
local directory service: enabled.
Extension-assigner tag-type ephone-tag.

Here is some of what you see when you do a 'show run':

telephony-service
max-ephones 25
max-dn 25
ip source-address 192.168.1.10 port 2000
time-zone 12
max-conferences 10 gain -6
moh music-on-hold.au
web admin system name xxxxx password xxxxx
dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
create cnf-files version-stamp 7960 Aug 11 2010 07:09:37

ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash0:

26 Replies 26

GUI is not absolutely necessary for me.  I just thought it would be nice to have it working, for convenience.  No logging into router and command line....just go to web page for some simple changes.

I'm not a fan of the GUI myself but it's an accessible way for a customer administrator, who doesn't have a lot of Cisco CLI experience, to set up users and phones.

It looks like the file permissions aren't set correctly,  did you extract the files with the archive tar /xtract source-url flash:/file-url command?

regards

Paul

I did exactly what the CME 8 readme.txt file said to do, which is:  archive tar /xtract tftp://ip-address-of-tftp-server/cme-full-8.0.0.0.tar flash: 

(6) Download the cme-full-8.0.0.0.tar file. This TAR file includes all the phone loads

(7906/11, 7915/16, 7921/25, 7931, 7937, 7941/61, 7942/62, 7945/65, 7970/71, 7975), as well as

gui files, and ringtones.  The gui files will be unarchived to the "gui" folder, while the ringtones and xml

will be downloaded to the "ringtones" folder. Phone loads will be downloaded to the flash root directory folder.  For all other support files such as BACD scripts, extension-assigner scripts, etc, the customer should download and copy the files onto the CME flash manually.

You may be right about the version clash then,

the 8.0.0.0 GUI files are tied to the 15.0(1)XA and 15.1(1)T releases.  So it might be worth rolling back to those releases if you want to enable the GUI.

Paul

Well shoot...I went back to the recommended IOS version and still no dice.   Same mostly blank page as shown previously.   Guess I'll go back to the newest release.  There's got to be something else making this not work right.   Hmmmm

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(1)T, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Mon 22-Mar-10 02:13 by prod_rel_team

Did you ever try the "ip http path flash:/"?  I can recreate this in my lab on 12.4(24)T3 with just having "ip http path flash:".  Without the / after I put in credentials I get the blank page and when I add the / to the end then the /ccme.html page does work properly.

My gui files are in a folder called gui so I must note that in the http path..they're not on the root of the flash.  If I do ip http path flash:/  I get a completely blank web page (all white - since there's no file found).   If I do ip http path flash:/gui OR ip http path flash:/gui/   I get the page displayed below.  It has a colored background and the words 'view window' in the top left, and that's it. 

I have found that starting from some past release, the only location the GUI files will work from, is root.

FINALLY!  :-)    After moving the files to the root of flash on this new version 8 build I loaded with IOS version 15.1(1)T  (even though I know there are problems with that IOS version), the GUI works.  I may try now to move to the very newest IOS and see if it still works after that.

Hello,

Could you please advice  me on how you move your CME GUI to root please ?

I have configured ip http path flash:/, but it returns back to flash .

I would be glad on your response

Thanks,

Dak

You have to write

ip http path flash:GUI

If ur GUI files are in a folder called GUI

HumanTorch
Level 5
Level 5

In CME 9.0 you NEED to add the below line in order for the GUI to work:

Router(config)#file privilege 0

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: