cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

254
Views
0
Helpful
7
Replies
Highlighted
Beginner

SRST Dial-peers configuration

Hello everyone,

 

I have a dial peer configured for incoming calls redirected to the CUCM working just fine, and wants to do the same when the router lose WAN connectivity and CUCM becomes unreacheable, the problem is that the srst dial-peer will be permanently used even when the WAN link goes back up and have to deactivate it manually 

here's a part of the configuration :

voice translation-rule 1
rule 1 /0944556677/ /1000/  # I see this like translation pattern in CUCM

voice translation-profile 1
translate called 1             #enable the previouos rule (?)

dial-peer voice 1 voip            #the original dial peer I use with CUCM
destination-pattern 0944556677
session target ipv4:192.168.1.2
dtmf-relay h245-alphanumeric
codec g711ulaw

dial-peer voice 2 pots         #Dial peer used when SRST is enabled
description INCOMING CALLS SRST
translation-profile incoming 1        # 1 is the ID of the translation profile
incoming called-number .T
no digit-strip
direct-inward-dial
port 0/1/0

Not sure if it will help, but i'm not using call-manager fallback, but voice register global instead

 

Tried to look for something like preference or playing with dial peers, doesn't work for me (I don't know maybe), and I have to disable the translation profile to make the original dial peer with CUCM work


based on the above, is there any way for me to make the first dial peer work again once the connectivity to CUCM is back and SRST is disabled ?

Everyone's tags (3)
7 REPLIES 7
Rising star

Re: SRST Dial-peers configuration

To use the preference command you must have exactly same destination patterns

Please rate helpful posts
Cisco Employee

Re: SRST Dial-peers configuration

Hi,

 

You may be facing the problem of overlapping dial-peers.

So, when you are not in SRST, your call flow should be:

 

PSTN --> PRI --> VG inbound POTS DP --> outbound voip H323 DP --> CUCM --> Device

 

When in SRST:

 

PSTN --> PRI -- > VG inbound POTS DP --> Outbound Virtual dial-peer --> Phone.

 

If you do a dial-peer voice summ, you should be able to see all the virtual dial-peers as well in up state when in SRST.

 

It possibly is that the translation does not kick in or maybe the number is incorrectly configured which cause the gateway to try and route the call through the H323 Dial-peer towards CUCM.

 

I would suggest, can you try test calls in SRST and collect the following:

 

# sh run 

# sh dial-peer voice summ

# sh ephone registered

# sh voice register pool all br

 

>> Make test calls and get the output of:

 

# deb voice ccapi inout

# deb voip translation

# deb isdn q931

# deb voip dialpeer

 

Br,

Bijo

 

 

Beginner

Re: SRST Dial-peers configuration

Hello Bichacko,
Maybe didn't explain the issue very well,
my problem is that, once I add the translation rule and profile for SRST, it will be used all the time, even when the WAN is UP and CUCM is reacheable, I'm trying to make CUCM dial-peer work again once the WAN is UP again... because now, i'm doing things manually ( deactivate translation rule so inboud dial-peer going to CUCM takes effect)
any idea please ?
Beginner

Re: SRST Dial-peers configuration

If I add a translation rule it will be permanently used, I want it to be deactivated when CUCM is UP
VIP Collaborator

Re: SRST Dial-peers configuration

Not sure if this will work, but have you tried applying the translation profile to the "voice-register pool"?

I assume it would only apply in SRST mode.

Beginner

Re: SRST Dial-peers configuration

unfortunatly it didn't work, because inside the voice register pool, you can add translation-profile incoming 1, but can't enable it inside of it (translate called 1)

 

This is drving me crazy :D, it's been 1 day i'm trying to figure out whats wrong, I hope you can help me in this 

in brief, here what happens :

 

CUCM UP / translation profile disabled = Call redirected to the appropriate Phone
CUCM down / Translation profile enabled = Call redirected to the appropriate phone
CUCM UP / translation profile enabled = Call not routed at all, and to make it work I have to disable Translation profile

what could be wrong ? the best dial-peer matching ? any idea  ?

VIP Collaborator

Re: SRST Dial-peers configuration

Bit confused, but I assume the translation-profile would include the rule for the translation.

Also, I think if applied to the pool it may be "outgoing" and not incoming.

I was able to apply the config to one of my routers, but unfortunately can't test it out.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards