cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

888
Views
0
Helpful
6
Replies
Beginner

SRST doesn't work with MGCP

                   Hello,

I try to implement SRST feature on a 2901 router. There's already a MGCP link between router and CUCM (8.6) which is OK (FXS port is mounted for analog phone on CUCM).

But SRST doesn't work.

CUCM config is OK (System => SRST => Name & IP address, and System => Device Pool => SRST=2901), and phone have the correct IP address of the SRST router in the CM List. IP address of the CUCM is 10.1.1.10.

I try to begin by a very simple config, here it is :

!

! Last configuration change at 13:30:24 UTC Fri Feb 15 2013

! NVRAM config last updated at 11:28:20 UTC Fri Feb 15 2013

! NVRAM config last updated at 11:28:20 UTC Fri Feb 15 2013

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname r2901srst

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

network-clock-participate wic 0

network-clock-participate wic 1

!

no ipv6 cef

ip source-route

ip cef

!

!

application

global

  service alternate Default

!

!

ip domain name democisco.com

multilink bundle-name authenticated

!

!

!

!

isdn switch-type basic-net3

!

crypto pki token default removal timeout 0

!

!

voice-card 0

!

!

!

!

!

!

!

license udi pid CISCO2901/K9 sn FCZ********

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.0.3.102 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0/0/0

no ip address

isdn switch-type basic-net3

isdn timer T310 6000

isdn overlap-receiving

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn send-alerting

isdn sending-complete

isdn outgoing-voice info-transfer-capability 3.1kHz-audio

!

interface BRI0/0/1

no ip address

!

interface BRI0/1/0

no ip address

!

interface BRI0/1/1

no ip address

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.0.3.1

!

!

!

!

control-plane

!

!

voice-port 0/0/0

compand-type a-law

cptone FR

!

voice-port 0/0/1

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 0/3/2

!

voice-port 0/3/3

!

ccm-manager mgcp

!

mgcp

mgcp call-agent 10.1.1.10 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

!

mgcp profile default

!

!

dial-peer voice 100 pots

port 0/0/0

!

dial-peer voice 103 pots

service mgcpapp

port 0/2/0

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.1.1.10 port 2000

max-ephones 10

max-dn 10

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Please help if you see what can be wrong !

Thank you,

Clement

2 ACCEPTED SOLUTIONS

Accepted Solutions
Engager

SRST doesn't work with MGCP

Dear

Based on your configuration , i found that you type the IP address of your call manager under call- manager-fallback

Solution

call-manager-fallback

ip source-address  10.0.3.102 port 2000  ( The IP address must be the IP of the router which will replace call manager).Please check also the ip of SRST router Cisco Unified CMAdministration, choose System > SRST > Add New

Thank you

Please rate if this will help

View solution in original post

Advocate

Re: SRST doesn't work with MGCP

1) change ip source address under fallback to the ip address of this router as per above post.

There are another couple of things missing in the config came, without which SRST will not be fully functional:

1) add: "ccm-manager fallback-mgcp" - to enable the gateway failover from mgcp to h323

2) add outbound dial-peers(there is an incomplete 100 dial peer): example, at least a basic one sending all calls to PSTN, if 0 is access code:

Dial-peer voice 100 pots
Destination-patt 0T
Port 0/0/0

3) Incoming dial-peer and translation rule for incoming calls to your DID numbers during SRST, lets say your extension are 1XXX:
Voice translation-rule 1
r 1 /.*\(1...$\)/ /\1/
Voice translation-pro FR-PSTN
t calle 1

dial-peer voice 1 pots
Incoming called-num .
Translation-pro in FR-PSTN
Direct

*PS* - Excuse syntax error if any, I dont have CLI nearby, sending from phone.

Sent from Cisco Technical Support iPhone App

View solution in original post

6 REPLIES 6
Engager

SRST doesn't work with MGCP

Dear

Based on your configuration , i found that you type the IP address of your call manager under call- manager-fallback

Solution

call-manager-fallback

ip source-address  10.0.3.102 port 2000  ( The IP address must be the IP of the router which will replace call manager).Please check also the ip of SRST router Cisco Unified CMAdministration, choose System > SRST > Add New

Thank you

Please rate if this will help

View solution in original post

Advocate

Re: SRST doesn't work with MGCP

1) change ip source address under fallback to the ip address of this router as per above post.

There are another couple of things missing in the config came, without which SRST will not be fully functional:

1) add: "ccm-manager fallback-mgcp" - to enable the gateway failover from mgcp to h323

2) add outbound dial-peers(there is an incomplete 100 dial peer): example, at least a basic one sending all calls to PSTN, if 0 is access code:

Dial-peer voice 100 pots
Destination-patt 0T
Port 0/0/0

3) Incoming dial-peer and translation rule for incoming calls to your DID numbers during SRST, lets say your extension are 1XXX:
Voice translation-rule 1
r 1 /.*\(1...$\)/ /\1/
Voice translation-pro FR-PSTN
t calle 1

dial-peer voice 1 pots
Incoming called-num .
Translation-pro in FR-PSTN
Direct

*PS* - Excuse syntax error if any, I dont have CLI nearby, sending from phone.

Sent from Cisco Technical Support iPhone App

View solution in original post

Highlighted
Beginner

Re: SRST doesn't work with MGCP

Thank you guys for answers.

I think you are right.

As my router is in my office, I will test on monday to change ip-source address to router's IP, add ccm-manager fallback-mgcp, and add dial-peers.

I've already think about dial-peers, but firstly I want my phones register correctly.

Give you news and rates next week, I will now think about register third party SIP phones when SRST activated.

Thank you so much,

Clement

Advocate

Re: SRST doesn't work with MGCP

No problem - let us know if you have further questions.

Terry

Sent from Cisco Technical Support iPhone App

Engager

Re: SRST doesn't work with MGCP

Dear

1- Firstly check the registeration is ok , after that please use the (R#sh call-manager-fallback).

2- After this you will have to add all your dial-peers  for example as below.

dial-peer voice 200 pots

destination-pattern 9[2-9].........

port 0/0/1:23

!

dial-peer voice 201 pots

destination-pattern 91[2-9].........

port 0/0/1:23

!

dial-peer voice 202 pots

destination-pattern 9011...........

port 0/0/1:23

!

dial-peer voice 203 pots

destination-pattern 9911

port 0/0/1:23

Thank you

please rate if this will help

Beginner

Re: SRST doesn't work with MGCP

It works perfectly guys !

Feb 17 17:23:32.143: %IPPHONE-6-REGISTER_NEW: ephone-1:SEP00179551F950 IP:10.0.3.3 Socket:1 DeviceType:Phone has registered.

Feb 17 17:23:57.003: %SYS-5-CONFIG_I: Configured from console by console

Feb 17 17:23:57.055: %LINK-5-CHANGED: Interface BRI0/0/0, changed state to administratively down

Feb 17 17:23:58.203: %SYS-5-CONFIG_I: Configured from console by console

Feb 17 17:24:01.415: %SYS-5-CONFIG_I: Configured from console by console

Feb 17 17:24:01.455: %LINK-3-UPDOWN: Interface BRI0/0/0, changed state to up

Feb 17 17:24:42.991: %CALL_CONTROL-6-APP_NOT_FOUND: Application mgcpapp in dial-peer 103 not found.  Handing callid 10 to the alternate app .

But I have a problem with an analog phone wired to a FXS port (it's the dial-peer voice 103 pots in my config). IP phone have correct tone, but I've a busy one on the analog. The message which appears in the console is the last in my log above.

I know to activate fallback on SRST for FXS port, I have to use SCCP as shown in this guide : http://www.cisco.com/en/US/docs/ios/voice/fxs/configuration/guide/fxssrst.pdf

In addition, I've add destination-pattern 1105 into the dial-peer of the analog phone, which permits it to receive calls but no to initiate a call.

My config is :

ccm-manager fallback-mgcp

ccm-manager mgcp

!

mgcp

mgcp call-agent 10.1.1.10 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 10.0.3.102 identifier 20 version 7.0

sccp ccm 10.1.1.10 identifier 10 version 7.0

sccp

!

sccp ccm group 1

description ### Groupe de CCM pour prise en charge SCCP sur ports FXS ###

associate ccm 10 priority 1

associate ccm 20 priority 2

switchback method graceful

!

dial-peer voice 100 pots

port 0/0/0

!

dial-peer voice 103 pots

service mgcpapp

destination-pattern 1105

port 0/2/0

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.0.3.102 port 2000

max-ephones 10

max-dn 10

system message primary /!\ Mode de secours actif /!\

system message secondary Mode degrade actif

It might be OK following instructions in the guide ?

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here