Showing results for 
Search instead for 
Did you mean: 

SRST - FXO Port Answers then Silence

Lamar Demby

When testing SRST, I'm getting a symptom in which inbound calls are not getting connected to the ephone that is properly registered with the Reception DN.  Outbound calls work fine.

The FXO port answers the call, then the caller only hears silence.  The caller does not get disconnected, no dial/busy-tone, nothing...just silence.  I can see the LED on the fxo port lit in Active status for the entire length of the call, so I know that I'm connected.  The PLAR does not seem to be working.  I ran debug on voice ccapi inout/error as well as voice dialpeer inout/error.  I receive no errors and the correct inbound dialpeer is matched.  There are two 4-port FXO cards in the VGW and POTS test calls to both cards end with the same result.  The voice ccapi inout debug output is attached.

The CM is ver 8.03 and the VGW is model 2951 running MGCP on IOS ver 15.1(1) T2.  I have the exact same config running on a test 2951 VGW in a lab and it works flawlessly.  I've done a stare & compare on both the working and non-working configs and do not see any difference.  My next step was to replace the FXO card(s) to see what happens before I open a TAC, but thought I'd check with Peers before doing so in case I'm missing something simple.

Has anyone else experience such a symtom?  I've search the net looking for any simliar problems, but have yet to find anything.

In the example below, the POTS Line TN = 555111.  The PLAR is to the Reception DN @ 5552222.

Here's my config:




  service alternate Default


voice-port 0/0/1

echo-cancel coverage 64

timing hookflash-out 50

connection plar 5552222

description IB Redirect Port - 5551111

caller-id enable


dspfarm profile 111 mtp 

codec g711ulaw

maximum sessions hardware 119

associate application SCCP


dial-peer voice 999001 pots

service mgcpapp


port 0/0/1



secondary-dialtone 9

max-conferences 2 gain -6

transfer-system full-consult

limit-dn 7945 1

limit-dn 7975 2

ip source-address port 2000

max-ephones 100

max-dn 100 dual-line

system message primary Failover - Dial 9 for LineOut

default-destination 5552222


Thanks in advance,


2 Replies 2

Lamar Demby

Just swapped fxo card with known working card and placed the original card into the test VGW with matching config, IOS version, works, so problem must be with something on original VGW.

Lamar Demby


Turns out that I was missing a command on the non-working VGW..."ccm-manager fallback-mgcp".  Will test tonight afterhours to verify finding.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: