cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
527
Views
0
Helpful
2
Replies
Beginner

SRST mode - inbound calls doesnt working

Hi All,

I have a office that in SRST mode can´t be reached for inbound calls from the PSTN, they use 5 digits extensions , I mean the extension start with 2XXXX , is correct the translation rule and the dialpeer config?

Also for local local they have to dial 9 and include the 1, that is correct too..

I think maybe works my translation

rule 1 /^\(4075634\)\(....\)/ /2\2/

where the 4075634XXXX is the DID

Please your imputs!

ivgwautocount-dmvpn#show run | sec dial-pe´


dial-peer voice 10 pots
service mgcpapp
port 1/0:23
dial-peer voice 100 pots
translation-profile incoming prefix2
incoming called-number .
direct-inward-dial
port 1/0:23


dial-peer voice 1000 pots
description Local Calls
preference 1
destination-pattern 9[2-9]..[2-9]......
port 1/0:23
forward-digits 0
dial-peer voice 1001 pots
description Long Distance Calls
preference 1
destination-pattern 91[2-9]..[2-9]......
port 1/0:23
prefix 1

#show run | sec voice trans
voice translation-rule 1
rule 1 /\(...$\)/ /2\1/
voice translation-profile prefix2
translate called 1

ivgwautocount-dmvpn#show call-manager-fallback
CONFIG (Version=7.1)
=====================
Version 7.1
For on-line documentation please see:
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support_series_home.html

ip source-address 10.12.120.1 port 2000
ip qos dscp:
ef (the MS 6 bits, 46, in ToS, 0xB8) for media
cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal
af41 (the MS 6 bits, 34, in ToS, 0x88) for video
default (the MS 6 bits, 0, in ToS, 0x0) for serviceservice directed-pickup
max-ephones 58
max-dn 125
max-conferences 8 gain -6
dspfarm units 0
dspfarm transcode sessions 0
huntstop
no huntstop channel
huntstop channel 0
dialplan-pattern 1 2.... extension-length 5 extension-pattern 2....
voicemail 912147267301
cnf-file location: system:
cnf-file option: PER-PHONE-TYPE
network-locale[0] US   (This is the default network locale for this box)
network-locale[1] US
network-locale[2] US
network-locale[3] US
network-locale[4] US
user-locale[0] US    (This is the default user locale for this box)
user-locale[1] US
user-locale[2] US
user-locale[3] US
user-locale[4] US
srst mode auto-provision is OFF
srst ephone template is 0
srst dn template is 0
srst dn line-mode single
moh SampleAudioSource3db.au
time-format 12
date-format mm-dd-yy
timezone 0 Greenwich Standard Time
secondary-dialtone 9
call-forward busy 912147267301
call-forward noan 912147267301 timeout 12
no transfer-pattern is configured, transfer is restricted to local SCCP phones only.
alias 1 22850 to 912147267301
alias 2 12850 to 912147267301
keepalive 30 auxiliary 30
timeout interdigit 5
timeout busy 10
timeout ringing 180
timeout transfer-recall 0
timeout ringin-callerid 8
timeout night-service-bell 12
caller-id name-only: enable
system message primary Limited Services Available
Limit number of DNs per phone:
  12SP: 56
  7902: 56
  7905: 56
  7906: 56
  7910: 56
  7911: 56
  7912: 56
  7920: 56
  7921: 56
  7925: 56
  7931: 56
  7935: 56
  7936: 56
  7937: 56
  7940: 56
  7941: 56
  7941GE: 56
  7942: 56
  7945: 56
  7960: 56
  7961: 56
  7961GE: 56
  7962: 56
  7965: 56
  7970: 56
  7971: 56
  7975: 56
  7985: 56
  anl: 56
  ata: 56
  bri: 56
  CIPC: 56
  vgc-phone: 56
Log (table parameters):
     max-size: 150
     retain-timer: 15
transfer-system full-consult
transfer-digit-collect new-call
multicast moh 239.1.1.1 port 16384
route 10.12.120.1
local directory service: enabled.
Extension-assigner tag-type ephone-tag.

2 REPLIES 2
Highlighted
Rising star

Re: SRST mode - inbound calls doesnt working

Hello,

Inbound calls in the SRST should me matched to two dial-peer (one VOIP and One Pots)

Try to add the VOIP dial-peer with the destintion number 2XXXX

Also add the direct-inward-dial to the Pots dial-peer.

Beginner

Re: SRST mode - inbound calls doesnt working

I see a problem in your translation rule, there is one dot extra, and one "X" extra you have on. PSTN numbers are 10 digits, you have a rule for 11. Try fixing that, also besides this, remove the mgcpapp from that Pots dialpeer, there is no need for that as it's a PRI.

However down in your router config you have:

#show run | sec voice trans
voice translation-rule 1
rule 1 /\(...$\)/ /2\1/
voice translation-profile prefix2
translate called 1

Now you should be either getting 10 digits from PSTN or 4, if you are getting 4 digits, then there is One MORE Dot needed in that rule above to match. If you are getting 10 digits, then that rule has to be modified based on the digits you are getting.

Example for 4 digits should be;

Voice Translation-rule 1

rule 1 /\(....$\)/ /2\1/

hope this helps.

cheers.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards