cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1083
Views
0
Helpful
6
Replies
Beginner

SRST on voice gateway

I have h323 gateway with sip configuration as given in cisco document, After failover sccp phones are registered. But sip phone cisco 8811 phones are not registered even, we didnt recieve any logs or hits on gateway.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Participant

* Add "max-dn" under voice

* Add "max-dn" and "mode esrst" to enable more features under voice register global.

* Also under voice register  pool add the following id network "id network 0.0.0.0.0  mask 0.0.0.0" for testing purpose and "codec g711ulaw" and "no vad".

* Make sure you have the SRST-Reference on the CUCM page  for SIP also on the CUCM.

voice register global

mode esrst
system message Primary Link Failure
max-pool 10

max-dn 100


voice register pool 1
id network 0.0.0.0.0  mask 0.0.0.0
preference 1
proxy 192.168.x.x  voice gateway ip add
dtmf-relay rtp-nte sip-notify

-Kevin

6 REPLIES 6
Advocate

Can you post your config?

Can you post your config? Check the basics like SRST reference in CUCM and your configs.

Whats the firmware version of the phone? Make sure its supported : check here

-Terry

Please rate all helpful posts

Beginner

Dear Terry,

Dear Terry,

Phone version its showing 10.3.(1) 

Basic configuration at CUCM alright. 

Participant

Hi Dinesh,

Hi Dinesh,

Here is the link to configure SIP-SRST:

https://supportforums.cisco.com/document/12746456/how-implement-cisco-unified-sip-srst

8811 is supported on SRST version 10.5 IOS is (15.4(3)M ) and above:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cusrst/requirements/guide/srs105spc.html

Cisco Unified IP Phone 8811

N/A

10.2.2

This should help.

-Kevin

Beginner

Kevin,

Kevin,

Thanks 

I follow the same document and configured below show run. I have sccp phone too. Pls suggest below are the config. Pls suggest 

version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
!
hostname DXB-AWQ-VG1
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
--More--   exit-address-family
!
card type e1 0 1
enable secret 5 $1$8x43$S0VQwIYA5cguHv8JYaksJ1
!
no aaa new-model
clock timezone AST 4 0
!
!
!
!
!
!
!
!
!
!
!

no ip domain lookup
ip domain name x.com
--More--  !
!
!
!
!
!
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
!
!
--More--  voice service voip
ip address trusted list
ipv4 192.168.48.0 255.255.255.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g722-64
codec preference 3 g729br8
codec preference 4 g729r8
!
voice class h323 1
h225 timeout tcp establish 3
!
!
!
!
--More--  !
voice register global
default mode
system message Primary Link Failure
max-pool 10
!
voice register pool 1
id network 192.168.x.0 mask 255.255.255.0
preference 1
proxy 192.168.x.x  voice gateway ip add
dtmf-relay rtp-nte sip-notify
voice-class codec 1
!
!
voice translation-rule 10
rule 1 /^\([0-9]\)/ /9\1/
!
voice translation-rule 20
rule 1 /^9/ //
!
voice translation-rule 30
rule 1 /^\(5...$\)/ /04406\1/
!
--More--  !
voice translation-profile addinPrefix
translate calling 10
!
voice translation-profile callingpstn
translate calling 30
translate called 20
!
!
!
!
voice-card 0/1
dsp services dspfarm
no watchdog
!
license udi pid ISR4321/K9 sn FDO19480FP5
!
spanning-tree extend system-id
!
username netadmin privilege 15 password 7 151C0E18052E262D26
username admin privilege 15 secret 5 $1$eItX$g4HvMfUK5oTiy0JSg2zLI0
!
redundancy
--More--   mode none
!
!
!
!
controller E1 0/1/0
framing no-crc4
pri-group timeslots 1-20
!
controller E1 0/1/1
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
--More--  !
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
ip address 192.168.x.x 255.255.255.0
negotiation auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.x.x
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
--More--  interface Service-Engine0/1/0
!
interface Serial0/1/0:15
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip default-gateway 192.168.48.1
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
--More--  ip route 0.0.0.0 0.0.0.0 192.168.48.1
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0:15
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
--More--  !
!
call-manager-fallback
secondary-dialtone 9
max-conferences 3 gain -6
transfer-system full-consult
timeouts interdigit 5
timeouts ringing 26
ip source-address 192.168.xx port 2000 voice gasteway  IP add
max-dn 100
system message primary Link failure-Standby Mode
!
!
dial-peer voice 1000 pots
description National Calls
translation-profile outgoing callingpstn
destination-pattern 90[2-36-9][1-8]......$
progress_ind alert enable 8
!
dial-peer voice 1001 pots
description Mobile Calls
translation-profile outgoing callingpstn
destination-pattern 905[0526].......$
--More--   progress_ind alert enable 8
port 0/1/0:15
!
dial-peer voice 1002 pots
description Emergency Calls
destination-pattern 99..$
progress_ind alert enable 8
forward-digits 3
!
dial-peer voice 1003 pots
description Service Calls
destination-pattern 91..$
progress_ind alert enable 8
forward-digits 3
!
dial-peer voice 1004 pots
description Emergency Calls
destination-pattern 999
progress_ind alert enable 8
!
dial-peer voice 1005 pots
translation-profile outgoing callingpstn
destination-pattern 900T
--More--   progress_ind alert enable 8
!
dial-peer voice 1006 pots
description Toll Free Calls
translation-profile outgoing callingpstn
destination-pattern 9[678]00T
progress_ind alert enable 8
!
dial-peer voice 1007 pots
description Local Calls
translation-profile outgoing callingpstn
destination-pattern 9[2-8]......$
progress_ind alert enable 8
!
dial-peer voice 1008 pots
description Local Calls
translation-profile outgoing callingpstn
destination-pattern 904[2-8]......$
progress_ind alert enable 8
!
dial-peer voice 10 pots
incoming called-number .
direct-inward-dial
--More--   port 0/1/0:15
!
dial-peer voice 5600 voip
translation-profile outgoing addinPrefix
preference 2
destination-pattern 57..$
session target ipv4:192.168.xx
voice-class codec 1
voice-class h323 1
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 5601 voip
translation-profile outgoing addinPrefix
preference 1
destination-pattern 57..$
session target ipv4:192.168.xx
voice-class codec 1
voice-class h323 1
dtmf-relay h245-alphanumeric
no vad

Highlighted
Participant

* Add "max-dn" under voice

* Add "max-dn" and "mode esrst" to enable more features under voice register global.

* Also under voice register  pool add the following id network "id network 0.0.0.0.0  mask 0.0.0.0" for testing purpose and "codec g711ulaw" and "no vad".

* Make sure you have the SRST-Reference on the CUCM page  for SIP also on the CUCM.

voice register global

mode esrst
system message Primary Link Failure
max-pool 10

max-dn 100


voice register pool 1
id network 0.0.0.0.0  mask 0.0.0.0
preference 1
proxy 192.168.x.x  voice gateway ip add
dtmf-relay rtp-nte sip-notify

-Kevin

Beginner

After doing this procedure

After doing this procedure different model of Phones are registered like 7821 phones. But this phones taking long time to fall-back on srst or viseversa.  Could you pls tell me exact router version support.

I am referring below link 

http://docwiki.cisco.com/wiki/Cisco_Unified_SRST_Manager_Compatibility_Matrix

its says require router version should be 15.6 for cisco IP Phone 8811.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards