cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

639
Views
0
Helpful
0
Replies
Highlighted
Beginner

SRST: Phones not registering using VRF and MPLS

Greetings.

I have a point - to - multi point MPLS network that is using VRF groups with MPLS/EIGRP/BGB (I am not verify familiar with routing protocols).  When a phone goes into srst mode, they do not register with the local gateway.  I am able to replicate this in a lab environment.

Topology is thus:

IP Phone connected to 3750 access switch

3750 Access switch connected to 2921 ISR (datak9 (eval), uck9 (eval))  IOS is: c2900-universalk9-mz.SPA.152-4.M1.bin.

2921 connected to production 6500

6500 connected to production 2921 (WAN gateway)

Lab CUCM connected to access switch connected to 6500

ip vrf voice

rd 30:30

route-target export 30:30

route-target import 30:30

!

multilink bundle-name authenticated

!

mpls label protocol ldp

voice vrf voice

!

voice service voip

h323

interface Loopback0

ip address 1.1.1.9 255.255.255.255

!

interface GigabitEthernet0/0

description WAN link to MPLS

ip address 10.253.0.254 255.255.255.0

duplex full

speed 100

mpls mtu 1508

mpls ip

no cdp enable

!

interface GigabitEthernet0/1

description link to site switch

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.2000

description Local Voice Network 172.27.84.0

encapsulation dot1Q 2084

ip vrf forwarding voice

ip address 172.27.84.1 255.255.255.0

ip helper-address 10.10.20.15

ip helper-address 10.10.121.16

mpls ip

!

router eigrp 100

network 1.1.1.9 0.0.0.0

network 10.253.0.0 0.0.0.255

network 10.255.251.0 0.0.0.7

redistribute static

!

router bgp 100

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 update-source Loopback0

!

telephony-service

group 1 vrf voice

  ip source-address 172.27.84.1 port 2000

!

srst mode auto-provision none

srst dn line-mode dual

max-ephones 12

max-dn 24

max-conferences 8 gain -6

transfer-system full-consult

!

When null0 routing to the CallManager (ip route vrf voice 10.10.20.19 255.255.255.255 null0), the device loses connectivity and begins searching.  The device never registers with the gateway, but I do get this from a 'debug ip tcp trans'

Reserved port 0 in Transport Port Agent for TCP IP type 0

TCP: connection attempt to port 2000

TCP: sending RST, seq 0, ack 2207086699

TCP: sent RST to 172.27.84.40:50594 from 172.27.84.1:2000

Released port 0 in Transport Port Agent for TCP IP type 0 delay 240000

TCP0: state was LISTEN -> CLOSED [0 -> UNKNOWN(0)]

TCB 0x31D49BD4 destroyed

TCP0: ACK timeout timer expired

TCP0: ACK timeout timer expired

TCP0: ACK timeout timer expired

I am able to ping the device from the vrf ('ping vrf voice 172.27.84.40') and from extended pings from interface g0/0 (traceroute actually sends this traffic back to the WAN router and from their back to the lab (remote) router), but not from the subinterface g0/1.2000.  From what I am attempting to understand from vrf docs is that this is normal.  I do have an SR on-going with TAC on this, but I thought I'd ping the community to see if there is any others who have seen this.

Regards,

Robert.

Everyone's tags (4)
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here