cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1554
Views
0
Helpful
3
Replies
Beginner

Switchport Configurations for using Astra IP Phone and Ericsson IP PABX

Hi

Could anyone help to provide me with switchport configuration for using Astra IP Phone with Cisco 2960 switch. Client is using Ericsson IP PABX solution. Vlan 10 is for Data and Vlan 20 is for voice. IP phone registers to Ericsson IP PABX if the switchport is configured as :

interface gi0/1

switchport mode access

switchport access vlan 20

but, I need to connect PC to IP Phone to save ports.

I tried the below configuration but it does not work for me.

interface gi0/1

switchport mode trunk

switchport trunk native vlan 10

switchport trunk allowed vlan 10,20

Thanks

Ibrahim SAYEED

3 REPLIES 3
Beginner

Switchport Configurations for using Astra IP Phone and Ericsson

I believe i need to use the following on the trunk port between the switches:

switchport trunk native vlan 10

--- 10 is the data vlan

I will try this and confirm so that it will help others as well.

Enthusiast

Re: Switchport Configurations for using Astra IP Phone and Erics

hi  Ibrahim,

You can configure using 802.1X Authentication support. This works with some third party phones however there is no specific configs for Astra and Ericsson .

Refer to below document regarding

802.1x configuration : -

http://www.cisco.com/en/US/tech/tk389/tk814/technologies_configuration_example09186a00808abf2d.shtml#phone

Hope this helps!

Regards,

Karthik

Highlighted
Beginner

Switchport Configurations for using Astra IP Phone and Ericsson

just to update. I could not succeed in making the phone and PC work with different vlans.

interface gi0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

** with this configuration both IP phone and PC take IP Address from DHCP server but from the same ip subnet.

** I opened a TAC case to get help but believe me the assigned engineer's response has been far below expectations.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards