cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
963
Views
5
Helpful
26
Replies
Highlighted
Beginner

TCL script on CME not working!

Hi all,

I would greatly appreciate any help on this issue I'm having setting up AA on CME.

my setup is as follows;

PSTN caller>>>>>>>>SIP Gateway>>>>>>>>>CME (AA Script answers call and caller is placed in a queue N>B there are two different AA's for two different teams)

 

I have setup the AA as follows;

 

service aa_VIP flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  paramspace english language en
  param handoff-string aa_VIP
  param max-time-call-retry 60
  paramspace english location flash:
  param service-name queue
  param aa-pilot 2798282
  param welcome-prompt _bacd_welcome.au
  param number-of-hunt-grps 1
  param call-retry-timer 15
 !
 service queue flash:app-b-acd-3.0.0.2.tcl
  param queue-len 15
  paramspace english language en
  paramspace english index 0
  paramspace english location flash
  param aa-hunt1 1998
  param queue-manager-debugs 1
  param aa-hunt2 1999
  param number-of-hunt-grps 2
 !
 service aa_CS flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  paramspace english language en
  param service-name queue
  param aa-pilot 2798283
  param welcome-prompt _bacd_welcome.au
  paramspace english location flash:
  param number-of-hunt-grps 1
  param call-retry-timer 15
  param handoff-string aa_CS
  param max-time-call-retry 60

 

dial-peer voice 7836 voip
 description **Autoattendant AA**
 service aa_vip
 destination-pattern 2798282
 session protocol sipv2
 session target sip-server
 incoming called-number 2798282
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 7837 voip
 description **Autoattendant AA**
 service aa_cs
 destination-pattern 2798283
 session protocol sipv2
 session target sip-server
 incoming called-number 2798283
 dtmf-relay rtp-nte
 codec g711alaw
 no vad

 

 

ephone-hunt 1 longest-idle
 pilot 1988
 list 63, 67, 38
 timeout 10, 10, 10
!
!
ephone-hunt 2 longest-idle
 pilot 1999
 list 71, 72, 74, 75, 76
 timeout 10, 10, 10, 10, 10

 

However this is not working.

When I run a debug voip application script, I get nothing. Also a debug voip application media state does not provide any output.

To be honest I am yet to see an example of TCL configuration using a SIP dial-peer in all the examples I have seen.

Also I would like to know if it is possible to have two separate queues for two AA's.

 

Many thanks in advance.

Regards,

Y.

 

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

After the troubleshooting

After the troubleshooting session , we found some mandatory parameters missing on application definition...

service aa_VIP flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  paramspace english language en
  param handoff-string aa_VIP
  param max-time-call-retry 60
  paramspace english location flash:
  param service-name queue
  param aa-pilot 27799282
  param welcome-prompt _bacd_welcome.au
  param number-of-hunt-grps 1
  param call-retry-timer 15

param max-time-vm-retry 2

param second-greeting-time 60

param voice-mail XXX

 

After fixed those parameters all started work.

 

HTH

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"

View solution in original post

26 REPLIES 26

Hi.Try to add these two

Hi.

Try to add these two dialpeer

 

dial-peer voice 100 voip

incoming called-number 2798282 

service aa_vip

dtmf-relay rtp-nte

codec g711alaw

no vad

 

dial-peer voice 110 voip

incoming called-number 2798283

service aa_cs

dtmf-relay rtp-nte

codec g711alaw

no vad

 

Activate a debug voip application script and post the output

 

Let me know

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"
Beginner

Thanks Carlo,Your help is

Thanks Carlo,

Your help is very much welcome as I have a very short time to get this working.

I added the dial  peers as suggested and still get no joy.

There is no output for the debug voip application script and so decided to debug dial peer voip all to see the dial peer being matched on the incoming call. It seems to be matching the general incoming dial-peer set up for the DID range 27982.. rather than the specific dial-peer set up for the pilot numbers.

So I removed the dial peers 7836 and 7837 but still i get a fast busy signal,

I am able to call other DID numbers without an issue.

 

Find output below.

Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpMatchPeertype:exit@5985
Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=2798283
Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpMatchCore:
   Dial String=2798283, Expanded String=2798283, Calling Number=
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  4 17:50:47.554: //-1/E98855798066/DPM/MatchNextPeer:
   Result=Success(0); Incoming Dial-peer=1 Is Matched
Dec  4 17:50:47.554: //-1/E98855798066/DPM/MatchNextPeer:
   Result=Success(0); Incoming Dial-peer=110 Is Matched
Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpMatchPeertype:exit@5985
Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=110
Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
Dec  4 17:50:47.554: //-1/E98855798066/DPM/dpAssociateIncomingPeerSPI:exit@6564
Dec  4 17:50:47.556: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=2798283, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  4 17:50:47.556: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=2798283
Dec  4 17:50:47.556: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=2798283, Expanded String=2798283, Calling Number=
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  4 17:50:47.556: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
   Result=Success(0); Outgoing Dial-peer=1 Is Matched
Dec  4 17:50:47.556: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
Dec  4 17:50:47.556: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=2798283, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
Dec  4 17:50:47.556: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=1

 

Regards,

Y

 

HiSo in this case sorry for

Hi

So in this case sorry for late reply.

Please post all your config to analyze it better.

I saw a matched dialpeer 1 that I didn't see in your first post 

 

Thanks

 

regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Beginner

Hi Carlo,My apologies for

Hi Carlo,

My apologies for posting this late.

Please find below;


version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
!
boot-start-marker
boot system flash0:c3900e-universalk9-mz.SPA.151-4.M2.bin
boot-end-marker
!
!
card type e1 0 0
no logging console

!
!
!
!
!
aaa session-id common
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
network-clock-participate wic 0
no ipv6 cef
ip source-route
!
!
ip cef
!
!
!
ip domain name xxxxxx.ads
ip name-server xx.56.153.xx
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!


voice-card 0
 dspfarm
 dsp services dspfarm
!
!
voice rtp send-recv
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol pass-through g711alaw
 h323
 modem passthrough nse codec g711alaw
 sip
  registrar server expires max 3600 min 3600
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice logout-profile 1
 pin 1234
 user 100 password cisco
 number 100 type normal
!
!
!
voice translation-rule 1
 rule 1 /\(..$\)/ /27982\0/
!
voice translation-rule 2
 rule 1 /^0/ //
!
voice translation-rule 3
 rule 1 /^9/ //
!
voice translation-rule 4
 rule 1 /2798283/ /83/
!
voice translation-rule 1001
 rule 1 reject /^000/
 rule 2 reject /^900/
!
!
voice translation-profile AA-Incoming
 translate called 1
!
voice translation-profile BLOCK
 translate called 1001
!
voice translation-profile profile1
 translate calling 1
!
voice translation-profile profile2
 translate calling 1
 translate called 2
!
voice translation-profile profile3
 translate called 3
!
!
!
application
 service aa_VIP flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  paramspace english language en
  param handoff-string aa_VIP
  param max-time-call-retry 60
  paramspace english location flash:
  param service-name queue
  param aa-pilot 27799282
  param welcome-prompt _bacd_welcome.au
  param number-of-hunt-grps 1
  param call-retry-timer 15
 !
 service queue flash:app-b-acd-3.0.0.2.tcl
  param queue-len 15
  paramspace english language en
  paramspace english index 0
  paramspace english location flash
  param aa-hunt1 1998
  param queue-manager-debugs 1
  param aa-hunt2 1999
  param number-of-hunt-grps 2
 !
 service aa_CS flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  paramspace english language en
  param service-name queue
  param aa-pilot 27799283
  param welcome-prompt _bacd_welcome.au
  paramspace english location flash:
  param number-of-hunt-grps 1
  param call-retry-timer 15
  param handoff-string aa_CS
  param max-time-call-retry 60
 !
!
license udi pid C3900-SPE200/K9 sn FOC15411EUL
!
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
hw-module sm 1
!
archive
 path flash0:/ARCHIVED-CONFIG/capelin-01-archived_
 maximum 14
 write-memory
 time-period 2880

!
redundancy
!
!
controller E1 0/0/0
 pri-group timeslots 1-31
!
controller E1 0/0/1
 pri-group timeslots 1-31
!
!
!
!
!
interface GigabitEthernet0/0
 backup interface GigabitEthernet0/1
 ip address 10.127.15.130 255.255.255.128
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.127.15.130 255.255.255.128
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address xx.165.161.xx 255.255.255.240
 ip access-group 101 in
 duplex full
 speed auto
!
interface GigabitEthernet0/3
 ip address 192.168.100.1 255.255.255.0
 duplex full
 speed auto
!
interface GigabitEthernet0/3.1
 shutdown
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 shutdown
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/0/1:15
 no ip address
 encapsulation hdlc
 shutdown
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface SM1/0
 description *** Interface on CME connecting to the CUE module ***
 ip address 10.100.100.2 255.255.255.0
 service-module ip address 10.100.100.1 255.255.255.0
 !Application: CUE Running on SM
 service-module ip default-gateway 10.100.100.1
!
interface SM1/1
 description Internal switch interface connected to Service Module
 no ip address
!
interface Vlan1
 description $ES_LAN$
 no ip address
!
ip forward-protocol nd
!
ip http server
ip http authentication aaa
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash0:/GUI
!
ip route 0.0.0.0 0.0.0.0 10.127.15.129
ip route 10.100.100.1 255.255.255.255 SM1/0
ip route 10.127.15.139 255.255.255.255 SM1/0
ip route 84.XX.XX.126 255.255.255.255 xx.165.161.xx
!

access-list 101 permit udp host 84.XX.XX.126 any eq 5060
access-list 101 permit udp any any range 16384 32767
!
nls resp-timeout 1
cpd cr-id 1
!

tftp-server flash0:Phones/7935/P00503010800.bin alias P00503010800.bin
tftp-server flash0:Phones/Ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash0:Phones/Ringtones/Analog2.raw alias Analog2.raw
tftp-server flash0:Phones/Ringtones/Analog1.raw alias Analog1.raw
tftp-server flash0:Phones/Ringtones/Bass.raw alias Bass.raw
tftp-server flash0:Phones/Ringtones/CallBack.raw alias CallBack.raw
tftp-server flash0:Phones/Ringtones/Chime.raw alias Chime.raw
tftp-server flash0:Phones/Ringtones/Classic1.raw alias Classic1.raw
tftp-server flash0:Phones/Ringtones/Classic2.raw alias Classic2.raw
tftp-server flash0:Phones/Ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash0:Phones/Ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash0:Phones/Ringtones/Drums1.raw alias Drums1.raw
tftp-server flash0:Phones/Ringtones/Drums2.raw alias Drums2.raw
tftp-server flash0:Phones/Ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash0:Phones/Ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash0:Phones/Ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash0:Phones/Ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash0:Phones/Ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash0:Phones/Ringtones/Piano1.raw alias Piano1.raw
tftp-server flash0:Phones/Ringtones/Piano2.raw alias Piano2.raw
tftp-server flash0:Phones/Ringtones/Pop.raw alias Pop.raw
tftp-server flash0:Phones/Ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash0:Phones/Ringtones/Ring1.raw alias Ring1.raw
tftp-server flash0:Phones/Ringtones/Ring2.raw alias Ring2.raw
tftp-server flash0:Phones/Ringtones/Ring3.raw alias Ring3.raw
tftp-server flash0:Phones/Ringtones/Ring4.raw alias Ring4.raw
tftp-server flash0:Phones/Ringtones/Ring5.raw alias Ring5.raw
tftp-server flash0:Phones/Ringtones/Ring6.raw alias Ring6.raw
tftp-server flash0:Phones/Ringtones/Ring7.raw alias Ring7.raw
tftp-server flash0:Phones/Ringtones/RingList.xml alias RingList.xml
tftp-server flash0:Phones/Ringtones/Sax1.raw alias Sax1.raw
tftp-server flash0:Phones/Ringtones/Sax2.raw alias Sax2.raw
tftp-server flash0:Phones/Ringtones/Vibe.raw alias Vibe.raw
tftp-server flash0:locale/g3-tones.xml alias United_Kingdom/g3-tones.xml
tftp-server flash0:locale/mk-sccp.jar alias English_United_States/mk-sccp.jar
tftp-server flash0:/Phones/7941_7961/apps41.9-1-1TH1-16.sbn alias apps41.9-1-1TH1-16.sbn
tftp-server flash0:/Phones/7941_7961/cnu41.9-1-1TH1-16.sbn alias cnu41.9-1-1TH1-16.sbn
tftp-server flash0:/Phones/7941_7961/cvm41sccp.9-1-1TH1-16.sbn alias cvm41sccp.9-1-1TH1-16.sbn
tftp-server flash0:/Phones/7941_7961/dsp41.9-1-1TH1-16.sbn alias dsp41.9-1-1TH1-16.sbn
tftp-server flash0:/Phones/7941_7961/jar41sccp.9-1-1TH1-16.sbn alias jar41sccp.9-1-1TH1-16.sbn
tftp-server flash0:/Phones/7941_7961/SCCP41.9-1-1SR1S.loads alias SCCP41.9-1-1SR1S.loads
tftp-server flash0:/Phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash0:/Phones/7941_7961/term61.default.loads alias term61.default.loads
tftp-server flash0:Desktops/320x212x12/List.xml
tftp-server flash0:Desktops/320x212x12/fortanne.png alias Desktops/320x212x12/fortanne.png
tftp-server flash0:Desktops/320x196x4/List.xml alias Desktops/320x196x4/List.xml
tftp-server flash0:Desktops/320x196x4/fortanne.png alias Desktops/320x196x4/fortanne.png
tftp-server flash0:ATA030204SCCP090202A.zup
!
!
!
control-plane
!
!
voice-port 0/0/0:15
 shutdown
!
voice-port 0/0/1:15
 shutdown
!
!
!
mgcp profile default
!
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 5
 shutdown
!
dial-peer voice 5887 voip
 description **CUE Voicemail**
 destination-pattern 5887
 b2bua
 session protocol sipv2
 session target ipv4:10.100.100.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 1 voip
 description **Incoming Call from SIP Trunk**
 destination-pattern 27982..
 session protocol sipv2
 session target sip-server
 incoming called-number .%
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 3 voip
 description Internal Calls to Boorfields 1530-1599
 destination-pattern 15[3-9].
 session protocol sipv2
 session target ipv4:10.4.1.1
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 7 voip
 translation-profile outgoing profile2
 destination-pattern 02[0-3,5,7][0-9].....
 session protocol sipv2
 session target ipv4:84.XX.XX.126
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 8 voip
 translation-profile outgoing profile2
 destination-pattern 099......
 session protocol sipv2
 session target ipv4:84.XX.XX.126
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 9 voip
 translation-profile outgoing profile2
 destination-pattern 07[7,9]......
 session protocol sipv2
 session target ipv4:84.XX.XX.126
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 2 voip
 description **Outgoing SIP trunk calls to International**
 translation-profile outgoing profile2
 destination-pattern 000T
 session protocol sipv2
 session target ipv4:84.XX.XX.126
 dtmf-relay rtp-nte
 codec g711alaw
 fax rate disable
 no vad
!
dial-peer voice 4 voip
 description Internal Calls to Boorfields
 destination-pattern 1[6-8]..
 session protocol sipv2
 session target ipv4:10.4.1.1
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 10 voip
 description **Outgoing Call to SIP Trunk for Freephone Numbers**
 translation-profile outgoing profile2
 destination-pattern 0800.....
 session protocol sipv2
 session target ipv4:84.XX.XX.126
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 110 voip
 service aa_cs
 incoming called-number 2798282
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
dial-peer voice 100 voip
 service aa_vip
 incoming called-number 2798282
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
!
num-exp 3562798247 47
num-exp 3562798255 55
num-exp 3562798283 83
num-exp 3562798282 82

sip-ua
 retry invite 4
 timers connect 100
 sip-server ipv4:84.XX.XX.126
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 authentication credential secretname emapp
 em keep-history
 em logout 2:30
 max-ephones 100
 max-dn 500
 ip source-address 10.127.15.130 port 2000
 caller-id block code *8888
 service phone webAccess 0
 system message XXXX
 url messages http://10.100.100.1/voiceview/common/login.do
 url services http://10.100.100.1/voiceview/common/login.do
 url authentication http://10.127.15.130/CCMCIP/authenticate.asp secretname emapp
 load 7937 P00503010800.bin
 load 7941 term41.default.loads
 load 7961 term61.default.loads
 load ata ATA030204SCCP090202A
 time-zone 28
 time-format 24
 date-format dd-mm-yy
 keepalive 10
 voicemail 5887
 max-conferences 8 gain -6
 call-forward pattern .T
 hunt-group logout HLog
 moh music-on-hold.au
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 transfer-pattern 27799283 blind
 secondary-dialtone 0
 night-service code *99
 create cnf-files version-stamp 7960 Dec 04 2014 19:35:15
!
!
ephone-template  1
 softkeys idle  Redial Gpickup Pickup Cfwdall Dnd
 softkeys seized  Endcall Redial Gpickup Pickup Cfwdall
 softkeys connected  Endcall Hold Trnsfer
!
!
!
ephone-dn  3  dual-line
 number 38 no-reg primary
 label George XXXXX
 name George XXXXX

!
!
ephone-dn  42  dual-line
 number 47 no-reg primary
 label Meeting room 2
 name Meeting room 2

ephone-dn  63  dual-line
 number 63 no-reg primary
 label Shane XXXXX
 name Shane XXXXX

!
!
ephone-dn  71  dual-line
 number 71 no-reg primary
 label Stuart XXXXX
 name Stuart XXXXX
!
!
ephone-dn  72  dual-line
 number 72 no-reg primary
 label Sam K. A. XXXXX
 name Sam K. A. XXXXX
!
!
ephone-dn  74  dual-line
 number 74 no-reg primary
 label Charlotte XXXXX
 name Charlotte XXXXX
!
!
ephone-dn  75  dual-line
 number 75 no-reg primary
 label Andrew XXXXX
 name Andrew XXXXX
!
!
ephone-dn  76  dual-line
 number 76 no-reg primary
 label Jake XXXXX
 name Jake XXXXX
!
!
ephone-dn  77  dual-line
 number 77 no-reg primary
 label Theodoros XXXXX
 name Theodoros XXXXX
!
!
ephone-dn  100
 number 5888..
 mwi on
!
!
ephone-dn  101
 number 5889..
 mwi off
!
!
ephone  1
 mac-address 001E.F7C4.B6D5
 type 7941
 button  1:1
!
!
!
ephone  2
 mac-address 001E.F7C4.B69B
 type 7941
 button  1:2
!
!
!
ephone  3
 mac-address 0017.5ACC.832C
 ephone-template 1
 type 7941
 button  1:3
!
!
!
ephone  4
 mac-address 001E.F7C4.B616
 type 7941
 button  1:4
!
!
!
ephone  5
 mac-address 001B.54CA.C420
 type 7941
 button  1:5
!
!
!
ephone  6
 mac-address ECC8.82B0.EE61
 type 7942
 button  1:6
!
!
!
ephone  7
 mac-address 0017.5A95.DF48
 type 7941
 button  1:7
!
!
!
ephone  8
 mac-address 0017.5A5B.3F72
 type 7941
 button  1:8
!
!
!
ephone  9
 mac-address 0017.94F9.532E
 type 7941
 button  1:9
!
!
!
ephone  10
 mac-address 0017.5A95.DDF3
 type 7941
 button  1:10
!
!
!

!
!
ephone  71
 mac-address 0017.5A95.E10B
 ephone-template 1
 type 7941
 button  1:71
!
!
!
ephone  72
 mac-address 0027.0D3D.F2B2
 ephone-template 1
 type 7941
 button  1:72
!
!
!
ephone  74
 mac-address 0027.0D3D.F06D
 ephone-template 1
 type 7941
 button  1:74
!
!
!
ephone  75
 mac-address 0017.5A95.DE7D
 ephone-template 1
 type 7941
 button  1:75
!
!
!
ephone  76
 mac-address 001E.F7C4.B6C0
 ephone-template 1
 type 7941
 button  1:76
!
!
!
ephone  77
 mac-address 0017.9551.FB1D
 ephone-template 1
 type 7941
 button  1:77
!
!
ephone-hunt 1 longest-idle
 pilot 1988
 list 63, 67, 38
 timeout 10, 10, 10
!
!
ephone-hunt 2 longest-idle
 pilot 1999
 list 71, 72, 74, 75, 76
 timeout 10, 10, 10, 10, 10
!
!
!

!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 transport input ssh
line vty 5 15
 privilege level 15
 transport input ssh
!
scheduler allocate 20000 1000
ntp server 10.127.14.65
end


Thanks,

Y

Hi.Ok Iet's add what follows

Hi.

Ok Iet's add what follows on dial peers 100 and 110

 

dial-peer voice 100

session protocol sipv2

 

dial-peer voice 110

session protocol sipv2

 

Let me know

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Beginner

Hi Carlo,Still no luck

Hi Carlo,

Still no luck unfortunately. Still getting fast busy signal and no output for debug voip application script.

I believe there is no need to re-introduce dial-peers 7836 & 7837 with the additions of 100 and 110?

 

Regards,

Y

Hi.Please activate a debug

Hi.

Please activate a debug ccsip message and debug voip diaper inout and post the output.

 

Thanks

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Beginner

Thanks Carlo,Please find

Thanks Carlo,

Please find below,

/-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=2798282, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  5 13:05:27.246: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=2798282
Dec  5 13:05:27.246: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
Dec  5 13:05:27.246: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=2798282, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
Dec  5 13:05:27.246: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=1
Dec  5 13:05:27.246: //193/377215D782B9/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 84.xx.xx.126:5060;branch=z9hG4bK-23eb56-8c4f4b97-69386b6e
From: <sip:442071841530@XX.165.161.XX:5060;transport=UDP>;tag=49cb680-7f000001-13c4-23eb56-989349d0-23eb56
To: <sip:2798282@XX.165.161.XX:5060>
Date: Fri, 05 Dec 2014 13:05:27 GMT
Call-ID: 4a13c08-7f000001-13c4-23eb56-93ebdb14-23eb56@XX.165.161.XX
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Dec  5 13:05:27.246: //193/377215D782B9/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 84.xx.xx.126:5060;branch=z9hG4bK-23eb56-8c4f4b97-69386b6e
From: <sip:442071841530@XX.165.161.XX:5060;transport=UDP>;tag=49cb680-7f000001-13c4-23eb56-989349d0-23eb56
To: <sip:2798282@XX.165.161.XX:5060>;tag=431B740-BBE
Date: Fri, 05 Dec 2014 13:05:27 GMT
Call-ID: 4a13c08-7f000001-13c4-23eb56-93ebdb14-23eb56@XX.165.161.XX
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=16
Content-Length: 0


Dec  5 13:05:27.266: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:2798282@XX.165.161.XX:5060;transport=UDP SIP/2.0
From: <sip:442071841530@XX.165.161.XX:5060;transport=UDP>;tag=49cb680-7f000001-13c4-23eb56-989349d0-23eb56
To: <sip:2798282@XX.165.161.XX:5060>;tag=431B740-BBE
Call-ID: 4a13c08-7f000001-13c4-23eb56-93ebdb14-23eb56@XX.165.161.XX
CSeq: 1 ACK
Via: SIP/2.0/UDP 84.xx.xx.126:5060;branch=z9hG4bK-23eb56-8c4f4b97-69386b6e
Max-Forwards: 70
Supported: 100rel,replaces
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
User-Agent: ADTRAN_Netvanta_6310/R10.9.4.E
Contact: <sip:442071841530@84.255.6.126:5060;transport=UDP>
Content-Length: 0

 

Regards,

Y

Hi.The  output of the debug

Hi.

The  output of the debug voip dialpeer inout seems incomplete.

Please activate it again and post the full output.

Thanks

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"
Beginner

Hi Carlo,Thanks, please find

Hi Carlo,

Thanks, please find below;

 


-1/D034B85E82D9/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
Dec  5 14:49:56.488: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=2798282, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  5 14:49:56.488: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=2798282
Dec  5 14:49:56.488: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
Dec  5 14:49:56.488: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=2798282, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
Dec  5 14:49:56.488: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=1
Dec  5 14:49:56.490: //201/D034B85E82D9/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 84.XX.XX.126:5060;branch=z9hG4bK-2403d3-8caef200-ebf48a4
From: <sip:442071841530@xx.165.161.xx:5060;transport=UDP>;tag=49c09b8-7f000001-13c4-2403d3-ec85af7b-2403d3
To: <sip:2798282@xx.165.161.xx:5060>
Date: Fri, 05 Dec 2014 14:49:56 GMT
Call-ID: 4a11d08-7f000001-13c4-2403d3-d9eae47a-2403d3@xx.165.161.xx
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Dec  5 14:49:56.490: //201/D034B85E82D9/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 84.XX.XX.126:5060;branch=z9hG4bK-2403d3-8caef200-ebf48a4
From: <sip:442071841530@xx.165.161.xx:5060;transport=UDP>;tag=49c09b8-7f000001-13c4-2403d3-ec85af7b-2403d3
To: <sip:2798282@xx.165.161.xx:5060>;tag=4915904-1FA3
Date: Fri, 05 Dec 2014 14:49:56 GMT
Call-ID: 4a11d08-7f000001-13c4-2403d3-d9eae47a-2403d3@xx.165.161.xx
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=16
Content-Length: 0


Dec  5 14:49:56.512: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:2798282@xx.165.161.xx:5060;transport=UDP SIP/2.0
From: <sip:442071841530@xx.165.161.xx:5060;transport=UDP>;tag=49c09b8-7f000001-13c4-2403d3-ec85af7b-2403d3
To: <sip:2798282@xx.165.161.xx:5060>;tag=4915904-1FA3
Call-ID: 4a11d08-7f000001-13c4-2403d3-d9eae47a-2403d3@xx.165.161.xx
CSeq: 1 ACK
Via: SIP/2.0/UDP 84.XX.XX.126:5060;branch=z9hG4bK-2403d3-8caef200-ebf48a4
Max-Forwards: 70
Supported: 100rel,replaces
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
User-Agent: ADTRAN_Netvanta_6310/R10.9.4.E
Contact: <sip:442071841530@84.XX.XX.126:5060;transport=UDP>
Content-Length: 0


Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:2798282@xx.165.161.xx:5060 SIP/2.0
From: <sip:442071841530@xx.165.161.xx:5060;transport=UDP>;tag=49b9d10-7f000001-13c4-2403d7-9cbc3ee3-2403d7
To: <sip:2798282@xx.165.161.xx:5060>
Call-ID: 4a07c38-7f000001-13c4-2403d7-d810f302-2403d7@xx.165.161.xx
CSeq: 1 INVITE
Via: SIP/2.0/UDP 84.XX.XX.126:5060;branch=z9hG4bK-2403d7-8caf0033-a08af5c
Max-Forwards: 70
Supported: 100rel,replaces
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
User-Agent: ADTRAN_Netvanta_6310/R10.9.4.E
Contact: <sip:442071841530@84.XX.XX.126:5060;transport=UDP>
Content-Type: application/sdp
Content-Length: 193

v=0
o=- 1536890987 0 IN IP4 84.XX.XX.126
s=-
c=IN IP4 84.XX.XX.126
t=0 0
m=audio 10974 RTP/AVP 8 101
a=ptime:20
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15

Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=2798282, Called Number=2798282, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=2798282
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=2798282, saf_enabled=1, saf_dndb_lookup=1, dp_result=0
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=1
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=442071841530, Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=NO_MATCH(-1) After All Match Rules Attempt
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=442071841530, Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=NO_MATCH(-1) After All Match Rules Attempt
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
Dec  5 14:50:00.123: //-1/D25F64A782DE/DPM/dpAssociateIncomingPeerCore:
   Calling Number=442071841530, Called Number=2798282, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
Dec  5 14:50:00.123: //-1/D25F64A782DE/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=100
Dec  5 14:50:00.123: //-1/D25F64A782DE/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=2798282, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=2798282
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=2798282, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
Dec  5 14:50:00.123: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=1
Dec  5 14:50:00.125: //202/D25F64A782DE/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 84.XX.XX.126:5060;branch=z9hG4bK-2403d7-8caf0033-a08af5c
From: <sip:442071841530@xx.165.161.xx:5060;transport=UDP>;tag=49b9d10-7f000001-13c4-2403d7-9cbc3ee3-2403d7
To: <sip:2798282@xx.165.161.xx:5060>
Date: Fri, 05 Dec 2014 14:50:00 GMT
Call-ID: 4a07c38-7f000001-13c4-2403d7-d810f302-2403d7@xx.165.161.xx
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Dec  5 14:50:00.125: //202/D25F64A782DE/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 84.XX.XX.126:5060;branch=z9hG4bK-2403d7-8caf0033-a08af5c
From: <sip:442071841530@xx.165.161.xx:5060;transport=UDP>;tag=49b9d10-7f000001-13c4-2403d7-9cbc3ee3-2403d7
To: <sip:2798282@xx.165.161.xx:5060>;tag=4916736-638
Date: Fri, 05 Dec 2014 14:50:00 GMT
Call-ID: 4a07c38-7f000001-13c4-2403d7-d810f302-2403d7@xx.165.161.xx
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=16
Content-Length: 0


Dec  5 14:50:00.147: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:2798282@xx.165.161.xx:5060;transport=UDP SIP/2.0
From: <sip:442071841530@xx.165.161.xx:5060;transport=UDP>;tag=49b9d10-7f000001-13c4-2403d7-9cbc3ee3-2403d7
To: <sip:2798282@xx.165.161.xx:5060>;tag=4916736-638
Call-ID: 4a07c38-7f000001-13c4-2403d7-d810f302-2403d7@xx.165.161.xx
CSeq: 1 ACK
Via: SIP/2.0/UDP 84.XX.XX.126:5060;branch=z9hG4bK-2403d7-8caf0033-a08af5c
Max-Forwards: 70
Supported: 100rel,replaces
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, REGISTER
User-Agent: ADTRAN_Netvanta_6310/R10.9.4.E
Contact: <sip:442071841530@84.XX.XX.126:5060;transport=UDP>
Content-Length: 0


Regards,

Y

Hi.Can you please remove 

Hi.

Can you please remove  destination-pattern 27982. from dialpeer 1 and try again?

 

Let me know

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Beginner

Thanks Carlo,I removed it and

Thanks Carlo,

I removed it and I still get a fast busy signal not only the AA pilot but also for all other extensions, which was working before but once I put it back, I can successfully make calls to the other DDi's.

 

Regards,

Y

 

Hi.I think I've found the

Hi.

I think I've found the issue.

aa-pilot are mistyped 

they are defined as 27799282 and should be 2798282 and 27799283 should be 2798283

Change aa-pilot accordingly and let me know 

 

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Beginner

Hi Carlo,Many Thanks but its

Hi Carlo,

Many Thanks but its not that, that was a typo when I was editing the output.

However I think it might have to do with the fact that there is already an inbuilt application, however I downloaded another from Cisco and extracted this and saved to flash.

sh call application active app-level
Application level active Info:


Application name:              app-b-acd-aa
URL:                           builtin:app_b_acd_aa_script.tcl
Total sessions:                                 0

Application name:              app-b-acd
URL:                           builtin:app_b_acd_script.tcl

 


Application name:              aa_VIP
URL:                           flash:app-b-acd-aa-3.0.0.2.tcl
Total sessions:                                 0

Application name:              queue
URL:                           flash:app-b-acd-3.0.0.2.tcl
Total sessions:                                 0

Application name:              aa_CS
URL:                           flash:app-b-acd-aa-3.0.0.2.tcl

 


Total sessions:                                 0

This isn't in the flash. I'm unable to find in sh flash output.

Dont think its in a tftp server either though this cme was being used at a decommissioned location previously the guys that set it up have since left.

How can I find the location of this?

Regards,

Y

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards