cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1428
Views
0
Helpful
4
Replies
Highlighted
Beginner

TFTP error on 3925 intergrated voice router

We have a 3925 intergrated voice router that prompts this error  cmapp_sccp_tftp_download_file: Unable to get configuration file size tftp://x.x.x.x/SKIGxxxxxx.cnf.xml, rc=-2

It gives the IP to our call manager then a mac address of analog gatway and extension pertaining to cnf.xml. The error runs when the  router  is connected to the network and also when it is not connected to the network. I have looked in the Cisco bug toolkit did not find a bug that was related to the issue. I check the tftp in the call manager there is no file of that type which there should not be. We have 3925s voice routers already registered to the call manager. Voice router information below:

 

Cisco IOS Software, C3900e Software (C3900e-UNIVERSALK9-M), Version 15.2(4)M2, RELEASE SOFTWARE (fc2)

System image file is "flash:c3900e-universalk9-mz.SPA.152-4.M2.bin"

Cisco CISCO3925-CHASSIS (revision 1.0) with C3900-SPE200/K9 with 1797120K/300032K bytes of memory

 

4 REPLIES 4
Highlighted
Rising star

Hi,

 

Are you using the 3925 as a CME? If yes, could you please post the config.

Regards

Highlighted

No, we are not using as CME.

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2015.03.26 11:13:02 =~=~=~=~=~=~=~=~=~=~=~=

XXXXXXXX#

XXXXXX#term len 0

XXXXXXXX#sh run

Building configuration...

 

Current configuration : 14446 bytes

!

! Last configuration change

! NVRAM

! NVRAM

version 15.2

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

service sequence-numbers

!

hostname XXXXXXX

!

boot-start-marker

boot system flash:c3900e-universalk9-mz.SPA.152-4.M2.bin

boot-end-marker

!

!

card type t1 0 0

logging buffered 16384

enable secret 4 DJsu7i99xp.Xzvkf3epKdaTCS5CUguxaCh2jhXROMZ.

!

aaa new-model

!

!

aaa authentication login default group tacacs+ local

aaa authentication enable default group tacacs+ enable

aaa authorization console

aaa authorization exec default group tacacs+ if-authenticated

aaa authorization commands 15 default group tacacs+ none

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting connection default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

!

!

!

!

!

aaa session-id common

clock timezone CST -6 0

clock summer-time CDT recurring

!

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

ip cef

!

!

!

!

 

!

!

!

!

no ip domain lookup

ip domain name textron.com

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-dms100

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice rtp send-recv

!

voice service pots

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g729br8

!

!

!

!

voice translation-rule 1

rule 1 /3451/ /918005336093/

!

voice translation-rule 2

rule 1 /^\(4...\)$/ /XXXXXX\1/

rule 2 /^\(6...\)$/ /XXXXXX\1/

!

!

voice translation-profile 5-digit-dial

translate called 1

!

voice translation-profile pstn-in

translate called 2

!

!

!

!

application

global

service alternate default

!

!

license udi pid

!

!

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

hw-module pvdm 0/2

!

vtp domain BHAMA

vtp mode transparent

!

redundancy

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24 service mgcp

description

!

controller T1 0/0/1

cablelength long 0db

pri-group timeslots 1-24 service mgcp

description

!

csdb tcp synwait-time 30

csdb tcp idle-time 3600

csdb tcp finwait-time 5

csdb tcp reassembly max-memory 1024

csdb tcp reassembly max-queue-length 16

csdb udp idle-time 30

csdb icmp idle-time 10

csdb session max-session 65535

!

!

!

!

interface Loopback0

ip address

!

interface Loopback11

description

ip address

!

interface GigabitEthernet0/0

description

ip address

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

description

ip address 1

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/3

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

description

no ip address

encapsulation hdlc

isdn switch-type primary-dms100

isdn incoming-voice voice

isdn map address .* plan isdn type national

no cdp enable

!

interface Serial0/0/1:23

description

no ip address

encapsulation hdlc

isdn switch-type primary-dms100

isdn incoming-voice voice

isdn map address .* plan isdn type national

no cdp enable

!

!

!

router eigrp 1

network 10.0.0.0

redistribute connected

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip tacacs source-interface Loopback11

!

logging trap notifications

logging facility local1

logging source-interface Loopback11

logging host

logging host

logging host

logging host

logging host

access-list 18 permit

access-list 18 permit

access-list 18 permit

access-list 18 permit

access-list 86 permit

access-list 86 permit

access-list 86 permit

access-list 86 permit

access-list 89 permit

access-list 89 permit

access-list 89 permit

!

nls resp-timeout 1

cpd cr-id 1

!

snmp-server community

snmp-server community

snmp-server ifindex persist

snmp-server trap-source Loopback11

snmp-server locatiON

snmp-server contact

snmp-server system-shutdown

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps vrrp

snmp-server enable traps flowmon

snmp-server enable traps transceiver all

snmp-server enable traps ds1

snmp-server enable traps call-home message-send-fail server-fail

snmp-server enable traps tty

snmp-server enable traps eigrp

snmp-server enable traps gatekeeper

snmp-server enable traps xgcp

snmp-server enable traps license

snmp-server enable traps ethernet cfm cc mep-up mep-down cross-connect loop config

snmp-server enable traps ethernet cfm crosscheck mep-missing mep-unknown service-up

snmp-server enable traps flash insertion removal

snmp-server enable traps auth-framework sec-violation

snmp-server enable traps ds3

snmp-server enable traps entity-sensor threshold

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps isdn chan-not-avail

snmp-server enable traps isdn ietf

snmp-server enable traps adslline

snmp-server enable traps vdsl2line

snmp-server enable traps c3g

snmp-server enable traps icsudsu

snmp-server enable traps envmon

snmp-server enable traps ds0-busyout

snmp-server enable traps ds1-loopback

snmp-server enable traps energywise

snmp-server enable traps vstack

snmp-server enable traps mac-notification

snmp-server enable traps aaa_server

snmp-server enable traps atm subif

snmp-server enable traps cef resource-failure peer-state-change peer-fib-state-change inconsistency

snmp-server enable traps memory bufferpeak

snmp-server enable traps cnpd

snmp-server enable traps config-copy

snmp-server enable traps config

snmp-server enable traps config-ctid

snmp-server enable traps entity

snmp-server enable traps fru-ctrl

snmp-server enable traps resource-policy

snmp-server enable traps event-manager

snmp-server enable traps frame-relay multilink bundle-mismatch

snmp-server enable traps frame-relay

snmp-server enable traps frame-relay subif

snmp-server enable traps hsrp

snmp-server enable traps ipmulticast

snmp-server enable traps msdp

snmp-server enable traps mvpn

snmp-server enable traps nhrp nhs

snmp-server enable traps nhrp nhc

snmp-server enable traps nhrp nhp

snmp-server enable traps nhrp quota-exceeded

snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message

snmp-server enable traps pppoe

snmp-server enable traps cpu threshold

snmp-server enable traps rsvp

snmp-server enable traps syslog

snmp-server enable traps l2tun session

snmp-server enable traps l2tun pseudowire status

snmp-server enable traps vtp

snmp-server enable traps bstun

snmp-server enable traps dlsw

snmp-server enable traps ipsla

snmp-server enable traps stun

snmp-server enable traps bfd

snmp-server enable traps bulkstat collection transfer

snmp-server enable traps mpls traffic-eng

snmp-server enable traps mpls fast-reroute protected

snmp-server enable traps mpls rfc ldp

snmp-server enable traps mpls ldp

snmp-server enable traps pw vc

snmp-server enable traps ipmobile

snmp-server enable traps snasw alert isr topology cp-cp port link dlus

snmp-server enable traps dial

snmp-server enable traps dsp card-status

snmp-server enable traps dsp oper-state

snmp-server enable traps dsp video-usage

snmp-server enable traps dsp video-out-of-resource

snmp-server enable traps ethernet cfm alarm

snmp-server enable traps rf

snmp-server enable traps vrfmib vrf-up vrf-down vnet-trunk-up vnet-trunk-down

snmp-server enable traps mpls vpn

snmp-server enable traps ccme

snmp-server enable traps srst

snmp-server enable traps voice

snmp-server enable traps dnis

snmp-server host

snmp-server host

snmp-server host

tacacs-server host

tacacs-server host

tacacs-server host

tacacs-server host

tacacs-server key

!

!

!

control-plane

!

!

voice-port 0/0/0:23

!

voice-port 0/0/1:23

!

!

!

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.244.200.33 10.227.210.33

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold bind Loopback11

ccm-manager config server X.X.X.X. X.X.X.X X.X.X.X

ccm-manager config

ccm-manager sccp local Loopback11

!

mgcp

mgcp call-agent X.X.X.X. 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability mf-package

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package line-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp fax t38 nsf 000000

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface Loopback11

mgcp bind media source-interface Loopback11

!

mgcp profile default

!

sccp local Loopback11

sccp ccm X.X.X.X identifier 1 priority 1 version 7.0

sccp ccm X.X.X.X identifier 2 priority 2 version 7.0

sccp ccm X.X.X.X identifier 3 priority 3 version 7.0

sccp ip precedence 3

!

sccp ccm group 1

bind interface Loopback11

associate ccm 1 priority 1

associate ccm 2 priority 2

associate ccm 3 priority 3

associate profile 2 register Amarillo_XCODE

associate profile 3 register Amarillo_MTP

associate profile 1 register Amarillo_CNFB

switchback method graceful

switchback interval 8

!

dspfarm profile 1 transcode

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

maximum sessions 20

associate application SCCP

!

dspfarm profile 2 conference

codec g729br8

codec g729r8

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

maximum sessions 8

associate application SCCP

!

dspfarm profile 3 mtp

codec g711ulaw

codec pass-through

maximum sessions hardware 42

maximum sessions software 200

associate application SCCP

!

dial-peer voice 1 pots

translation-profile incoming pstn-in

incoming called-number .

direct-inward-dial

!

dial-peer voice 10 pots

destination-pattern 9[2-9]11

port 0/0/0:23

forward-digits 3

!

dial-peer voice 11 pots

preference 1

destination-pattern 9[2-9]11

port 0/0/1:23

forward-digits 3

!

dial-peer voice 12 pots

destination-pattern 911

port 0/0/0:23

forward-digits 3

!

dial-peer voice 13 pots

preference 1

destination-pattern 911

port 0/0/1:23

forward-digits 3

!

dial-peer voice 20 pots

destination-pattern 9[2-9].........

port 0/0/0:23

forward-digits 10

!

dial-peer voice 21 pots

preference 1

destination-pattern 9[2-9].........

port 0/0/1:23

forward-digits 10

!

dial-peer voice 30 pots

destination-pattern 91[2-9]..[2-9]......

port 0/0/0:23

forward-digits 11

!

dial-peer voice 31 pots

preference 1

destination-pattern 91[2-9]..[2-9]......

port 0/0/1:23

forward-digits 11

!

dial-peer voice 40 pots

destination-pattern 9011T

port 0/0/0:23

prefix 011

!

dial-peer voice 41 pots

preference 1

destination-pattern 9011T

port 0/0/1:23

prefix 011

!

dial-peer voice 50 pots

incoming called-number .

direct-inward-dial

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

ip source-address X.X.X.X port 2000

max-ephones 700

max-dn 1400 octo-line

system message primary Operating in SRST mode

system message secondary In SRST mode

transfer-pattern .T

voicemail XXXXXXXXXXXX

translation-profile incoming 5-digit-dial

call-forward pattern .T

call-forward busy XXXXXXX

call-forward noan XXXXXXXX timeout 10

time-zone 8

!

!

banner exec ^C

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

^C

banner login ^C

******************* WARNING NOTICE *******************

^C

!

line con 0

exec-timeout 15 0

password

line aux 0

exec-timeout 15 0

password

line vty 0 4

exec-timeout 60 0

password

transport input all

line vty 5 924

exec-timeout 60 0

password

transport input all

!

scheduler allocate 20000 1000

ntp access-group

ntp server

ntp server

ntp server

ntp server

Highlighted

Hi

 

Why are you using "ccm-manager sccp local Loopback11"

If it's not in use , i would suggest remove this command. this is the source of your problem.

 

Regards

Aditya Gupta

 

Highlighted

Actually, the culprit is the 'ccm-manager config' command.  This command is instructing the router to contact the CUCM TFTP server to download the port configuration.  All this does is automatically create the dial-peers that MGCP uses on the router.  Many times, I see engineers manually create the dial-peers and manually enter the 'application MGCPAPP' command.  If you properly configure CUCM and the 'ccm-manager config' command, you don't have to do that.  However, looking at your config, I don't see MGCP doing anything at all. Is this device defined with CUCM as an MGCP gateway?  That would explain why you are getting the error about a missing file.  It would appear the solution is to remove the MGCP configuration altogether.

Content for Community-Ad