cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
188
Views
0
Helpful
7
Replies
Highlighted
Beginner

Transforming dialled number across SIP trunks

Hi,

I have the following setup:  Phone --> CUCM --> SIP Trunk --> CUBE --> ITSP

The SIP trunk to the provider will be used by a number of company offices in Europe. When an outgoing call reaches the CUBE it will be directed to a dial peer that contains a logical trunk to the ITSP. This is achieved by configuring the dial peers with different destination IP addresses which are within the ITSP's network.

Presently, the configuration for the UK is as follows. A user dials a UK mobile number, 907! This matches a route pattern which sends this to a particular route list. Within the detailed route list configuration the digits 44 are added to the called number to distinguish that the call has been placed from the UK.  The call is sent across the CUCM-CUBE SIP trunk and matches an incoming dial peer.  To send the call across the logical SIP trunk from the CUBE to ITSP, an outgoing dial peer with a destination pattern of 449 is matched.  The dial peer uses a translation pattern to remove the 449 before sending to the ITSP.

For other offices to use this infrastructure for example, if a German user places a call, when the call reaches the route list a 49 will be added to the called number. This will match a 499 dial peer on the CUBE, the 499 is stripped and then the number is sent to the destination IP address of the German logical SIP trunk in the ITSP environment.

The problem I face is that when the dialled number reaches the route list, the prefix digits are shown on the phone's display.  Obviously this can be confusing for the users are they are not expecting to see this.

I have tried a number of different ways of trying to hide this but so far all attempts have failed.  With ISDN any changes made at the route list to the dialled number are not displayed on the phone - with SIP it appears to work differently. I need to find a way of just showing the dialled number on the phone.

Any help would be appreciated.

Thanks.

7 REPLIES 7
Highlighted
Engager

Hi,

Hi,

Please check the following document and I hope one of the method may suffice your requirement.

https://supportforums.cisco.com/blog/12726551/connected-number-display-phone

- Vivek

Highlighted
Beginner

Thanks for the reply. I had

Thanks for the reply. I had looked into SIP profiles before but I'm not sure they will work in this instance.

CUCM sends an invite to the CUBE with the CALLED number set with a prefix of 449. To control the phone display, I would need to edit the 100 trying message (and others) sent back from the CUBE to CUCM.

016394: Mar 4 10:38:29.605: //370415/3A82C6000000/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP x.x.x.x:5060;branch=z9hG4bK15941143922a1

From: <sip:+4420385XXXXX@x.x.x.x>;tag=1088353~b10c6c89-a578-4dda-8973-d5ea9c3b13ad-22147666

To: <sip:44907867XXXX@x.x.x.x>

Date: Fri, 04 Mar 2016 10:38:29 GMT

Call-ID: 3a82c600-6d9165a5-14748-bac2b0a@x.x.x.x

CSeq: 101 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-15.4.3.M4

Content-Length: 0

So I created the following profile in the CUBE:

voice class sip-profiles 1000
 response 100 sip-header To modify "<sip:449(.*)@" "<sip:\1@"
 response 183 sip-header To modify "<sip:449(.*)@" "<sip:\1@"
 response 183 sip-header Contact modify "<sip:449(.*)@" "<sip:\1@"
 response 200 sip-header To modify "<sip:449(.*)@" "<sip:\1@"
 response 200 sip-header Contact modify "<sip:449(.*)@" "<sip:\1@"
 request INVITE sip-header To modify "<sip:449(.*)@" "<sip:\1@"

However it doesn't matter under which dial peer I place this, the 100 message received at CUCM from the CUBE always shows the 449 as does the 183 and 200 messages. Consequently the phone shows the called number as 44907XXXX etc.

Highlighted
Engager

Hi,

Hi,

Connected number is controlled through rpid header, so you need to apply SIP profiles only to rpid header and also ensure that you have enabled sending rpid header under sip-ua mode in CUBE.

- Vivek

Highlighted
Beginner

Thanks for the reply.  If I

Thanks for the reply.  If I just enable no remote-party-id under sip-ua and do not use any SIP profiles, then when the call is connected it shows the dialled number without the 9 prefix. I could use a SIP profile to add a 9 to the RPID to show the dialled number on the phone.

However, during the ringing state the phone display is showing 449 as the prefix and it is this part that I want to change to show the called number and not the transformations which have taken place at the route list.

Is this possible?

Thanks.

Highlighted
Engager

rpid header is included in

rpid header is included in 18x responses too. You can check what is sent by CUBE in 18x response and 200 OK under rpid header and then apply the SIP profiles accordingly. 

Did you also look at remote party transformation available at device page?

Other option is to always display original dialed number by changin respective service parameter.

Which option do you feel works best for you?

- Vivek

Highlighted
Beginner

In my 183 message from CUBE

In my 183 message from CUBE to CUCM there is no RPID field.  In the 200 message from CUBE to CUCM there is a RPID field but as the call is connected at this stage the user will have already seen 44907... on the display. This is what I want to avoid.

I looked at remote party transformations on the device and correct me if I am wrong but this is only for calling party transformations? - I want to transform the called party number.

The service parameter change would work but since this is for all calls I'm not sure that somewhere down the line it will break something so I am reluctant to turn this on.

Any other thoughts?

Highlighted
Beginner

I looked at remote party

I looked at remote party transformations on the device and correct me if I am wrong but this is only for calling party transformations? - I want to transform the called party number.

I forgot to turn on the service parameter - confirm that this option does work.

Thanks for your help