cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
6648
Views
11
Helpful
19
Replies
sip.support
Beginner

Trunk E1 Router c2811 to Panasonic TDA600 PBX

Hi, i'm ryan. i wanna ask about my problem here.

There is a topology like this:

Phone_A (extension: 3304) - PBX - Router - Phone_B (FXS - extension 8989).

To connect Router to PBX using E1.

the PBX is a Panasonic TDA600 and connection to the router using PRI Module 30ch,

the Router is C2811 Router include VWIC2-2MFT-T1/E1 for connection to the PBX.

Router and PBX located in one building.

I have configure the router (capture attached). And was able to make calls from Phone_A to Phone_B (direct extension).

the PBX also have been configured, for a number that begins with 89 will be passed to the trunk-group PRI30ch

. From PBX to test the connection to the router, it is checked by calling* 851 from Phone_A, if the connection is correct, then Phone_A will receive a long tone,and now it was successful & no problem.

Now the problem is, Phone_A can not directly dial the extension of Phone_B (appears busy tone). but Phone_A can call Phone_B by call * 851 first, if it receive long tone, and we press extension 8989 so the calls can be really successfully.

I need solution? how to Phone_A can directly call Phone_B, direct call the extention i mean,not using the * 851 first.

Hopefully anyone can help me.
Thank's before for the help.

Regards,

Ryan

19 REPLIES 19
acampbell
Advocate

Ryan,

Can you clear up your design before I can help you.

I think your system is like this from the config you have shown.

3304 - PAN/PBX --- E1/QSIG ---- ROUTER -----FX? --- 8080

You are mentioning 8989 I dont see any peer for this.

There are a few other items missing from the config

Can you please verify the design and explain what number ranges are in each side of the network.

Regards

Alex.

Regards, Alex. Please rate useful posts.

Alex,

oh, i'm sorry, i forget to change, the ekstension is 8080, thanks for the correction.

for the design is like this :

3304 - PAN/PBX ---- E1/QSIG ---- ROUTER ----- FXS --- 8080

thanks for the help before.

Regards,

Ryan

Ryan,

Can you try adding the following line to your config


!
network-clock-select 1 E1 0/0/0
! THIS FIXES THE ISDN LINE CLOCKING TO COME FROM THE TRAD PBX
!
!
interface Serial0/0/0:15
isdn overlap-receiving T302 2000
!
!
dial-peer voice 1 pots
description *** FOR INCOMING CALL MATCHING ***
! Match Incoming PSTN calls to this peer !
incoming called-number .
! THIS NEEDS THE FULLSTOP
direct-inward-dial
port 0/0:15
!
!
dial-peer voice 3304 pots
direct-inward-dial
!
!

Then try retesting

Let us know how it goes

HTH
Alex

Regards, Alex. Please rate useful posts.

Alex,

oke, i will try it. and publish the result here.

but, i have a question. is it posible that the problem is not the router but the panasonic tda 600 pbx??

cause call from router to pbx is working fine, and call from pbx to router that not working fine.

thanks before for the advise .

Best Regards,

Ryan

Ryan,

Your existing config does not allow direct dialling in to the router from the PBX.

The issue you may need to look at on the PBX is how to access the QSIG trunk from that side.

Your notes above state you needed to dial *851 first.

I am not sure if this is a MUST or does the routing table in the PBX point calls to 8080 down the

QSIG trunk.

Make the changes I sent then retest.

Let us know the results.

Regards

Alex

Regards, Alex. Please rate useful posts.

Dear Alex,

thanks before, the problem is solve now, the problem occur because the pabx, when i add the ip of router to the pabx, all is working fine. thank you very much for the answer.

and the *851 is a feature of panasonic pbx to test the link from pbx to router. in the past, i install a new pri card in pbx, and allocate that card to trunk group 51, so the explanation of *851 is *8 is the feature of pbx, and the 51 is the trunk group.and we also make a leading number 89 to the trunk group 51. so if there is a call begin with 89, the pbx will route that call through trunk-group 51.

but another problem is occur the router now just receive 2 last digit, example when i call 8987, the router just receive 2 last digit -> 87, so from that, i make dial-peer voice 87 pots, and the port is to pots through fxs port. (the config and capture of debug isdn q931 and debug voice translation is attached).

my question is, how to make the router can receive all 4 digits from pbx?? because i need to receive all the 4 digit.

* i make a change, the pots which connected to router is changed to 8987.

thank you very much for the help.

Best regards,

Ryan

Ryan

Make sure that the PBX is sending all 4 digits

You may be using overlap signalling on the PBX side

Try adding this peice of config.

!

!

!

interface Serial0/0/0:15

isdn overlap-receiving

isdn overlap-receiving T302 2000

!

!

Let us know how you get on

HTH

Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.

Dear Alex,

i have add this config :

interface Serial0/0/0:15

isdn overlap-receiving

isdn overlap-receiving T302 2000

but nothing change, and after i add that config, i can't call from phone that connected to pabx to phone that connected to router.

i wanna ask, how to make sure that the PBX is sending all 4 digits??

Thank you very much before.

Best regards,

Ryan

Ryan,

I dont know how to help you with the PBX

Looking at the Q931 trace

Called Party Number i = 0x89, '89'

It looks like you are only getting "89" from the PBX.

Other than putting some Q931/QSIG analyser in series in the trunk you need help from panasonic support.

Regards

Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.

hi acampbell

i dont know what do i do for this

please help me

 


Current configuration : 2787 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
card type e1 0 3
logging message-counter syslog
enable secret 5 $1$l4aA$qLLYjc/eUTeVm8ArOA3gh.
!
no aaa new-model
network-clock-participate wic 3
!
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name alish
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-qsig
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol cisco
!
!
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
! Warning! DSPs 5,6,7,8 in slot 0 are using non-default firmware from device flash:
! This is not recommended, the IOS default version is 24.3.4
!
!
!
username alish privilege 15 secret 5 $1$Wi7e$KuYtp3rQLvBzajnOTEndK.
!
!
!
archive
log config
hidekeys
!
!
controller E1 0/3/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/3/1
framing NO-CRC4
clock source internal
pri-group timeslots 1-31
!
ip ssh version 2
!
!
!
!
interface FastEthernet0/0
ip address 192.168.20.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/3/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn timer T310 120000
isdn overlap-receiving T302 4000
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Serial0/3/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn timer T310 120000
isdn overlap-receiving T302 2000
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/3/0:15
!
voice-port 0/3/1:15
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
!
!
!
!
dial-peer voice 5000 pots
destination-pattern 5[1-4]..
incoming called-number .
no digit-strip
direct-inward-dial
port 0/3/0:15
forward-digits 4
!
dial-peer voice 4000 voip
destination-pattern 4...
voice-class codec 1
session protocol sipv2
session target ipv4:192.168.20.10
session transport udp
no vad
!
dial-peer voice 6666 pots
destination-pattern 6666
port 0/2/0
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
logging synchronous
login local
transport output ssh
line aux 0
line vty 0 4
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
end

5[1-4]..  -----PAN/PBX ---- E1/QSIG ---- ROUTER------ Elastix------ 4...

 

r-godden
Beginner

could add the 89 on the router

voice translation-rule 1
rule 1 // /89\1/
!
!
voice translation-profile ADD_89
translate called 1
!

dial-peer voice 87 pots

translation-profile outgoing ADD_89
destination-pattern 87
port x/x/x

Ryan,

1) Can you post the full show run for the current status

2) Are all incoming patterns going to start with 89

Regards

Alex

Regards, Alex. Please rate useful posts.
Create
Recognize Your Peers
Content for Community-Ad