cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
719
Views
0
Helpful
5
Replies
Highlighted
Engager

Unable to add secondary DNS server

I'm running CUCM 8.6.2, and I'm unable to add a secondary DNS server to the CUCM in the CLI.

When I issue the command:

set network dns secondary X.X.X.X

I get the message back:

"     ***   W A R N I N G   ***

This will cause the system to temporarily lose network connectivity

Continue (y/n)?"

I reply "y" and I get the response (sometimes immediatly, other times after a delay)

"Executed command unsuccessfully"

Running packet captures I can't see any attempt to contact the DNS server. I can ping & ssh to the DNS server fine from the CUCM box.

What CUCM logs should I look via RTMT to try and diagnose this ?

Thanks,

GTG

Please rate all helpful posts.
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Unable to add secondary DNS server

Hi

Not sure really - I've never seen it fail. I imagine you'll end up raising a TAC case for it as it will need root access etc.etc.

However... I would try:

file search activelog / 1.2.3.4 recurs reltime minutes 10 ignorecase

From the CLI, where 1.2.3.4 is the DNS server address you tried to add. That will scan all log files for occurences of that address, and hopefully show up where such changes are logged.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

View solution in original post

5 REPLIES 5
Highlighted

Unable to add secondary DNS server

Hi

Not sure really - I've never seen it fail. I imagine you'll end up raising a TAC case for it as it will need root access etc.etc.

However... I would try:

file search activelog / 1.2.3.4 recurs reltime minutes 10 ignorecase

From the CLI, where 1.2.3.4 is the DNS server address you tried to add. That will scan all log files for occurences of that address, and hopefully show up where such changes are logged.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

View solution in original post

Highlighted
Engager

Unable to add secondary DNS server

Thanks for that. I think I've found the problem: A bug in CUCM.

If your primary DNS server IP address is, say, 192.168.1.10 and you then try to add 192.168.1.1 as a secondary, it complains that it already exists.

You can get round it by either:

a - Reversing the order of the DNS servers.

b - Putting a fake entry in for the primary. Set the secondary correctly. Then you can put the real entry in for the primary.

GTG

Please rate all helpful posts.
Highlighted
Beginner

Unable to add secondary DNS server

Do you have the bug ID for this issue ?

Highlighted
Engager

Unable to add secondary DNS server

Godo news: Bug ID is CSCuf46934.

Bad news 1: Cisco won't fix the bug until at least CUCM 10.

Bad news 2: Cisco refuse to make this bug public. My SE can't find out why.

Please rate all helpful posts.
Highlighted
Beginner

Unable to add secondary DNS server

Thank you ,  Sir.