Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Unity 5.0 MWI on 1 phone failing to light

I've got a weird issue -

I've got Unity 5.0 with CUCM 6.1.1. I've got 5 phones, mixed between an Avaya PBX and the CUCM side, that work perfectly fine in lighting the MWI light and sending email. I have one extension, however, that fails to light but the user does get an email and is able to check the messages via the phone.

I know the MWI on the phone works as I am able to successfully dial the On and Off extensions and light and unlight the MWI. Additionally, when I make that phone light for another extension, it does work.

I've so far tried deleting the user (twice!) from Unity, and re-adding them but it does not appear to work. In looking under the Subscribers -> Messages for the user, the MWI indicator checkbox is selected and the extension is entered properly, but the Indicator Lamps is shown as being Off.

Any idea what I can do to remedy this?

Brandon Buffin

Make sure that the calling search space assigned to the MWI numbers contains the partition assigned to the DN that will not light.

Hope this helps.


All DNs are in the same partition.

All of them, except for this one, will light the MWI.

I just double checked again.

Thanks anyway Brandon.

Does the MWI ever light, even momentarily? Is it possible that the user uses a POP account to check email or that the messages are being forwarded to a different account?


The phone does not light at all, and the user does not forward his email to another account. He is readily able to check the message from his account.

Do a quick check at the phone. You should be able to dial the MWI "ON" extension at that phone and light up the phones light. Then dial the MWI "OFF" extension. If you can not do either, it's a CSS/PT problem with the phone.

If you CAN, then you have something wrong in Unity. Possibly the extension is not the primary on the phone (alt number) or the subscribers mailbox is out of sync. (listen to all messages, delete, read, whatever, then sync the mailbox, leave a new message see what happens)


As stated in my original post, I can dial the MWI extensions and it works fine.

The extension is the primary, and only, one on the phone.

The account on Unity is setup exactly the same as the account I use, except for the user being different, and I have no problems with mine.

Sorry, I missed that.

Open up the port monitor and watch the call come into Unity. Leave a message and see if Unity dials MWI out from your ports.

You could also have an Exchange issue with this account. I have seen issues where for whatever reason, the customer added a new account in, and Unity permissions did come down from the high container in AD. Compare the permissions on your account that works, and your problem account.

Do a quick check also. If you have UM, make sure the voicemail shows up in the Inbox of the subscribers. If you VM Only, you can log into OWA from a machine to the Unity messages store and see if it shows up.

Check your Unity event logs on the server to see if there are any failures and report back.

hope this helps.


We are using UM.

I've opened a TAC case on this since I didn't want to post some of the log files I had. As long as I don't forget, I will update this with what we found.

I'm thinking it may be an Exchange issue since the lady at TAC said this is the process for lighting the MWI:

1) Message is left for user on Exchange and Exchange will send a Notify

message to Unity to notify us of the new message (same is true for deleting messages).

2) Unity will dial out the MWI code for the particular extension if it did

not already have MWI On/Off.

3) CallManager will see the digits and update its database for the

particular extension to show a status of lamp On/Off and will send the StationD message to the phone whenever change notify is triggered.

Does the user have a rule sending the message to a folder other than the inbox? I know that in Unity 4 Unity only reads messages in the inbox folder.

No, the user did not have a mail rule moving the message.

In talking with TAC, they gave me a bunch of different things to try - none of which worked. However, after adding in another user to Unity, the problem user's MWI started working again. I'm not sure how to explain that one away. but that is what I did to fix it.

Content for Community-Ad

Spotlight Awards 2021