cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

5643
Views
30
Helpful
16
Replies
Collaborator

Upgrade to CUCM 10.5(1) Fails

Hello,

I have been trying to move a CUCM 7.1(5) cluster on MCS to 10.5(1) on UCS without much success.

Initially I tried to go from 7.1(5) to 10.5(1) by following the Jump upgrade process.

I successfully built a replica of the CUCM 7.1(5) cluster on the UCS servers and did a DRS restore.

When I tried doing an upgrade to CUCM 10.5(1) it failed on the database installation stage.

I raised a TAC case and was asked for logs which I provided but the Cisco Database Installation Service Log did not have any information for the failure.

The TAC engineer said that he had seen this before and it was a problem with dial plans installed on the server.

I had the UK dial plan installed so I rebuilt the cluster on UCS without installing dial plan, locales and phone firmware as I had previously. The only cop file I installed was the refresh upgrade file.

When I tried to upgrade I got the same error.

I was not getting much response from the TAC engineer so I thought I would try upgrading to CUCM 9.1(2) as an interim step. This worked fine and I took a backup then re-installed CUCM 9.1(2) to align the partitions then did a restore. Again this worked ok.

I then tried to install to 10.5(1). I installed the ciscocm.version3-keys.cop file and started the upgrade. It failed in exactly the same place and once again there was no database log.

The failure message I get in the install log is shown below:

10/23/2014 10:25:45 component_install|File:/opt/cisco/install/bin/component_install:807, Function: exec_progmeter(), /opt/cisco/install/bin/progmeter failed (1)|<LVL::Error>
10/23/2014 10:25:45 appmanager.sh|Internal Error, File:/usr/local/bin/base_scripts/appmanager.sh:273, Function: refresh_upgrade(), failed to refresh_upgrade infrastructure_post components|<LVL::Critical>
10/23/2014 10:25:45 post_install|File:/opt/cisco/install/bin/post_install:961, Function: install_applications(), /usr/local/bin/base_scripts/appmanager.sh -refresh-upgrade failed (1)|<LVL::Error>
10/23/2014 10:25:45 post_install|Exiting with result 1|<LVL::Info>

Has anyone seen anything similar to this and, if yes, how was it resolved?

I am trying to get more urgency from TAC but the case has been open for four days so far and I have had very little response.

Thanks

 

16 REPLIES 16
Hall of Fame Cisco Employee

It appears that most of the

It appears that most of the times you get that error the issue is indeed with locales, dial plans, etc. Something you installed on the server.

FYI, Jump upgrade is ONLY for 9.1(2), it's not applicable for any other version  The replacement for this if you are going to 10.x is PCD migration.

Aside from removing those elements, or installing them, if removal is not possible, the only other errors I could find are having auto-registration enabled, and EM still working during the upgrade.

If you have it enabled, try disabling it, and also disable EM.

HTH

java

if this helps, please rate
Beginner

Hi All, I got the same issue

Hi All,

 

I got the same issue here.

I am upgrading from 9.1.2.12901-3 to 10.5.1.11900-13 in these steps.

1. Backup of CUCM 9.1.2 Databases

2. Installation of 9.1.2 using same OVA (cucm_9.1_vmv8_v1.7)

3. Restore of CUCM 9.1.2 Databases

4. Installation of ciscocm.version3-key.cop.sgn

5. Upgrade to 10.5.1.11900-13 - Installation fails at 87% - Database Installation.

 

I have opened a TAC Case two week ago with no progress.

I have tried the follow:

*Deleting the subscribers from the db,

*Reassigning all CM groups to publisher

*Deleted Phone NTP references

*Deleted Application Servers

*Deleted LDAP

*Deleted All Users

*Disabled Extension Mobility

*Ensure DNS and NTP is accessible

*Tried several ISO images

*DRS with only UCM DB selected

 

I cannot complete the PCD installation due my lab running Free ESXi (Mounting NFS Vcenter Errors), running PCD is too much of a risk in my live environment.

 

Can anyone help?

 

This is the offending error in the log.....

11/21/2014 10:38:47 IPM|Internal Error, File:ipm.c:2011, Function: ipmReadNormalizedInputLine(), "/usr/local/cm/script/cm-dbl-install RU PostInstall 10.5.1.11900-13 9.1.2.12901-3 /usr/local/cm/ /common/component/database /common/log/install/capture.txt " failed (1)|<LVL::Critical>
11/21/2014 10:38:49 IPM|  end-of-session "Installing database component": 2331.569 secs.|<LVL::Info>
11/21/2014 10:38:49 IPM|Close progress meter "Component Install"|<LVL::Info>
11/21/2014 10:38:49 component_install|Writing database into /common/log/install/component_failed.xml file.|<LVL::Info>
11/21/2014 10:38:49 component_install|/common/log/install/component_failed.xml created : 0|<LVL::Info>

 

I have also attached the complete install log to help diagnose.

 

Thanks in advance.

 

Ed

Collaborator

Hi,I got some help from TAC

Hi,

I got some help from TAC and the issue was traced to having the UK dial plan installed on the servers. The relevant logs were actually in the inactive partition rather than the active partition. This is normal for a refresh upgrade apparently.

I managed to uninstall the dial plan from the Publisher but could not uninstall it from the Subscriber. I removed the Sub from the cluster and was then able to upgrade the Pub to 10.5(1).

However when the upgraded server booted there were numerous warning shown on the console and the server would not shut down properly when the utils sytstem shutdown command was issued. These issues remained even after a backup - rebuild - restore.

By this time I had spent more than a week on the issue. As the cluster only had 200 phones and no complex integrations (Jabber, UCCX etc) I decided to build a new cluster and use BAT to export/import the configuration. This took far less time than I had spent on the upgrade!

Beginner

Hi James,Thanks for getting

Hi James,

Thanks for getting back to me so soon.

I have uninstalled the dialplan by going to Call Routing...Dial Plan Installer and uninstalling all listed.

 

I have just started the upgrade process again and will report back the result.

Beginner

Hi James,The uninstall of the

Hi James,

The uninstall of the UK Dialplan worked a treat.

I can't believe a TAC case opened for almost 3 weeks could not tell me this.

Thanks for your help.

Ed

 

 

Participant

I also had this problem,

I also had this problem, after two days it was found to be a SIP profile.

 

In 9.x onwards there is a default SIP Profile called something like "Standard SIP Profile for Cisco VCS"

 

Prior to 9.x you could create a SIP profile with this name (it happened by default when you installed VCS i believe so it is not unlikely)

 

When you try and upgrade it conflicts.  The fix is to simply rename the SIP profile to something other than its current name.  I just changed mine to "SIP Profile for VCS"  ( I removed the word standard)

 

now all is working a treat.

Beginner

Ran into the same issue with

Ran into the same issue with migration from 8.6.2 to 10.5.2 using PCD 10.5.2 and 11.5. Cisco TAC was unable to pin point the issue but your post was super helpful as was seeing the following error in \var\log\active\cm\trace\dbl\installdb_ru.log.err but was not sure what was the duplicate value!!!, thx a ton! 

19:04:42.194 | DBUtil::DoSQLCommand ### *ERROR* ###: SQL Exception detected while Adding Saved Initialization Records back to table [Error executing "INSERT INTO sipprofile SELECT * FROM TmpSaveTargetInitial": [Informix][Informix ODBC Driver][Informix]Could not insert new row - duplicate value in a UNIQUE INDEX column (Unique Index:).]
19:04:42.194 | DBUtil::BlockCopyTable ### *ERROR* ###: SQL Exception Detected: ErrorCode=-239 , SQLState=23000
19:04:42.194 | DBUtil::BlockCopyTable *ERROR* (diagnosis): Unexplained SQL Exception processing table sipprofile. Please report/investigate in full logs. (-239) [Error executing "INSERT INTO sipprofile SELECT * FROM TmpSaveTargetInitial": [Informix][Informix ODBC Driver][Informix]Could not insert new row - duplicate value in a UNIQUE INDEX column (Unique Index:).]

Highlighted

This Should be marked as

@carlnewton

You answer Should be marked as correct answer.

After about a day troubleshooting with TAC i finally found this tread and bingo, i had the sip profile.

changing the name as you advised made the trick.

Migration:

Be5K 8.6.1 >>> Import migration to CUCM VM 8.61 >>> refresh upgrade to 11.5

I was having the issue when upgrading to 11.5.

i was sure that i made something wrong on the Import from BE5K, and that was causing the issue, but, the issue was like you described someone had the "Standard SIP Profile for Cisco VCS" configured in the CUCM before the upgrade.

THANK YOU!

VIP Mentor

Have you tried upgrading to

Have you tried upgrading to 10.0 first? Then go to 10.5 from that.

Please rate all useful posts
Enthusiast

Hi,I did this recently from 6

Hi,

I did this recently from 6.1x to 10.5 via 9.1.2 successfully by doing the following:

  • Upgraded to 9.1.2 (can't recall running the refresh cop)
  • Upgraded to 10.5 ran a DRS backup
  • Restored the DRS backup on a fresh 10.5

 

I originally thought could upgrade from 6.1.4 as per the matrix in the below table but had to take the 9.x route.

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/compat/matrix/10_x/CUCM_BK_CD1DB914_00_compat_matrix/CUCM_BK_CD1DB914_00_compat_matrix_chapter_01.html#CUCM_RF_U3F4468C_00

 

VIP Mentor

While you are waiting for TAC

While you are waiting for TAC, you can try this..Upgrade to 10.0, then go from there to 10.5

Please rate all useful posts
Beginner

Hi James,Did you get this

Hi James,

Did you get this resolved? I am having the same issue. Tried everything!!! Spent a week already.

I am migrating from 6.1(4). 

At the moment setting up PCD. Will see if it will get this sorted.

I have not tried the 10.0 pass yet. Will do if PCD fail.

Cheers

Beginner

Just a quick update. PCD did

Just a quick update. PCD did not work! The was an error where system could not access some file for a while and finally failed the upgrade

Beginner

My upgrade/migration story

My upgrade/migration story summary

1) 6.1.4 Jump Upgrade to 9.1.2 Successfull

2) 9.1.2 RU Upgrade to 10.5 Unsuccessful (Tried all possible ways)

3) 9.1.2  RU Upgrade to 10.0 Unsuccessful

4) 9.1.2 Migration to  10.5 via PCD Unsuccessful

5) 9.1.2 Migration to  10.0 via PCD Unsuccessful

6) 6.1.4 Migration to  10.5 via PCD Unsuccessful (Not supported)

7) 6.1.4 L2 upgrade to 6.1.5 Successful

8) 6.1.5 RU Upgrade to 10.5 Unsuccessful

9) 6.1.5 RU Upgrade to 10.0 Unsuccessful

10) 6.1.5 Migration to 10.5 via PCD Unsuccessful

11) 6.1.5 Migration to 10.0 via PCD Successful!!!

12) 10.0 L2 upgrade to 10.5 Successful!!!

I was using this PCD: pcd_vApp_UCOS_10.5.1.10000-6_vmv7_v1.2

All necessary cop files have been applied manually to 6.1.5

I was using the same 6.1.5 without any changes on all migrations/upgrades from step 7.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here