cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1548
Views
0
Helpful
12
Replies
jcarvalh
Beginner

Upgrading CCM 7.1 to CCM 8.6 (HP to UCS)

Hello all.

I need to upgrade a a CCM 7.1 to CCM 8.6 and I am also going to upgrade the hardware (HP to UCS). Is there any way to export the configs from the HP server running CCM7.1 to the UCS server running CCM 8.6?

Best regards,

Joao Carvalho.

12 REPLIES 12
sdekooter
Beginner

Hello Joao,

You should use the backup of your current cluster and restore it to the new cluster. This process works only if the new installation has the (exact) same version CUCM installed as the backupset you're restoring to it.

You would need to install the 7.1 release on your new UCS cluster first and then do an upgrade.

http://www.cisco.com/en/US/customer/docs/voice_ip_comm/cucm/install/8_6_1/cluster/clstr861.html#wp87714

Also take note of the files not being restored in this process. You might have to have them in place before doing a restore (custom backgrounds and localization for example).

You'll have to have new licenses in place as well.

Stoyan Stoitsev
Collaborator

Hello,

You need to get to a version that supports virtualization on UCS - 8.5 or 8.6. So first go to "Supported Servers for Releases of Cisco Unified Communications Manager":

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/ps5748/ps378/prod_brochure0900aecd8062a4f9.html

and check whether your HP server supports 8.5 or 8.6. Notice that some servers are supported only for a "bridged" upgrade. Bridged means that no services will start on the old server after the upgrade, the DB will be modified according to the new version and you will only be able to take a backup.

So when you upgrade your HP server to the version you have installed on the UCS take a backup and restore it on the UCS server.

Stoyan

Jaime Valencia
Hall of Fame Cisco Employee

An alternative is to go the the 1st release we support on VM which is 8.0(2) on MCS, backup, restore on VM and then upgrade.

Please notice that anything below 8.0(2) is NOT supported on ESXi. That's why there are servers supported for "bridged" upgrade.

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

Hi javalenc.

I have an issue like this, but with some difference, here is the explanation:

I have a cluster (2 servers, pub and sub) with CCM 7.1.3 and i need to upgrade it to a CCM 8.5 versión but in new hardware.

New hardware is a MCS-7825-I5 server.

These are the process that i did:

First Path --- Backup CCM 7.1.3 --Install CCM 7.1.3 on New Hardware(7825-I5)-----Restore Database----Upgrade to 8.5

I made a BACKUP from the CCM 7.1.3 and then I tried to install the CCM 7.1.3 onto the new hardware(MCS-7825-I5) to restore back the Database BACKUP. But when the installation began i didn´t work because according to Cisco Documentation, this server doesn´t support other version prior to 8.5.

Second Path--Backup CCM 7.1.3 --Install CCM 7.1.3 on 7825-H2(bridge upgrade)--Upgrade to 8.5----Backup 8.5---Install CCM 8.5 on New Hardware (7825-I5)---Restore Database.

i took a server from my LAB wich is a MCS-7825-H2 to make a Bridge upgrade with it, and I installed the CCM 7.1.3 and then restored back the Database successfully, but i tried to upgrade it to a CCM 8.5 with the patch UCSInstall_UCOS_8.5.1.100000-26.sgn but once again i didn´t work because appeared this message "Upgrades are prohibited during Licensing Grace Period"  i´ve read something about this issue in the bug CSCtb86875 and is cause of License problem, and in the workarround says tha i need to Remove the rehosted (new) license files using cli commond "file delete xxx.lic" ; Restart license manager and Re-upload the rehosted (new) license files. But in my case a just want to use the server to bridge upgrade not for keep it.

According to my explanation can you tell me what it the best path to upgrade my coustomer´s CCM 7.1.3 to a version 8.5?

Please help me, i´ll appreciate your comments.

Do you remember how TAC solved this problem? I got the same issue, and this was my process. I'm upgrading from 7.1.5.10000-12 on MCS to 8.6 on UCS.

1. DRS backup production 7.1.5.10000-12 on MCS

2. Install 7.1.5.10000-12 on a VM. Yes, I get that it's not supported, but it should still work. I've done numerous upgrade from 4.x to 7.x on a VM to 8.x, and it always worked.

3. DRS restore

4. Now trying to upgrade to 8.6 and getting this error "Upgrades are prohibited during Licensing Grace Period"

It's gotta to be some simple trick with license files that could fix this. I tried installing rehosted NODE/PHONE license to the license mac, that didn't help. I tried removing all licenses, that also didn't help.

Do you remember what was the trick?

I am with Roman here, agreed it is not supported, but Cisco did not give us much options when they decided the path. I have done it and others have done successfully. Upgrading existing environment to version 8 is not always an option, most customers go to new hardware because their existing hardware is not supported with version 8.X, so what other options does it leave you with?  Install 7.1 on UCS vmware, upgrade to 8.X and be done it!

HTH,

Chris

Exactly!

Now, I know what Cisco will say in my situation, my 7825H2 supports bridged upgrade to 8.0/8.5, but it's just such an inconvinience that I have to mess with production server. My Unity Connection and UCCX don't have this issue, as I'm using COBRAS and PreUpgradeTool so I can stage everything on VM.

I tried opening a case, and I got the same story about no support of 7 on VM with some strange explanation about "disk striping" that could cause issues with upgrading CM from 7 to 8 on a VM. Whatever that means, but I still have a lot of working deployments on 8 that were migrated from 4 via 7 on a VM. They all work just fine and no issues with TAC supportability.

And yes, in situations where existing platforms supported 7 but doesn't support 8, even with bridged upgrade, that's an issue, because you would have to find another newer temporary MCS server to do the bridge.

I still hope to find a solution to this "bug".

Just shooting in the dark here but why don't you upgrade to 8.5, then get the license and move on to 8.6?

Last month I did a MCS 4.2 to VM 7.1.5.34900-7 to latest 8.6 and all worked just fine...

It doesn't seem to care what ISO I give it, 8.0, 8.5, 8.6.... I don't think it even checks it. Basically, in 7.1.5 on VM if I go to Software Upgrades and specify DVD, as soon as I hit Next, I get "Upgrades are prohibited during Licensing Grace Period".

Exactly! I've done many 4.2 to 7.1.5 to 8.6, and they all worked perfectly fine.

Our of curiousity I gave it the latest 7.1.5 DVD and a Windows XP DVD, it's the same error every time. It doesn't check what's on the ISO, it just doesn't want to upgrade.

Finally found the solution. I had to get root access and delete licenses from database. I can now upgrade.

I might have had a simpler solution available. Just like some others were saying that the solution was to remove all licenses and then install new licenses again which will delete the demo licenses. I tried this before and it didn't work for me, but now I can see that was because my new rehosted licenses were created for the hardware mac instead of the license mac (HOSTID=HOSTNAME=).

Create
Recognize Your Peers
Content for Community-Ad