cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
330
Views
0
Helpful
3
Replies

users say calls have nobody at other end

Mark Graham
Level 1
Level 1

hi everyone, i have stumbled on an issue that i'm not sure how to diagnose

for a police department we have the phones setup in this fashion.

cisco 2821 with hard lines go into 2 fxo cards, 6 lines total

half of the lines are for 911

the rest are roll over lines for the primary number.

the numbers are plared into the router, and call control happens at our primary callmanager.  which we're upgrading at the moment.  we are currently on 6.1.5.10 -- upgrading to the latest and greatest version 9 soon, we just have to upgrade the unity connection and presence. 

one other thing i'd like to mention about the voice ports is the ports are split in 3 way's

each pair of wire goes to three seperate devices on a phone block.  one of them being the router, the other is the voice recorder that we have.  it runs those phones on a 25 pair cable going to the server, lastly they are punched down on a patch panel as last effort incase for some reason the dispatch center looses power, phones can be still answered after analog phones are patched in. 

the IOS on the 2821 is 12.4(24) T    i know that i will have to upgrade this to the latest 15.1 software as we upgrade. 

users are stating some calls are not being picked up at their handsets, or they hear no voice at the other end.  looking at call legs i do see  SelectedQoS=best-effort

that shouldnt be best effiort right? 

my class maps are configured as : 

class-map match-any VOICE

match ip dscp ef

match ip precedence 5

class-map match-any VOIP-SIG

match ip dscp cs3

policy map :

policy-map HIGH-BW-LINK

class VOICE

    priority

class VOIP-SIG

    bandwidth remaining percent 50

class class-default

    bandwidth remaining percent 10


the router has the policy applied to the network interface outbound. 

if needed here is my config:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

hostname router

!

boot-start-marker

boot system flash:c2800nm-advipservicesk9-mz.124-24.T1.bin

boot-end-marker

!

logging message-counter syslog

logging buffered 50000

no logging console

enable secret xxxxxxxx

!

aaa new-model

!        

aaa authentication login default group tacacs+ local

aaa authentication login Console group tacacs+ local enable

aaa authorization console

aaa authorization exec default group tacacs+ local

aaa authorization exec Telnet group tacacs+ if-authenticated

aaa authorization commands 1 default group tacacs+

aaa authorization commands 15 default group tacacs+ local

aaa accounting exec default

action-type start-stop

group tacacs+

!

aaa accounting commands 1 default

action-type start-stop

group tacacs+

!

aaa accounting commands 15 default

action-type start-stop

group tacacs+

!

aaa session-id common

!

dot11 syslog

ip source-route

!

ip cef

!

no ipv6 cef

ntp peer 10.1.1.68

!

multilink bundle-name authenticated

!

voice rtp send-recv

!

voice service voip

fax protocol cisco

h323    

  call start slow

!

voice class h323 1

  h225 timeout tcp establish 3

!

voice-card 0

!        

archive  

log config

  hidekeys

!

class-map match-any VOICE

match ip dscp ef

match ip precedence 5

class-map match-any VOIP-SIG

match ip dscp cs3

!

policy-map HIGH-BW-LINK

class VOICE

    priority

class VOIP-SIG

    bandwidth remaining percent 50

class class-default

    bandwidth remaining percent 10

!        

interface GigabitEthernet0/0

description **Voice Network

ip address 172.21.0.17 255.255.254.0

duplex auto

speed auto

h323-gateway voip bind srcaddr 172.21.0.17

service-policy output HIGH-BW-LINK

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router eigrp xxxxx

network 172.21.0.0 0.0.1.255

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.21.0.1

no ip http server

no ip http secure-server

!

no ip pim dm-fallback

ip pim autorp listener

!

logging history informational

logging facility local6

!

snmp-server community xxxxxx RW

snmp-server community xxxxxx RO

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps envmon

snmp-server enable traps isdn layer2

snmp-server enable traps isdn ietf

snmp-server enable traps ds0-busyout

snmp-server enable traps entity

snmp-server enable traps cpu threshold

snmp-server enable traps syslog

snmp-server enable traps voice poor-qov

tacacs-server host 10.1.1.22

tacacs-server directed-request

tacacs-server key xxxxxxxxxxx

!

control-plane

!

voice-port 0/0/0

no battery-reversal

no vad

connection plar opx immediate 2100

description 2042100

caller-id enable

!

voice-port 0/0/1

no vad

connection plar opx immediate 2101

description 2042101

caller-id enable

!

voice-port 0/0/2

no vad

connection plar opx immediate 2637

description 911 line 1

caller-id enable

!

voice-port 0/0/3

no vad

!

voice-port 0/1/0

no vad

connection plar opx immediate 2102

description 2042102

caller-id enable

!

voice-port 0/1/1

no vad

caller-id enable

!

voice-port 0/1/2

no vad  

connection plar opx immediate 2913

description 911 line 2

caller-id enable

!

voice-port 0/1/3

no vad

connection plar opx immediate 2899

description 911 line 2

caller-id enable

!

mgcp fax t38 ecm

mgcp behavior g729-variants static-pt

!

dial-peer voice 90911 pots

destination-pattern 9911

port 0/0/0

forward-digits all

!

dial-peer voice 91911 pots

preference 1

destination-pattern 9911

port 0/0/1

forward-digits all

!

dial-peer voice 92911 pots

preference 2

destination-pattern 9911

port 0/0/2

forward-digits all

!

dial-peer voice 93911 pots

preference 3

destination-pattern 9911

port 0/0/3

forward-digits all

!

dial-peer voice 9500 pots

preference 5

destination-pattern 9.T

port 0/0/0

forward-digits all

!

dial-peer voice 9501 pots

preference 4

destination-pattern 9.T

port 0/0/1

forward-digits all

!

dial-peer voice 9502 pots

preference 3

destination-pattern 9.T

port 0/0/2

forward-digits all

!

dial-peer voice 9503 pots

preference 2

destination-pattern 9.T

port 0/0/3

forward-digits all

!

dial-peer voice 401 voip

preference 1

destination-pattern [0-8]...

session target ipv4:172.21.2.10

dtmf-relay h245-signal

codec g711ulaw

no vad

!

dial-peer voice 100 pots

description **Incoming dial peer

incoming called-number 2...

no digit-strip

!

dial-peer voice 402 voip

destination-pattern [0-8]...

session target ipv4:172.21.0.10

dtmf-relay h245-signal

codec g711ulaw

no vad

!

gateway

timer receive-rtp 1200

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

timeouts interdigit 4

ip source-address 172.21.0.17 port 2000

max-ephones 24

max-dn 24

system message primary SRST Fallback Active

system message secondary SRST Fallback

keepalive 15

access-code fxo 9

!

banner login ^CC

             ******************************************************

             *    WARNING --- WARNING --- WARNING --- WARNING     *

             *                                                    *

             *    !Unauthorized Access is Strictly Forbidden!     *

             *                                                    *

             * Unauthorized access to networks, systems, hosts    *

             * or any other resources is strictly forbidden.      *

             * Violators will be prosecuted to the fullest extent *

             * of the law.                                        *

             *                                                    *

             ******************************************************

^C

!        

line con 0

password 7 03074F07

authorization exec Telnet

logging synchronous

login authentication Console

line aux 0

line vty 0 4

password xxxxxxxxxxx

authorization exec Telnet

logging synchronous

login authentication Local

length 0

transport input telnet ssh

line vty 5 15

password xxxxxxxxxxx

authorization exec Telnet

logging synchronous

login authentication Local

length 0

transport input telnet ssh

!

scheduler allocate 20000 1000

end      

3 Replies 3

paolo bevilacqua
Hall of Fame
Hall of Fame

You can remove all QoS config, it is not needed.

Other than that update IOS and check again.

is it possible that the issue is happening on the carrier side then paolo?     and why would the QoS config not be needed?  i figured the policy was needed.  keep in mind, this router only does that job and nothing more.

Unlikely it's carrier problem, but you can check with a buttset.

QoS on LAN definitely not needed.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: