cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

261
Views
0
Helpful
3
Replies
Highlighted
Beginner

VoIP dial-peer

Hi all, I've got a total N00b question, and inherited this setup...  I am very new to telephony so limited experience on this front.

I have a Cisco 2921 with a

NAME: "VWIC3-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 1", DESCR: "VWIC3-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1" in slot 0/1/0.

The PRI seems to be active:

ISDN Serial0/1/0:23 interface
        dsl 1, interface ISDN Switchtype = primary-ni
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 16
    Total Allocated ISDN CCBs = 0

My brief config:

controller T1 0/1/0
 cablelength long 0db
 pri-group timeslots 1-24 service mgcp

interface Serial0/1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable

voice-port 0/1/0:23

I also have a cucm setup in my HQ office with all these IP Phones setup there.

In looking at this config i show some dial-peer configs (shown below):

I'm assuming if i dial 911 or 9,410,xxx-xxxx the router will send this call across the local PRI rather than the MPLS line to my home office.  Is this true?  The area code 410 is in baltimore and not sure why a LD call specific to this area code would traverse the PRI rather than the MPLS.  I understand that 911 is setup this way for emergency, but why the 410?

Secondly the dial-peer 512 is the local area code in Austin (my branch office), but the translation-profile is setup with 'local' rather than "LOCAL".  Is case sensitivity important?  With this dial-peer will this send all my local calls across this PRI?

Any clarification is appreciated.


dial-peer voice 911 pots
 translation-profile outgoing ANI
 destination-pattern 911$
 port 0/1/0:23
 forward-digits 3
!
dial-peer voice 9410 pots
 translation-profile outgoing LOCAL
 destination-pattern 9410.......$
 port 0/1/0:23
 forward-digits 10

dial-peer voice 512 pots
 translation-profile outgoing local
 destination-pattern 9512.......$
 port 0/1/0:23
 forward-digits 10

3 REPLIES 3
Highlighted
Hall of Fame Cisco Employee

I suggest you post your full

I suggest you post your full config, those dial-peers will not be used by that PRI, unless you have SRST. That PRI is handled by MGCP on CUCM, so CUCM is the one that takes care of all the routing, the PRI will just do whatever CUCM says.

No way to tell you anything with just bits and pieces of the config.

HTH

java

if this helps, please rate
Highlighted
Beginner

Thanks Jamie, I agree (i did

Thanks Jamie, I agree (i did clear a few password and other unnecessary things per our security policy).

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2016.03.21 14:11:01 =~=~=~=~=~=~=~=~=~=~=~=
term len 0
Austin-MPLS#sh run
Building configuration...


Current configuration : 16700 bytes
!
! Last configuration change at 00:19:48 CST Thu Feb 18 2016
! NVRAM config last updated at 08:16:10 CST Sun Dec 13 2015
! NVRAM config last updated at 08:16:10 CST Sun Dec 13 2015
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Austin-MPLS
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 0
card type t1 0 1
logging buffered 100000
no logging console
no logging monitor
enable password 7 082
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication login console-login local
aaa authentication login http group tacacs+ local
aaa authentication enable default enable
aaa authorization exec default group tacacs+ local
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 1 default stop-only group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting network default start-stop group tacacs+
aaa accounting connection default start-stop group tacacs+
aaa accounting system default start-stop group tacacs+
!
!
!
!
!
aaa session-id common
!
clock timezone CST -6 0
clock summer-time CDT recurring
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 T1 0/0/0
!
no ipv6 cef
!
!
no ip source-route
!
!
!
!
!
ip flow-cache timeout active 1
ip domain list corporate.
no ip domain lookup
ip domain name corporate.
ip name-server 172.16.82.10
ip name-server 172.18.82.10
ip cef
ip wccp 61 redirect-list WAAS_Redirects
ip wccp 62 redirect-list WAAS_Redirects
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-4165044240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4165044240
 revocation-check none
 rsakeypair TP-self-signed-4165044240
!
!

      quit
voice-card 0
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  bind control source-interface GigabitEthernet0/1.136
  bind media source-interface GigabitEthernet0/1.136
  registrar server
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice register global
 max-dn 200
 max-pool 50
!
voice register pool  1
 id network 172.29.136.0 mask 255.255.255.0
 application sip.app
 dtmf-relay sip-notify
 codec g711ulaw
!
!
!
voice translation-rule 1
 rule 1 // /512320/
!
voice translation-rule 2
 rule 1 // // type any subscriber plan any isdn
!
voice translation-rule 3
 rule 1 // // type any national plan any isdn
!
voice translation-rule 4
 rule 1 // // type any international plan any isdn
!
!
voice translation-profile ANI
 translate calling 1
!
voice translation-profile INT
 translate calling 1
 translate called 4
!
voice translation-profile LD
 translate calling 1
 translate called 3
!
voice translation-profile LOCAL
 translate calling 1
 translate called 2
!
voice translation-profile my_profile
 translate called 1
!
!
!
license udi pid CISCO2921/K9 sn FTX16
hw-module pvdm 0/0
!
hw-module sm 1
!
!
!
username network.admin privilege 15 passwor
!
redundancy
!
!
!
!
!
controller T1 0/0/0
 cablelength long 0db
 pri-group timeslots 1-24 service mgcp
!
controller T1 0/0/1
 cablelength long 0db
 channel-group 0 timeslots 1-24
!
controller T1 0/0/2
 cablelength long 0db
 channel-group 0 timeslots 1-24
!
controller T1 0/0/3
 cablelength long 0db
 channel-group 0 timeslots 1-24
!
controller T1 0/1/0
 cablelength long 0db
 pri-group timeslots 1-24 service mgcp
!
controller T1 0/1/1
 cablelength long 0db
!
ip ssh version 2
!
class-map match-any QoS-VoIP-Control
 match ip dscp cs3
 match ip dscp af31
 match access-group name Voice-Control
class-map match-any QoS-VoIP-RTP
 match ip dscp ef
 match protocol rtp audio
class-map match-any QoS-Video-RTP
 match protocol rtp video
!
!
policy-map QoS-Policy
 class QoS-VoIP-RTP
  priority percent 30
  set ip precedence 5
 class QoS-Video-RTP
  priority percent 10
  set ip precedence 4
 class QoS-VoIP-Control
  bandwidth percent 20
  set ip precedence 3
 class class-default
  set ip precedence 0
  fair-queue
!
!
!
!
!
!
!
!
!
!
interface Loopback11
 ip address 10.200.111.203 255.255.255.255
!
interface Multilink1
 description CenturyLink MPLS
 no ip address
 ip nbar protocol-discovery
 ip flow monitor NETFLOW_MONITOR input
 ip flow monitor NETFLOW_MONITOR output
 ip flow ingress
 ip flow egress
 shutdown
 ppp multilink
 ppp multilink group 1
 no cdp enable
 service-policy output QoS-Policy
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description G0/0 INAC: **100Mb CenturyLink MPLS Circuit ID: xxxx **
 bandwidth 100000
 ip address 63.145.123.170 255.255.255.252
 ip nbar protocol-discovery
 ip flow monitor NETFLOW_MONITOR input
 ip flow monitor NETFLOW_MONITOR output
 ip flow ingress
 ip flow egress
 ip nat outside
 ip virtual-reassembly in
 duplex full
 speed 100
 service-policy output QoS-Policy
!
interface GigabitEthernet0/1
 description G0/1 UP: ** 1Gb Uplink to Austin1 G1/0/1**
 no ip address
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.136
 description Austin VOICE
 encapsulation dot1Q 136
 ip address 172.29.136.1 255.255.255.0
 ip helper-address 172.16.82.59
 ip nbar protocol-discovery
 ip pim sparse-dense-mode
 ip flow monitor NETFLOW_MONITOR input
 ip flow monitor NETFLOW_MONITOR output
 ip flow ingress
 ip flow egress
!
interface GigabitEthernet0/1.236
 description Austin LAN
 encapsulation dot1Q 236
 ip address 172.29.236.1 255.255.255.0
 ip helper-address 172.16.82.59
 ip wccp 61 redirect in
 ip nbar protocol-discovery
 ip flow monitor NETFLOW_MONITOR input
 ip flow monitor NETFLOW_MONITOR output
 ip flow ingress
 ip flow egress
!
interface GigabitEthernet0/1.336
 encapsulation dot1Q 336
 ip address 10.200.112.9 255.255.255.248
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/0/1:0
 no ip address
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 encapsulation ppp
 shutdown
 ppp multilink
 ppp multilink group 1
 ppp multilink endpoint mac GigabitEthernet0/0
 no cdp enable
!
interface Serial0/0/2:0
 no ip address
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 encapsulation ppp
 shutdown
 ppp multilink
 ppp multilink group 1
 ppp multilink endpoint mac GigabitEthernet0/0
 no cdp enable
!
interface Serial0/0/3:0
 no ip address
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 encapsulation ppp
 shutdown
 ppp multilink
 ppp multilink group 1
 ppp multilink endpoint mac GigabitEthernet0/0
 no cdp enable
!
interface Serial0/1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface SM1/0
 ip address 192.168.10.9 255.255.255.252
 ip wccp redirect exclude in
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 service-module ip address 192.168.10.10 255.255.255.252
 !Application: Restarted at Sun Dec 13 14:15:10 2015
 service-module ip default-gateway 192.168.10.9
!
interface SM1/1
 description Internal switch interface connected to Service Module
 no ip address
!
interface Vlan1
 no ip address
!
interface Vlan335
 no ip address
!
router bgp 65128
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 63.145.123.169 remote-as 209
 !
 address-family ipv4
  network 10.64.20.0 mask 255.255.255.0
  network 10.200.111.203 mask 255.255.255.255
  network 10.200.112.8 mask 255.255.255.248
  network 10.200.121.235 mask 255.255.255.255
  network 172.29.136.0 mask 255.255.255.0
  network 172.29.236.0 mask 255.255.255.0
  network 192.168.10.8 mask 255.255.255.252
  neighbor 63.145.123.169 activate
  neighbor 63.145.123.169 send-community
 exit-address-family
!
ip forward-protocol nd
!
ip bgp-community new-format
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip flow-export source SM1/0
ip flow-export version 9
ip flow-export destination 172.16.158.8 2055
ip flow-export destination 172.21.14.136 9995
!
ip route 0.0.0.0 0.0.0.0 63.145.123.169 254
ip route 10.64.20.0 255.255.255.0 172.29.236.11
ip route 10.200.121.235 255.255.255.255 Null0
!
ip access-list standard xxx_Monitor
 permit 161.89.160.115
 permit 161.89.160.116
 permit 162.89.160.117
 permit 161.89.151.222
 permit 161.89.150.220
 permit 161.89.151.221
 permit 161.89.151.220
ip access-list standard xxx_SNMP
 permit 172.16.82.245
 permit 172.16.158.6
 permit 172.16.158.7
 permit 172.16.158.4
 permit 172.16.158.5
 permit 172.16.158.8
 permit 172.16.158.9
 permit 172.18.82.165
 permit 151.148.64.46
 permit 172.18.82.145
 permit 172.18.97.14
 permit 172.18.127.26
 permit 172.16.127.0 0.0.0.255
ip access-list standard SNMP
 permit 151.148.64.46
 permit 172.18.97.14
 permit 172.16.127.0 0.0.0.255
 permit 172.16.158.0 0.0.0.255
 permit 172.16.168.0 0.0.0.255
ip access-list standard VTY
 permit 161.89.160.115
 permit 161.89.160.116
 permit 161.89.160.119
 permit 161.89.151.6
 permit 161.89.151.5
 permit 161.89.151.226
 permit 161.89.151.222
 permit 161.89.151.221
 permit 161.89.151.220
 permit 172.18.97.14
 permit 172.16.127.0 0.0.0.255
 permit 172.16.158.0 0.0.0.255
 permit 172.16.168.0 0.0.0.255
 permit 172.29.236.0 0.0.0.255
 permit 161.89.145.208 0.0.0.15
 permit 161.89.146.0 0.0.0.255
!
ip access-list extended xxx_MGMT
 permit ip host 172.29.236.2 161.89.151.0 0.0.0.255
 permit ip host 172.29.236.2 161.89.160.0 0.0.0.255
ip access-list extended Voice-Control
 permit tcp any any eq 1720
 permit tcp any any range 11000 11999
 permit udp any any eq 2427
 permit tcp any any eq 2428
 permit tcp any any range 2000 2002
 permit udp any any eq 1719
 permit udp any any eq 5060
ip access-list extended WAAS_Redirects
 permit tcp any 172.29.236.0 0.0.0.255
 permit tcp 172.26.236.0 0.0.0.255 any
!
ip sla responder
ip sla 1
 udp-jitter 209.45.202.58 32000 source-ip 63.234.161.70 source-port 32000 codec g711ulaw
 tos 160
 tag Austin to PDC
 frequency 30
 history distributions-of-statistics-kept 10
ip sla schedule 1 life forever start-time now
ip sla 2
 udp-jitter 209.45.202.110 32000 source-ip 63.234.161.70 source-port 32000 codec g711ulaw
 tos 160
 tag Austin to TDC
 frequency 30
 history distributions-of-statistics-kept 10
ip sla schedule 2 life forever start-time now
logging trap warnings
logging facility syslog
logging 172.16.127.11
logging 172.16.127.28
logging 172.18.97.14
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
!
route-map xxx_MGMT permit 10
 match ip address xxx_MGMT
!
!

!
!
!
control-plane
!
!
voice-port 0/0/0:23
!
voice-port 0/1/0:23
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 172.16.91.12 172.18.91.11
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 172.18.91.11 172.18.91.12
ccm-manager config
!
mgcp
mgcp call-agent 172.18.91.12 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp bind control source-interface GigabitEthernet0/1.136
mgcp bind media source-interface GigabitEthernet0/1.136
!
mgcp profile default
!
!
dial-peer voice 999020 pots
 service mgcpapp
 port 0/2/0
!
dial-peer voice 911 pots
 translation-profile outgoing ANI
 destination-pattern 911$
 port 0/1/0:23
 forward-digits 3
!
dial-peer voice 9410 pots
 translation-profile outgoing LOCAL
 destination-pattern 9410.......$
 port 0/1/0:23
 forward-digits 10
!
dial-peer voice 9443 pots
 translation-profile outgoing LOCAL
 destination-pattern 9443.......$
 port 0/1/0:23
 forward-digits 10
!
dial-peer voice 9667 pots
 translation-profile outgoing LOCAL
 destination-pattern 9667.......$
 port 0/1/0:23
 forward-digits 10
!
dial-peer voice 11 pots
 translation-profile outgoing LD
 destination-pattern 91[2-9].........$
 port 0/1/0:23
 forward-digits 11
!
dial-peer voice 9011 pots
 translation-profile outgoing INT
 destination-pattern 9011T
 port 0/1/0:23
 prefix 011
!
dial-peer voice 100 pots
 translation-profile incoming my_profile
 incoming called-number .
 direct-inward-dial
 port 0/1/0:23
!
dial-peer voice 512 pots
 translation-profile outgoing local
 destination-pattern 9512.......$
 port 0/1/0:23
 forward-digits 10
!
!
!
!
gatekeeper
 shutdown
!
!
banner motd ^C
================================================================
                 *** NOTICE TO ALL USERS ***

^C
!
line con 0
 login authentication console-login
 stopbits 1
line aux 0
 stopbits 1
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 67
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class VTY in
 privilege level 15
 password 7 08261F5A
 transport input ssh
line vty 5 15
 access-class VTY in
 privilege level 15
 password 7 08261F5A5
 transport input ssh
!
scheduler allocate 20000 1000
ntp authentication-key 1 md5 075F78186A5D3D507E7C7078 7
ntp authenticate
ntp trusted-key 1
ntp update-calendar
ntp server 192.168.1.1 key 1
ntp server 192.168.1.2 key 1
ntp server 192.168.1.21 key 1
end

Austin-MPLS#

Highlighted
Hall of Fame Cisco Employee

Well, whoever did this, did a

Well, whoever did this, did a messy job, it seems that both of your PRIs are supposed to be MGCP, you can confirm that in the CUCM config, but one is lacking config, if they're both supposedly MGCP

This is a good config:

interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bind-l3 ccm-manager <---- notice this command, which binds L3 to MGCP, as it has to be
no cdp enable


controller T1 0/1/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp

This is a half cooked config

controller T1 0/0/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp


interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable

Not sure if you have/had another port for MGCP

dial-peer voice 999020 pots
 service mgcpapp
 port 0/2/0

You also seem to have what might have been an attempt for SRST, but just as with the above PRI, is not fully configured

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cusrst/admin/sccp_sip_srst/configuration/guide/SCCP_and_SIP_SRST_Admin_Guide/srst_setting_up_the_network.html

Right now those dial-peers and translation rules, seem to be doing absolutely nothing, as they're supposed to use the PRI which is controlled by MGCP.

You might want to ask around if someone has some idea of what that ISR is supposed to do before removing and adjusting that config.

HTH

java

if this helps, please rate