cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1726
Views
13
Helpful
18
Replies
Kaushik Ray
Beginner

VoIP issues after IOS upgrade

Hello I am seeing a strange issue;

There is a Hub Router with IOS version c2800nm-spservicesk9-mz.124-24.T3.bin

There are some remote sites that connects to this Hub Router and all the remote sites run CMEs.

All the IP Phones on them are 7942s.

All services were working fine.

I had a requirement to upgrade the IOS (as the Hub Router needs to run VPN) and I got hold of a new flash put in all the relevant files that exists on the old flash apart from the new IOS image which I put in as c2800nm-adventerprisek9-mz.150-1.M9.bin

Powered down the router

Swapped out the flash cards and powered up the router again.

Data traffic was working fine

But the IP phones on the remote sites started having problems. When I called out the numbers I could see them hitting the router but could not hear the other end.

Since they are CMEs I thought the onshore router IOS change would not have affected anything.

I reverted back to the old IOS and all services have been restored and Voice services back to normal.

I compared all the files between the old flash and new flash (which I have attached with this post) and all identical including the file size of each file

apart from the following (these files exist on the old one twice but once on the new flash)

78     2496963 Feb 27 2008 19:53:18 apps11.8-3-2-27.sbn

79     7821474 Jan 04 2008 11:36:00 apps37sccp.1-1-1-1.bin

80     2494499 Feb 27 2008 20:03:44 apps41.8-3-2-27.sbn

and the following file exists on the old one but not on the new one

81        9968 Dec 17 2008 22:52:00 xml-test.html

But I would not have thought that these would have caused issues all the phones are 7942 and both the old and the new flash cards have

82      531737 Jun 02 2010 12:58:44 cnu42.9-0-3TH1-22.sbn

83     2162646 Jun 02 2010 12:59:10 cvm42sccp.9-0-3TH1-22.sbn

84      343211 Jun 02 2010 12:58:58 dsp42.9-0-3TH1-22.sbn

85     1756858 Jun 02 2010 12:59:04 jar42sccp.9-0-3TH1-22.sbn

86         676 Jun 02 2010 12:58:26 SCCP42.9-0-3S.loads

87         680 Jun 02 2010 12:58:32 term42.default.loads

88         680 Jun 02 2010 12:58:38 term62.default.loads

89     4581763 Jun 02 2010 12:58:50 apps42.9-0-3TH1-22.sbn

Any advice on this will be much appreciated if I am missing something.

Look forward to your advice and guidance and many thanks in advance.

Regards

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Ray,

I think u need to stick to same 12.4  version since 15.0(1)M9 is required for ISR G2 platforms.you can check the sheet.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm

In your case , it is 15.0(1)M9 installed on ISR 2800 router.

upgrading to above version 15.0(1)M9  also requires upgradation to CME 8.

This is what I think.

regds,

aman

View solution in original post

18 REPLIES 18

How the remote CMEs are connected through which call control protocol? SIP or H.323

Are you added "trusted address" which is new in 15.x image

Thanks a lot for your reply

the remote CMEs are all configured as H323

h323-gateway voip bind srcaddr xxx.xxx.xxx.xxx

and where do i need to add "trusted address" command?

Also I am running CME version as this

sh telephony-service

CONFIG (Version=7.1)

=====================

Version 7.1

Cisco Unified Communications Manager Express

For on-line documentation please see:

and Cisco site says this should be compatible with the IOS version I am running (

c2800nm-adventerprisek9-mz.150-1.M9.bin)

15.0(1)M9

7.1

7.1.1.0

Hi Kaushik,

trusted list commands are available under

voice service voip

you can use following for testing and then later add the trusted IP addresses. Following will disable trust list feature.

voice service voip

no ip address trusted authenticate

--

“If you have knowledge, let others light their candles in it.”

“If you have knowledge, let others light their candles in it.”

HI Amansin74

thanks for your reply. but the current version on the router i am trying to put in is before the version where this command was allowed?

My current version

c2800nm-adventerprisek9-mz.150-1.M9.bin

CME verision 7.1

Cisco advices this was enabled from the following

15.1(2)T

#

Cisco Unified CME 8.1

#

This command was introduced.

voice service voip

ip address trusted authenicate

ip address trusted list

ipv4 192.168.0.1 255.255.255.0

or

ipv4 0.0.0.0 0.0.0.0  (for all the IP addresses)

#show ip trusted address list

try the above command

Thanks again

Is this to be put in the Hub Router and the trusted list to be all the remote h323 ipaddresses?

Also this command i found int the Cisco site says

15.1(2)T

Cisco Unified CME 8.1

This command was introduced.

But my Router version will be

c2800nm-adventerprisek9-mz.150-1.M9.bin and CME version 7.1 or do I need for any IOS version 15 and upwards?

thanks

It does not allow the command under voice service voip as shown below:

Router#sh version | include flas

System image file is "flash:c2800nm-adventerprisek9-mz.150-1.M9.bin"

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#voice service voi

Router(config)#voice service voip

Router(conf-voi-serv)#no ip add ?

% Unrecognized command

Router(conf-voi-serv)#ip add?

% Unrecognized command

Hi Ray,

Toll Fraud Prevention was introduced from IOS 15.1(2)T

in your case , IOS has version 15.0(1)M9

regds,

aman

Thanks Aman

Hence my original question; if you could please see my original post I started having issues on VoIP by upgrading to

15.0(1)M9 and when I reverted back to the 12 IOS VoIP was restored.

I am not sure why this would happen; Any ideas.

If you can kindly check my original post; i have also attached the old and new flash card contents output.

Thanks again

Hi Ray,

I think u need to stick to same 12.4  version since 15.0(1)M9 is required for ISR G2 platforms.you can check the sheet.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm

In your case , it is 15.0(1)M9 installed on ISR 2800 router.

upgrading to above version 15.0(1)M9  also requires upgradation to CME 8.

This is what I think.

regds,

aman

View solution in original post

Thanks a lot Aman I will give it a try; I was actually confused as the compatibility matrix still showed

15.0(1)M9

7.1

7.1.1.0

But i will try with the 12.4 version

thanks again

Hi Ray,

Jus a correction , it is 15.0(1)M and not 15.0(1)M9 . 9 refers to note.

But what I referred is correct .

regds,

aman

Thanks Aman

Upgraded the Router to

c2811nm-adventerprisek9-mz.124-24.T3.bin from the SP services Variant and voice using CME is working fine.

As you pointed out the 15 version may need an upgrade on the CME as well.

Thanks a lot again!

Content for Community-Ad

Spotlight Awards 2021