cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
357
Views
0
Helpful
7
Replies

VoIP - Unknown UDP ports used

admincoco
Beginner
Beginner

Hi,

Im using CUCM 12.5 and UCCX for call center.

My users have Jabber + Cisco Finesse.

Randomly, my agents do not hear customers from external calls who pass through UCCX.

On debuging, I can see ports udp 4000 & 4001 denied on the network between agents and CUCM.

And also some 13xxx ports denied on the network between agents and voice gateway.

I cannot find any document relative to these UDP ports.

Do you have any information on these ports so I can open them all on the correct LAN ?

Thank you

1 Accepted Solution

Accepted Solutions

admincoco
Beginner
Beginner

Hi,

after weeks of troubleshooting, found the issue. On one voice gateway, first call was OK, second call was KO, third call was OK.

It looks like a weird issue on specific channels that i cannot explain. I miss some skills on that specific domain.

Told that to the communication operator and he did an iOS upgrade of the Voice link box (not my voice gateway).

Can't tell what is the operator box brand/model.

That did the job.

 

Edit :  Our configuration makes that it was noticed only UCCX calls but normal incoming calls were impacted also during tests.

View solution in original post

7 Replies 7

b.winter
Advocate
Advocate

Hi,

I also wouldn't have found anything for ports 4000 & 4001 UDP.

For "And also some 13xxx ports denied on the network between agents and voice gateway.":
Maybe the gateway is configured to use a wider UDP port range for media traffic, than it is configured in the FW?
E.g. GW uses UDP ports from 1024 to 65535, but FW only allows 16384 - 32766.

Thank you for your answser. 

Found that the 13xxx udp ports are used by new gateways. New model, new range. Ports opened and communication are OK.

 

But still have ports UDP 4000 and 4001 from agent computer to the CUCM, each time a call comes from UCCX only, when taking the call.

No port UDP 4000 & 4001 when getting a direct call. Not port UDP 4000 and 4001 when ringing.

Agents don't see any issue. I want to pass as everything is working, but I cant let it like that without understanding

Edit :

When taking the call, I can see 2 random ports 16xxx on my computer, used by CiscoJabber.exe . And this goes to CUCM on ports 4000 and 4001. Those ports close as soon as I end the call.

 

Scott Leport
Rising star
Rising star

Hi, 

Review these two links and make sure you have allowances for these TCP & UDP ports. 

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/admin/12_5_1SU3/systemConfig/cucm_b_system-configuration-guide-1251su3/cucm_m_tcp-and-udp-port-usage-12-0.html

UCCX:
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/crs/express_12_5/configuration/guide/rcct_b_1251port-utilization-guide-ccx/rcct_b_1251port-utilization-guide-ccx_chapter_01.html

Also issue a "show voip rtp conn" on your voice gateway to get the UDP port range it operates on. You may also want to make sure this UDP port range is allowed too. 

Hi Scott, 

thank you for your answer. None of the ports i m looking for are presente in the links you gave me.

Nevertheless, the command "show voip rtp connections" confirmed what I have read on another topic. My new gateway uses a new port range and that match what I've read. Ports allowed and one way voice issue is fixed now.

Just curious now about those two 4000 and 4001 UDP ports from Jabber to CUCM when taking an incoming call from UCCX.

Are you sure that its on UDP? There is an entry in the link I provided for ports 4000 - 4005, but they operate on TCP rather than UDP. 

There is also some discussion of it here. Old thread, but possibly still applicable: 

CUCM 8.6.2 RTP Port 4000 - Cisco Community

Yep, found that RTCP ports TCP 4000-4005 too.

But Im sure mine are UDP, got the print next to me, im sure they are UDP protocol.

Here is the netstat from a client after taking the call.

12840 is the PID of CiscoJabber.exe.

16512 and 16513 are the local ports.

UDP 192.168.X.X:16512 *:* 12840
UDP 192.168.X.X:16513 *:* 12840

On my firewall, i can track those sessions trying to reach the CUCM on ports UDP 4000 & 4001.

I can reproduce the same with another computer/IP/Jabber account on another LAN.

Always trying to reach CUCM on ports 4000 & 4001 when taking in incoming call from UCCX. 

No issue when taking an internal call, neither when taking a direct external call. This is specific to UCCX incoming calls on Jabber.

I cannot reproduce it using a physical IP phone.

 

Worth it to open a case for that ?

There is no issue reported on client side. Im just nervous not to find an explanation about those two ports.

 

admincoco
Beginner
Beginner

Hi,

after weeks of troubleshooting, found the issue. On one voice gateway, first call was OK, second call was KO, third call was OK.

It looks like a weird issue on specific channels that i cannot explain. I miss some skills on that specific domain.

Told that to the communication operator and he did an iOS upgrade of the Voice link box (not my voice gateway).

Can't tell what is the operator box brand/model.

That did the job.

 

Edit :  Our configuration makes that it was noticed only UCCX calls but normal incoming calls were impacted also during tests.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers