cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
890
Views
0
Helpful
3
Replies

What is the recommenden access port QoS configuration for 8900/9900 video enabled phones

aoster
Level 1
Level 1

Hi all,

we are currently starting to roll out some video enabled 9900 and 8900 phones in our network. In the past we did not use video and configured the access ports on our Catalyst 2960 switches with "auto qos voip ciscp-phone". This however creates a policy which does not include a class-map to correctly handle the AF41 video traffic coming from those phones. I have thougth about extending the autoqos policy with a AF41 class-map but am not sure if this is the right way to do it. 

That's what I have in mind:

!
class-map match-all AUTOQOS_VIDEO_DATA_CLASS
  match ip dscp af41

class-map match-all AUTOQOS_VOIP_DATA_CLASS
  match ip dscp ef
class-map match-all AUTOQOS_DEFAULT_CLASS
  match access-group name AUTOQOS-ACL-DEFAULT
class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
  match ip dscp cs3
!
policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
 class AUTOQOS_VOIP_DATA_CLASS
   set dscp ef
  police 128000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_VIDEO_DATA_CLASS
   set dscp af41
  police 1500000 8000 exceed-action policed-dscp-transmit

 class AUTOQOS_VOIP_SIGNAL_CLASS
   set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_DEFAULT_CLASS
   set dscp default
  police 10000000 8000 exceed-action policed-dscp-transmit
!

 

How do you guys do it ? Is there some documentation for this ? 

 

Thank you for your kind help

 

best regards

 

Andreas

1 Accepted Solution

Accepted Solutions

Andreas

You can user "sh policy-map X" and "show mls qos" , to check that your class apply or not.

No issues , you only added new class , and add it under policy-map , so no issues. If you need to create new classes which match your configurations , just follow the below:-

class-map match-all Video
  match ip dscp af41
class-map match-all Voice
  match ip dscp ef
class-map match-all Default
  match access-group name Default
class-map match-all Signal
  match ip dscp cs3


ip access-list extended Default
permit ip any any


policy-map CISCOPHONE-POLICY
 class Voice
   set dscp ef
  police 128000 8000 exceed-action policed-dscp-transmit
 class Video
   set dscp af41
  police 1500000 8000 exceed-action policed-dscp-transmit
 class Signal
   set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
 class Default
   set dscp default
  police 10000000 8000 exceed-action policed-dscp-transmit

interface range gig x/x/x -x
mls qos trust cos
mls qos trsust device cisco-phone
service-policy input CISCOPHONE-POLICY
priority-queue out
srr-queue bandwidth share 1 30 35 5

 

Thanks

Please rate all useful information

 

View solution in original post

3 Replies 3

islam.kamal
Level 10
Level 10

Hi

You have to keep this table on your mind. Your configuration is fine if your configuration for SD video , but if for HD video , it is not ok you have to change video bandwidth at least 5M.

Traffic TypeLayer 2 CoSLayer 3 IP PrecedenceLayer 3 DSCP
Voice RTP155EF
Voice control33AF31
Video conference44AF41
Streaming video (IP/TV)11AF13
Data0-20-20-AF23

 

*Interactive Video "AF41"- Sensitive but can tolerate packet loss of about 1% and latency almost same as voice.
*Streaming Video "AF13" - Less sensitive - can tolerate about 4-5% packet loss and latency of about 4-5 seconds.

*HD video conference will require between 5M to 16M , but SD video conference will use 384K to 1 M

Note:-Video QOS , if you will assume that your video conference will use around 384K , you have to add 20% because video conference include voice so the total bandwidth 460K.

 

Kindly check the below link

http://www.sdcug.com/wp-content/uploads/2011/04/Campus-QoS-for-Voice-and-Video.pdf

 

Thanks

please rate all useful information

 

Hello islam.kamal,

thank you for your answer. From what I have read in the documentation for the two IP phone series  8900 and 9900, the maximum video bandwidth will be around 1MBit/s, so to be on the save side I have choosen 1,5MBit/s.

What I am not sure about is if it is advisable to use/modify the auto qos policy for that purpose or if it would be better to create a new custom policy. It would however be more convenient to use the auto qos policy because I could still use the "auto qos voip cisco-phone" command at interface level.

 

Thank you for your kind help

best regards

Andreas

Andreas

You can user "sh policy-map X" and "show mls qos" , to check that your class apply or not.

No issues , you only added new class , and add it under policy-map , so no issues. If you need to create new classes which match your configurations , just follow the below:-

class-map match-all Video
  match ip dscp af41
class-map match-all Voice
  match ip dscp ef
class-map match-all Default
  match access-group name Default
class-map match-all Signal
  match ip dscp cs3


ip access-list extended Default
permit ip any any


policy-map CISCOPHONE-POLICY
 class Voice
   set dscp ef
  police 128000 8000 exceed-action policed-dscp-transmit
 class Video
   set dscp af41
  police 1500000 8000 exceed-action policed-dscp-transmit
 class Signal
   set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
 class Default
   set dscp default
  police 10000000 8000 exceed-action policed-dscp-transmit

interface range gig x/x/x -x
mls qos trust cos
mls qos trsust device cisco-phone
service-policy input CISCOPHONE-POLICY
priority-queue out
srr-queue bandwidth share 1 30 35 5

 

Thanks

Please rate all useful information

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: