cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
386
Views
0
Helpful
4
Replies
angelo castro
Beginner

Why Cannot Connect Cisco 7975G IP Phones to Cisco 2911 router

HI Everybody,

I need Assistance why Cisco 7975G cannot connect to cisco 2911 router.

Before the router I connect first to unmanaged POE switch.

 

I attach configuratipn of the router.

 

Thanks,

Angelo 

4 REPLIES 4
Chris Deren
Hall of Fame Master

Are other phones working?

What is the issue?

Is phone getting IP address and proper TFTP?

Have you looked at debug ephone register to see what is going on?  debug tftp-events?

Hi Chris,

Phone not Working.....

Issue is phone Show only Connecting

I'm think not getting IP address and proper TPTP.

I'm using Cisco Configuration Professional and not familiar with cisco ios command

 

Regards,

Angelo

What IP address is the IP phone getting ? Have a look at the menu Parameters > Network Configuration > IPv4 Configuration > IP address.

How did you configure the trunk port between the router and the switch ?

How did you declare the vlans in the switch ? Did you declare the voice vlan on the switch and affected the Interfaces to that voice vlan ?

 

If the switch is not manageable, then I think you have to work with the Native vlan, and add the option 150 (TFTP) to the DHCP pool of the native vlan (which is VLAN 1 in your config).

Phone IP Address show 192.168.40.8

and this my setting

interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/2.1
encapsulation dot1Q 1 native
ip address 192.168.40.1 255.255.255.0
!
interface GigabitEthernet0/2.10
encapsulation dot1Q 10
ip address 10.1.3.1 255.255.255.0
ip pim dense-mode
!
interface GigabitEthernet0/2.30
encapsulation dot1Q 30
ip address 10.7.1.1 255.255.255.0
!
interface GigabitEthernet0/2.50
encapsulation dot1Q 50
ip address 10.1.1.10 255.255.255.0
!
interface GigabitEthernet0/2.100
description $ETH-LAN$
encapsulation dot1Q 100
ip address 10.1.5.1 255.255.255.0
ip pim dense-mode
ip nat inside
ip virtual-reassembly in
!
interface Serial0/0/0:23
description MainCon
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable

 

What is the command to the

add the option 150 (TFTP) to the DHCP pool of the native vlan (which is VLAN 1 in your config).

im just beginner on cisco ios command. now im using CCP.

 

Regards,

Angelo

Content for Community-Ad

Spotlight Awards 2021