cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9789
Views
10
Helpful
12
Replies
Highlighted
Beginner

Why won't my 7941G-GE boot or register in CM after a reset?

I am having an issue with a Cisco 7941G-GE (SCCP) not booting after a reset.  I got a report of a PC not able to connect through a phone that has been in service.  I swapped out cabling and tried a couple of, known good, laptops so I am fairly confident it is the phone and/or the PC port on the phone.

I verified that the PC port was enabled in Call Manager (CCM 7.1.5) and did a "Servce - **#**" reset but as the phone was rebooting I saw it was trying to update to sccp41.9.0 but was getting an "auth failed" error.

It would cycle through the fail a couple of times and then finish booting.  I  didn't know but was hoping that it was causing the issue with the PC port so it did a Soft, "123456789*0#" hoping it would reload the firmware. 

That was when things just started getting worse.  After the soft reset it would start the update and then go to the Cisco logo and freeze.  I gave it pleanty of time before trying it again with the same results.

At that point, I did a, "3491672850*#" hard reset but that just wiped it out.  It went to a blank screen and is just dead in the water.  Every so often the speaker key will light up for a minute and the line 1 LED flashes and it is dead again.

Will CCM reload the firmware after a hard reset? I have verified DHCP has the code 150 for CM and that the TFTP server has the files but it won't connect, register or load.

Thanks!

12 REPLIES 12
Highlighted
Hall of Fame Master

You may need term41.default.loads from an older version, what you're trying to load is too new.

If you search, there are many similar thread with all the details.

Highlighted
Beginner

Hi Nick,

Have you been able to find a solution to this? I am also having the same problem even after setting up TFTP with sip version 8.2.1. I have already tried the latest version of SIP. My phone and TFTP server are on the same subnet and the firewall is off. I do know that the TFTP is reachable because my Polycom IP 430 phone just pulled the config files from the same TFTP server. I removed the polycom files and added the following files to the TFTP folder:

apps41.8-2-0-55.sbn

cnu41.8-2-0-55.sbn

cvm41sip.8-2-0-55.sbn

dsp41.8-2-0-55.sbn

jar41sip.8-2-0-55.sbn

SIP41.8-2-1S.loads

term41.default.loads

term61.default.loads

My DHCP is on, my 7941G phone IP is 192.168.1.3 and my TFTP server is 192.168.1.2. Can you or anyone help with this?

Highlighted

Hi Mohammad,

Are you been able to find a solution to this? I am also having the same problem, My 7941G freeze on Cisco Logo while booting up

Please reply me if u have solution

Regards

VIkrant

Highlighted

My problem was worse. I had a blank screen but I managed to resolve it.

http://www.fonality.com/trixbox/forums/vendor-forums-non-certified/linksys/cisco/cisco-7945g-sip-image

Highlighted

Bro Thanks for your quick reply,

We have CISCO IP phone 7941 for using VOIP from SIP provider, IINET is providing to us, It has default SIP Image, it is New SIP phone, Ive seen all the stuff out there, and have been unable to find the answer.

Now I have below files on TFTP Server
apps41.8-3-0-50.sbn
cnu41.8-3-0-50.sbn
cvm41sip.8-3-0-50.sbn
dialplan.xml
dsp41.8-3-0-50.sbn
jar41sip.8-3-0-50.sbn
OS79XX.TXT
P0S3-08-4-00.loads
P0S3-08-4-00.sb2
P003-08-4-00.bin
P003-08-4-00.sbn
SEP001B2AC76B9A.cnf.xml
SIP41.8-3-1S.loads
SIPDefault.cnf
term41.default.loads
XmlDefault.cnf.xml

can u Send Me ur Config File, Please dear help me my Email ID is Vikrant.ambhore@gmail.com

Highlighted
Contributor

Same problem here.  After doing a "123456789*0#" factory reset, my 7941 got stuck stuck in an upgrade cycle, so I tried the procedure again with "3491672850*#".  Now the LCD screen is blank.  However it's still doing the reboot cycle!  The TFTP server logs show a request for 'term41.default.loads' every 3 minutes. 

Highlighted

Have you read above ?

Highlighted

Paolo, pointed you in the right direction above. Search the forum and you will see many resolved issues like this. Take some time and be pro-active. There is much fun in learning through finding...

The term41.default.loads you have is too new for your phone to download.

May I suggest that please take the time to understand what you are doing before you do it. Do you know what the last action you did on that phone did to it...

Here is a detailed explanation of what you do when you do those resets..Understanding it will help you decide if its what you should be doing..

Soft Reset

The code for the soft factory reset is: 123456789*0#

A soft reset does the following:

  • •1.     deletes key files on the phone including /etc/init.tab
  • •2.     reboots
  • •3.     phone recovers default loads file from TFTP server

#Total Hard Reset

The code for the total hard reset is: 3491672850*#

A total hard reset formats /flash0 blowing away everything except CNU.  All settings and personalization of the phone is removed.

#Hard Reset with Network Setting Preservation

The code for the network preservation hard reset is: *7412369#085

And it also does a complete format of /flash0 - yet it preserves the network settings so that after the format, any static IP and other network settings are preserved. The settings are stored in volatile RAM, so it is important to not remove power to the phone during this process

For CSCsi60439 reference please see document EDCS-609633.

#Prerequisites

There are a number of prerequsites that are necessary for a successful factory reset.

  • •4.     You must have a network environment in which DHCP is used to provide the phone with an IP address and a TFTP server (i.e. DHCP option 150).
  • •5.     There must be an appropriate default load for your phone model on that TFTP server:      
  • The default load name is: termxx.default.loads (where xx is part of the model number, 41 for 7941, 62 for 7962, 70 for 7970, etc.)
  • The version of the default load must be the same signing type (dev or release) as the phone on which you wish to do a factory reset.
  • This file (termxx.default.loads) is packaged with every phoneload that is installed on the callmanager, but since the name is not unique per phoneload version, the copy of termxx.default.loads is always the one from the most recent load that was installed on the callmanager. It may not be the type (dev or release) that you want.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts
Highlighted

That's useful information.  Lots of the documentation out there, even that provided by Cisco, does not clearly explain the distrinction between the 123456789*0# and 3491672850*# reset codes.

What is the difference between dev and release signing types?  And how would I determine which to download?

Highlighted

Well never mind - my solution was the 8-5-2 firmware, specifically 8-5-2SR1.  Once I loaded that on the TFTP server, the phone took the images and came back to life. 

Note you have to be patient, since the upgrade will take about 3 minutes and the display will still be blank during this time.

Highlighted

Johnny glad you resolved it. Thanks for the nice rating. On the forum I have atlease solved 4 of this type of issues. Usually your cucm is on a 9.X release firmware and your phones are on a firmware that is too old to upgrade to that firmware. The 8.5.2 is a bridge firmware. Your phones can only upgrade to that firmware first and then they can then upgrade to the fimware on your cucm/cme. Just thought I should let you know why its working

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts
Highlighted

I did understand that 8-5-2 was a bridge release to the higher versions, I just don't understand why my phone wouldn't accept a 8-2, 8-3, or 8-4 version. All of them have worked in the past.  Oh well, all's well that ends well.  8-5-2SR1 seems to be stable and works with Asterisk, so that long overdue upgrade is now completed. 

Something I noticed from the other threads - if the phone is not reaching the TFTP server, note that after doing a factory reset the phone will not use the "switchport voice vlan" configuration.  It will just use the vlan set on the switch port (or native vlan on a trunk port).  My assumption is the bootloader does not support CDP.

Content for Community-Ad