cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
339
Views
0
Helpful
8
Replies

wrong vlan to ip phone

i assigned voice vlan  to vlan 120

and data vlan to vlan 130

but some ip phone assigned to vlan 130 and work normal

it should changes it manually from ip phone setting

8 REPLIES 8

Check the switchport settings

Check the switchport settings on the switch the phone is connected to. Does it have the voice vlan configured for the port - command "switchport voice vlan x"? Depending on your network topology it is very possible that a phone will work on the data vlan. However, voice traffic may not get the proper QoS treatment, etc.

Brandon

this command is configured ,

this command is configured , i think the problem in QOS

Beginner

Is your voice DHCP scope

Is your voice DHCP scope local to 2960 switch or somewhere else?  Also could you please post running config of your 2960 switch?


-Deven Gandhi
*Please rate all useful post

!interface GigabitEthernet1/0

!
interface GigabitEthernet1/0/1
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/3
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/4
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/5
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/6
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/7
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/8
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/9
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/10
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/11
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/12
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/13
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/14
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/15
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/16
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/17
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/18
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/19
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/20
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/21
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/22
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/23
switchport access vlan 3
switchport mode access
switchport voice vlan 120
spanning-tree portfast
!
interface GigabitEthernet1/0/24
switchport mode trunk

Frequent Contributor

Upgrade firmware on 3905, I

Upgrade firmware on 3905, I have seen that 3905 doesn't go in the correct VLAN

JH

Highlighted
Cisco Employee

Hi,

Hi,

Can you tell me what model Cisco IP phones and switches are you using?

Regards,

Ankoor Bek

ip phone 3905 switch 2960x

ip phone 3905

switch 2960x

Rising star

Could you explain the issue a

Could you explain the issue a little more?

I 'think' you are saying that your IP phones are picking up a DHCP address from the data vlan instead of the Voice VLAN, is that correct?

Thanks

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards