Showing results for 
Search instead for 
Did you mean: 

Yet Another Custom Background Image Problem....

Level 1
Level 1

Hi all,

I am now attempting to configure custom backgrounds on my 2811 router, which has phones consisting of 7971's, 7945's, 7975's, 7911's and 7941's. I have tried time and time again, and followed all guides, such as the one linked below, and still, just get "selections unavailable". Does anyone have a definate guide on how to accomplish this for multiple phone types without problems? (I have even used backgrounds.tar from Cisco's site, and still can't even get one of the standard Cisco images to appear, even though the xtract command sets it all up for me! (and yes I have been tftp-server flashing!

I have been going around in circles for the last 3 hours trying to get ONE custom image to appear on any phone, and it's frustrating the **** out of me!

I have set the images to the required pixels and everything.

Can someone please help?



1 Accepted Solution

Accepted Solutions


Try this:

tftp-server flash:/Desktops/320x216x16/List.xml alias Desktops/320x216x16/List.xml

Worked for me with a similar issue.



Sent from Cisco Technical Support iPad App

View solution in original post

5 Replies 5

Aaron Harrison
VIP Alumni
VIP Alumni

Hi Nic

Basically you need to debug your tftp server, and watch what happens on the debug when you press buttons on the phone.

The process is basically:

You press the 'background' option

Phone requests the xml file

Phone parses the xml file and reads each thumbnail image from TFTP

You select an image

Phone downloads that image

If you are getting the selections unavailable, run debug tftp-server events on the router and ensure you are seeing the output (term mon etc)

Press backgrounds - you should see the phone attempt to get the XML file. If it fails, check your tftp server config

You should then see it grab the thumbnails - if you don't see this, it's likely your XML file is bad. Post it up here - any miscapitalisation or errors will simply not work.

Again, if you see errors downloading the thumbnails, your XML has been read OK, but the filenames are wrong or your TFTP server setup is not right.



Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Hi Aaron,

This is what I have so far.

Dir Flash Output, Desktops output, and the 320x216x16 Output for the 7975 as follows:

Router#dir flash:

Directory of flash:/

    1  drw-           0   Apr 1 2012 16:29:14 +10:00  GUI

   20  drw-           0   Apr 4 2012 13:23:02 +10:00  EA

   55  drw-           0   Apr 1 2012 15:23:54 +10:00  ATA

   57  -rw-      883261   Apr 2 2012 12:23:02 +10:00

   58  drw-           0   Apr 6 2012 12:10:08 +10:00  Rings

   74  drw-           0  May 26 2012 22:42:30 +10:00  Desktops

  103  -rw-    64652888   Apr 1 2012 15:32:02 +10:00  c2800nm-adventerprisek9-mz.151-2.T1.bin

  104  drw-           0   Apr 1 2012 14:41:36 +10:00  Phones

Router#dir flash:Desktops

Directory of flash:/Desktops/

   85  drw-           0  May 26 2012 22:43:22 +10:00  320x216x16

  100  -rw-        4473  May 26 2012 22:44:44 +10:00  TN-OP-Color.png

  210  -rw-       42056  May 26 2012 22:45:28 +10:00  OP-Color-7975.png

  203  -rw-        2089  May 26 2012 22:46:14 +10:00  TN-Cisco-Color-7975.png

  101  -rw-        8156  May 26 2012 22:46:28 +10:00  Cisco-Color-7975.png

Router#dir flash:Desktops/320x216x16

Directory of flash:/Desktops/320x216x16/

   76  -rw-         245  May 27 2012 11:12:06 +10:00  List.xml

TFTP Server Flash Commands as follows:

tftp-server flash:/Desktops/OP-Color-7975.png

tftp-server flash:/Desktops/TN-OP-Color.png

tftp-server flash:/Desktops/Cisco-Color-7975.png

tftp-server flash:/Desktops/TN-Cisco-Color-7975.png

tftp-server flash:/Desktops/320x216x16/List.xml

A copy of my List.xml File



And finally, an output of TFTP Debug

*May 27 01:26:03.626: TFTP: Looking for Desktops/320x216x16/List.xml

(That's all I get).

Any ideas?

Thank you!!



Try this:

tftp-server flash:/Desktops/320x216x16/List.xml alias Desktops/320x216x16/List.xml

Worked for me with a similar issue.



Sent from Cisco Technical Support iPad App


Thank you so, so, so, so much! Nailed it in one! You have no idea how frustrating this was!

Thanks again


+5 for you David,

Excellent work!

Please rate all useful posts