cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

737
Views
0
Helpful
1
Replies
Beginner

6to4 tunnel

R1----R2---R3

The underlying IPv4 routing works fine as i can ping r1 fromr3.

I have configured a tunnel between R1 and R3. But I can't ping ipv6 between the two tunnel ends. The tunnel interface is up/up on both ends.

any idea?

thanks first

=====R1=====

interface Tunnel2

no ip address

no ip redirects

ipv6 address 2002:C0A8:6301::1/100

tunnel source Serial0/0

tunnel destination 1.1.23.3

tunnel mode ipv6ip 6to4

!

interface Serial0/0

ip address 1.1.12.1 255.255.255.0

serial restart-delay 0

ip route 0.0.0.0 0.0.0.0 1.1.12.2

=====R2=====

interface Serial0/0

ip address 1.1.12.2 255.255.255.0

serial restart-delay 0

!

interface Serial0/1

ip address 1.1.23.2 255.255.255.0

serial restart-delay 0

!

ip route 0.0.0.0 0.0.0.0 1.1.23.2

======R3=====

interface Tunnel2

no ip address

no ip redirects

ipv6 address 2002:C0A8:6301::2/100

tunnel source Serial0/0

tunnel destination 1.1.12.1

tunnel mode ipv6ip 6to4

!

interface Serial0/0

ip address 1.1.23.3 255.255.255.0

serial restart-delay 0

1 REPLY 1
Highlighted
Cisco Employee

6to4 tunnel

Hi,

There are a couple of things here:

- 6To4 implements multipoint tunnels so you don't need to specify the tunnel destination as it's embedded into the IPv6 address

- Your tunnel IPv6 addresses don't reflect your public IPv4 addresses:

R1 IPv4 @ is 1.1.12.1 which becomes 2002:0101:0c01::1/100

R3 IPv4 @ is 1.1.23.1 which becomes 2002:0101:1701::1/100

- IPv6 routing needs to be enabled on R1 and R3:

ipv6 unicast-routing

ipv6 cef

ipv6 route 2002::/16 tunnel 2

Here is a white paper presenting 6to4 tunnelling techniques:

http://www.cisco.com/web/about/ac123/ac147/ac174/ac197/about_cisco_ipj_archive_article09186a00800c830a.html

HTH

Laurent.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards