cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

268
Views
0
Helpful
0
Replies
Highlighted
Beginner

Dynamic ipv6 prefix delegation from provider change lifetime for better convergence

Hello,

I've a cisco 2901 with 15.7(3)M2 with a vdsl modul connected to a german Provider (deutsche Telekom). Technically everything is fine, but I've a problem with convergence when my router reboots and/or my dsl line is flapping.

They use ppp and I use dhcp client to get the prefix delegation pool stored in general-prefix TKOM:

interface Dialer1
description WAN
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ipv6 address autoconfig default
ipv6 enable
ipv6 nd prefix default 120 60
ipv6 nd ra suppress all
ipv6 tcp adjust-mss 1432
ipv6 dhcp client pd TKOM rapid-commit
ppp ipcp dns request accept
ppp ipcp route default
!

If I look at my prefix you'll see the following:

IPv6 Prefix TKOM, acquired via DHCP PD
  2003:E9:E3DB:AFFE::/56 Valid lifetime 13618, preferred lifetime 1018
   GigabitEthernet0/0.101 (Address command)

First the prefix is dynamic, every dsl reconnect I'll get a new prefix and you see the preferred lifetime is 1018 seconds (could be even higher) nearly 17 minutes. Now I assign first /64 on gi0/0.99:

interface GigabitEthernet0/0.99
 encapsulation dot1Q 99
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
ipv6 address TKOM ::1/64 ipv6 enable
ipv6 address ipv6 nd prefix default 120 60 ipv6 nd router-preference High ipv6 nd advertisement-interval ipv6 nd ra lifetime 60 ipv6 nd ra interval 20 15 ipv6 tcp adjust-mss 1432 !

Behind this is a switch and access points, and every of my clients (Mac OS X, Apple IOS and Linux) get a address on the prefix. Everything is working fine.

But when my dsl is flapping or I reboot my router. My clients get the new prefix if dsl is up, but still had also address from old prefix learned. They will discard it after the lifetime has expired. But until this had happend I can't use my ipv6 because my provider will not allow me to send traffic with old prefix.

So my problem is that I've a dynamic ipv6 prefix, which I can't change as a private person and that the provider set up a very high lifetime. I understand that the don't want so many queries on there system but I haven't found a way to change lifetime for my clients to speed up convergence ( for example check every minute). Since my Router directly knows the prefix is gone, but at least I don't know how it could transfer this data to the clients and also there is no way to change lifetime.

Anyone had an idea? I also know that the 2901 is pretty old and I would upgrade it with a newer model + software but at least haven't found a solution in the newest software using 1000V as well.

I also wasn't able to setup a dhcp server learning the prefix from ppp and setup a own lifetime, if some has an idead, please let me know.

kind regards

Viets

 

Everyone's tags (2)
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards