02-18-2022 05:08 AM
I'm testing the ipv6 BGP routing.
I have configured as below, but communication is not working.
What am I missing?
In addition, what are the settings for best practices of ipv6 routing?
Thanks for your help.
Solved! Go to Solution.
02-18-2022 05:39 AM - edited 02-18-2022 05:45 AM
Hi @chaname ,
2010::1/126 and 3010::1/126 are not part of the same subnet, so they can't communicate with each other.
It would work if you used 3010::1/126 on one side and 3010::2/126 on the other, as these two IPv6 addresses are part of the same subnet.
You need to configure a common subnet between IOU_R-2 and IOU_R-3 for the two routers to have IPv6 connectivity and for the BGP session to come up. I would also recommend using using RFC3848 IPv6 addresses (2001:db8::/32), which I normally used for lab testing. Please configure something as follow:
IOU_R-2:
interface e0/0
ipv6 address 2001:db8::1/64
!
router bgp 65000
no bgp default ipv4-unicast
neighbor 2001:db8::2 remote-as 64600
address-family ipv6 unicast
neighbor 2001:db8::2 active
!
IOU_R-3:
interface e0/0
ipv6 address 2001:db8::2/64
!
router bgp 64600
no bgp default ipv4-unicast
neighbor 2001:db8::1 remote-as 65000
address-family ipv6 unicast
neighbor 2001:db8::1 active
!
Regards,
02-18-2022 05:39 AM - edited 02-18-2022 05:45 AM
Hi @chaname ,
2010::1/126 and 3010::1/126 are not part of the same subnet, so they can't communicate with each other.
It would work if you used 3010::1/126 on one side and 3010::2/126 on the other, as these two IPv6 addresses are part of the same subnet.
You need to configure a common subnet between IOU_R-2 and IOU_R-3 for the two routers to have IPv6 connectivity and for the BGP session to come up. I would also recommend using using RFC3848 IPv6 addresses (2001:db8::/32), which I normally used for lab testing. Please configure something as follow:
IOU_R-2:
interface e0/0
ipv6 address 2001:db8::1/64
!
router bgp 65000
no bgp default ipv4-unicast
neighbor 2001:db8::2 remote-as 64600
address-family ipv6 unicast
neighbor 2001:db8::2 active
!
IOU_R-3:
interface e0/0
ipv6 address 2001:db8::2/64
!
router bgp 64600
no bgp default ipv4-unicast
neighbor 2001:db8::1 remote-as 65000
address-family ipv6 unicast
neighbor 2001:db8::1 active
!
Regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide