cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1200
Views
0
Helpful
2
Replies

IPV6 BGP

uni1389
Level 1
Level 1

Hello  All, 

I am trying to configure IPV6 BGP  between two directly connected routers, but am not able to ping directly connected interfaces and of course BGP neighborship is also not establishing. Configuration is mentioned for your feedback. 

 

 R1 configuration 


interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ipv6 address 2000:CC13:CC13:CC13::1/128
end

interface Loopback0
ip address 1.1.1.1 255.255.255.255
ipv6 address 2000:CC13:CC13:1::1/128
end

router bgp 65515
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2.2.2.2 remote-as 65516
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 password C1sc0!
neighbor 2.2.2.2 update-source Loopback0
neighbor 2000:CC13:CC13:2::1 remote-as 65516
neighbor 2000:CC13:CC13:2::1 ebgp-multihop 2
neighbor 2000:CC13:CC13:2::1 password C1sc0!
neighbor 2000:CC13:CC13:2::1 update-source Loopback0
!
address-family ipv4
neighbor 2.2.2.2 activate
exit-address-family
!
address-family ipv6
neighbor 2000:CC13:CC13:2::1 activate
exit-address-family

ip route 2.2.2.2 255.255.255.255 192.168.1.2
ipv6 route 2000:CC13:CC13:2::1/128 2000:CC13:CC13:CC13::2

 

R1#ping ipv6 2000:CC13:CC13:CC13::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:CC13:CC13:CC13::2, timeout is 2 seconds:

% No valid route for destination
Success rate is 0 percent (0/1)
R1#ping ipv6 2000:CC13:CC13:CC13::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:CC13:CC13:CC13::1, timeout is 2 seconds:
!!!!! 

 **************************************************

 R2 configuration 

 

R2#show run interface gigabitEthernet 0/0
Building configuration...

Current configuration : 157 bytes
!
interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
media-type rj45
ipv6 address 2000:CC13:CC13:CC13::2/128
end

R2#show run interface lo
R2#show run interface loo2
Building configuration...

Current configuration : 101 bytes
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
ipv6 address 2000:CC13:CC13:2::1/128
end

R2#show run | sec router bgp
router bgp 65516
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 65515
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 password C1sc0!
neighbor 1.1.1.1 update-source Loopback2
neighbor 2000:CC13:CC13:1::1 remote-as 65515
neighbor 2000:CC13:CC13:1::1 ebgp-multihop 2
neighbor 2000:CC13:CC13:1::1 password C1sc0!
neighbor 2000:CC13:CC13:1::1 update-source Loopback2
!
address-family ipv4
neighbor 1.1.1.1 activate
exit-address-family
!
address-family ipv6
neighbor 2000:CC13:CC13:1::1 activate
exit-address-family
R2#
R2#show run | sec route
router bgp 65516
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 65515
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 password C1sc0!
neighbor 1.1.1.1 update-source Loopback2
neighbor 2000:CC13:CC13:1::1 remote-as 65515
neighbor 2000:CC13:CC13:1::1 ebgp-multihop 2
neighbor 2000:CC13:CC13:1::1 password C1sc0!
neighbor 2000:CC13:CC13:1::1 update-source Loopback2
!
address-family ipv4
neighbor 1.1.1.1 activate
exit-address-family
!
address-family ipv6
neighbor 2000:CC13:CC13:1::1 activate
exit-address-family
ip route 1.1.1.1 255.255.255.255 192.168.1.1
ipv6 route 2000:CC13:CC13:1::1/128 2000:CC13:CC13:CC13::1
R2#

 

R2#ping ipv6 2000:CC13:CC13:CC13::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:CC13:CC13:CC13::1, timeout is 2 seconds:

% No valid route for destination
Success rate is 0 percent (0/1)
R2#ping ipv6 2000:CC13:CC13:CC13::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:CC13:CC13:CC13::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R2#

 

 

 

2 Replies 2

balaji.bandi
Hall of Fame
Hall of Fame

have you enabled ipv6 unicast routing and check the p2p IP reachable? - follow the below guide 

https://www.cisco.com/c/en/us/support/docs/ip/ip-routed-protocols/112228-bgp2isp-00.html

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Harold Ritter
Cisco Employee
Cisco Employee

Hi @uni1389 ,

You configured the wrong subnet length on the Gigi interface on R1 and R2. You need to change it to a /64 so that the two routers have a common subnet.

R1:

interface GigabitEthernet0/0
ipv6 address 2000:CC13:CC13:CC13::1/64

R2:

interface GigabitEthernet0/0
ipv6 address 2000:CC13:CC13:CC13::2/64

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: