cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1497
Views
0
Helpful
4
Replies
melve
Beginner

[Ipv6] Conflict with EIGRPv3 and OSPFv3

Hello people, I've been having trouble making OSPF and EIGRP work in the same topology. I managed to make EIGRP work between Laptop0 and R2, but once I configured OSPF between PC0 and R2, EIGRP stopped working. Here is a screenshot of the topology and the configuration I did in the 3 routers:

 



image.png

image.png

R1(config)#ipv6 router eigrp 1
R1(config-rtr)#eigrp router-id 1.1.1.1
R1(config-rtr)#no shutdown
R1(config-rtr)#exit
R1(config)#int s0/0/0
R1(config-if)#ipv6 eigrp 1
R1(config-if)#int g0/0
R1(config-if)#ipv6 eigrp 1
R1(config-if)#exit

-----------------------------------

R2(config)#ipv6 router eigrp 1
R2(config-rtr)#eigrp router-id 2.2.2.2
R2(config-rtr)#no shutdown
R2(config-rtr)#exit
R2(config)#int s0/0/0
R2(config-if)#ipv6 eigrp 1
R2(config-if)#exit

R2(config)#ipv6 router ospf 1
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#exit
R2(config)#int s0/0/1
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#exit

-----------------------------------

R3(config)#ipv6 router ospf 1
R3(config-rtr)#router-id 1.1.1.1
R3(config-rtr)#exit
R3(config)#int s0/0/1
R3(config-if)#ipv6 ospf 1 area 0
R3(config-if)#int g0/0
R3(config-if)#ipv6 ospf 1 area 0
R3(config-if)#exit

Thanks in advance, and excuse my poor english!

EDIT: File attached.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

I found that you forget to redistribution routes between EIGRP and OSPF.  Route redistribution allows a network that uses one routing protocol to route traffic dynamically based on information learned from another routing protocol.

 

Second issue found with IPv6 Subnetting:

 

Here is the missing configuration on R2:

ipv6 router ospf 1
router-id 2.2.2.2
redistribute eigrp 1 metric 1000 
!
ipv6 router eigrp 1
redistribute ospf 1 metric 100000 10 255 1 1500

 

Issue Second: Subnetting issue on R1 to Laptop0 and R3 to PC0. Those subnets are overlapping.

 

R1 Subnet on Gig0/0: FEC0:AC8::/108

Range: fec0:ac8:0:0:0:0:0:0
            fec0:ac8:0:0:0:0:f:ffff

 

R3 subnet on Gig0/0:: FEC0:AC8::1:0/111

Range: fec0:ac8:0:0:0:0:0:0
          fec0:ac8:0:0:0:0:1:ffff

 

So I changed IP subnet on the R1 as below:

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FEC0:AC8::1:0:1/108
ipv6 eigrp 1
ipv6 enable

 

Regards,

Deepak Kumar

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

View solution in original post

4 REPLIES 4
Deepak Kumar
VIP Advocate

Hi,

can you share your LAB in an attachment?

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

Yes! Here it is :)

Hi,

I found that you forget to redistribution routes between EIGRP and OSPF.  Route redistribution allows a network that uses one routing protocol to route traffic dynamically based on information learned from another routing protocol.

 

Second issue found with IPv6 Subnetting:

 

Here is the missing configuration on R2:

ipv6 router ospf 1
router-id 2.2.2.2
redistribute eigrp 1 metric 1000 
!
ipv6 router eigrp 1
redistribute ospf 1 metric 100000 10 255 1 1500

 

Issue Second: Subnetting issue on R1 to Laptop0 and R3 to PC0. Those subnets are overlapping.

 

R1 Subnet on Gig0/0: FEC0:AC8::/108

Range: fec0:ac8:0:0:0:0:0:0
            fec0:ac8:0:0:0:0:f:ffff

 

R3 subnet on Gig0/0:: FEC0:AC8::1:0/111

Range: fec0:ac8:0:0:0:0:0:0
          fec0:ac8:0:0:0:0:1:ffff

 

So I changed IP subnet on the R1 as below:

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FEC0:AC8::1:0:1/108
ipv6 eigrp 1
ipv6 enable

 

Regards,

Deepak Kumar

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

View solution in original post


@Deepak Kumar wrote:

Issue Second: Subnetting issue on R1 to Laptop0 and R3 to PC0. Those subnets are overlapping.

 

R1 Subnet on Gig0/0: FEC0:AC8::/108

Range: fec0:ac8:0:0:0:0:0:0
            fec0:ac8:0:0:0:0:f:ffff

 

R3 subnet on Gig0/0:: FEC0:AC8::1:0/111

Range: fec0:ac8:0:0:0:0:0:0
          fec0:ac8:0:0:0:0:1:ffff


Indeed! That was the issue! Thank you very much! :D

Content for Community-Ad
This widget could not be displayed.