cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
22564
Views
45
Helpful
31
Replies

IPv6 on vlans

mchance
Beginner
Beginner

I finally figured out how to get IPv6 on my outside and inside interfaces of my router (Cisco 2821) and on the uplink port on my switch (Cisco 3750).  All three IPv6 addresses are pingable from the outside world. The switch and router are connected with OSPF. I am not able to add the eui-64 prefix to my VLAN. What do I need to do to add IPv6 to my VLANs?

 

 

Router interfaces:

interface GigabitEthernet0/0
description OUTSIDE
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
ipv6 nd dad attempts 0
ipv6 nd autoconfig default-route
ipv6 dhcp client pd hint ::/64
ipv6 dhcp client pd COX
!
interface GigabitEthernet0/1
description INSIDE
ip address 10.0.0.9 255.255.255.252
ip nat inside
ip virtual-reassembly in
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7 0702364F1F514A51
ip ospf 10 area 0
duplex auto
speed auto
ipv6 address 2600:8807:8500:419::/64 eui-64
ipv6 address autoconfig
ipv6 enable
ipv6 nd autoconfig default-route
ipv6 ospf 10 area 0

 

Switch interfaces:

interface GigabitEthernet1/0/4
description LINK TO MIKEROUTER
no switchport
ip address 10.0.0.10 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7 10431E1A544F415F
ip ospf 10 area 0
ipv6 address autoconfig
ipv6 ospf 10 area 0

 

 

interface Vlan10
description MIKERO
ip address 10.10.17.1 255.255.255.0
ip ospf 10 area 0
ipv6 address autoconfig default
ipv6 enable
ipv6 ospf 10 area 0

31 Replies 31

Ok, so autoconfig worked on the inside switch interface.

This is what I am getting on the DHCP debug output

 

Sending SOLICIT to FF02::1:2 on GigabitEthernet0/1
Mar 6 17:09:47.954: IPv6 DHCP: Received ADVERTISE from FE80::20F:23FF:FE97:CEC6 on GigabitEthernet0/1
Mar 6 17:09:47.954: IPv6 DHCP: Adding server FE80::20F:23FF:FE97:CEC6
Mar 6 17:09:47.954: IPv6 DHCP: Removing server FE80::20F:23FF:FE97:CEC6 that advertised no addresses

Ok, I am nearly there. I got the IP all the way to my switch. How do I get the IP on the VLAN? Do I need to add the pd client to the switch interface?

Unfortunately, this ipv6 address that you got on the switch uplink is not really useful other than connecting to the Internet from the switch itself. There is not way to dynamically propagate the PD prefix you got from Cox. You could go and manually configure the switch, but would need to reconfigure if you get a new prefix delegation from them. The ideal would be to have the internal switch to act as a L2 switch and to manage the IPv6 configuration from the C2821.

 

Regards, 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

So configure a trunk on the switch and subinterfaces on the router? Ok, I can do that. What about the VLANs? Configure them as autoconfig? How would I get the IP's on to the computers?

Yes, configure a trunk on the C3750 towards the C2821 and subinterfaces on the C2821. These subinterfaces would be configured with the different /64 (COX ::1/64, COX ::1:0:0:0:1/64, COX ::2:0:0:0:1/64, etc).

 

The VLANs do not need an IPv6 address.

 

The computers would autoconfigure themselves from the router advertisement received from the C2821. The ipv6 prefix they would get would depend on the VLAN they are part of.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Ok, the subinterface picked up an IP, but the VLAN didn't and neither did my computer. I added "ipv6 add auto" to the VLAN and it picked up an IP and so did my computer but they are not reachable. What am I missing?

 

interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.10.17.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
ipv6 address COX ::1/64
ipv6 enable
end

Do I need a default route for the IPv6 addresses?

Change to the change. I am able to ping out to an IPv6 address on my computer. The firewall on windows 7 was blocking the pings. My last concern is the DNS. Shouldn't I be getting a DNS server in my ipconfig info?

So one step closer, by adding "ipv6 nd auto default-r"to the VLAN interface, I am now able to ping the VLAN IP from the outside. I am still not able to ping the computer and the computer is not picking up an IPv6 DNS server.

For dns and domain name information you need to configure the following on the C2821.

 

ipv6 dhcp pool dns-info
 import dns-server
 import domain-name

 

int <subinterface>
 ipv6 nd other-config-flag
 ipv6 dhcp server dns-info

 

This should provide your workstations with the required information.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

I am still unable to pick a DNS server.

Can you provide the output of a "show ipv6 dhcp pool"" The imported dns servers and domain name should show up in there. If they don't, you might need to bounce the WAN interface so the DHCP information from Cox is refreshed.

 

r2#sh ipv6 dhcp pool
DHCPv6 pool: client
  Imported DNS server: 2001:DB8::1
  Imported DNS server: 2001:DB8::2
  Imported Domain name: cisco.com
  Active clients: 0

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

They are there, they just aren't being passed on to my hosts.

 

MikeroRouter#sho ipv6 dhcp pool
DHCPv6 pool: dns-info
Imported DNS server: 2001:578:3F::30
Imported DNS server: 2001:578:3F:1::30
Active clients: 0

I am now magically picking up DNS servers!! Thanks for all your help. I really appreciate it. I will edit the OP with what I was trying to do and the configuration that worked and the observations I made later today.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: