cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2136
Views
0
Helpful
1
Replies
Highlighted

Issue 6to4 IPv6 Tunneling

Hey cisco support forum,

I'm preparing for a test, but I have an issue. I have two cisco C3725 routers connected via ethernet, but they can't seem to ping each other IPv6 address. IPv4 works fine. I connected the networks with an 6to4 IPv6 tunnel. The tunnel works if I change the tunnel source (and the IP) to FastEthernet0/0, but its mandatory for my assignment that is use a Loopback interface. I have to ping the fa0/1 interface of R2 from R1 and vice versa. But this doesn't work. I hope someone can help me. My configuration:

R1:

interface Loopback0
ip address 1.0.0.1 255.255.255.255
!
interface Tunnel0
ipv6 address 2002:100:1:2::1/64
tunnel source Loopback0
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1
ipv6 address 2001:DB8:0:1::1/64
!
!
no cdp log mismatch duplex
ipv6 route 2001:DB8:0:2::/64 2002:100:2:2::1
ipv6 route 2002::/16 Tunnel0

R2:

interface Loopback0
ip address 1.0.0.2 255.255.255.255
!
interface Tunnel0
ipv6 address 2002:100:2:2::1/64
tunnel source Loopback0
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet0/1
ipv6 address 2001:DB8:0:2::1/64
!
ipv6 route 2001:DB8:0:1::/64 2002:100:1:2::1
ipv6 route 2002::/16 Tunnel0

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

You're tunneling IPv6 in IPv4, so the IPv4 will need a route between routers.  Of course the FastEthernet interface works, it's directly connected.

Easiest option is static:

R1:

ip route 1.0.0.2 255.255.255.255 192.168.12.2

R2:

ip route 1.0.0.1 255.255.255.255 192.168.12.1

Cheers.

View solution in original post

1 REPLY 1
Highlighted

You're tunneling IPv6 in IPv4, so the IPv4 will need a route between routers.  Of course the FastEthernet interface works, it's directly connected.

Easiest option is static:

R1:

ip route 1.0.0.2 255.255.255.255 192.168.12.2

R2:

ip route 1.0.0.1 255.255.255.255 192.168.12.1

Cheers.

View solution in original post

Content for Community-Ad
This widget could not be displayed.