cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

1608
Views
0
Helpful
1
Replies
Highlighted
Beginner

Not working multitopology ISIS with IOS and IOS-XR

Hi everyone,

 

I've gon a problem setting up IPv6 routing with ISIS in the test network. There are four routers connected as shown on the image. 

 

 

I've got problems setting up IPv6 routing in this topology. I tried single topology and multitopology ISIS. Neither of them works properly. Single topology simple does not come up when IPv6 is configured in ISIS. Multitopology yet comes up but uyields only working IPv4 roting. I can see that IPv6 ISIS RIB is buit by the routers, but it is not copied into the main routing table.

 

That's what I get in the multitopology mode:

 

All neignors are up. 

R2#show isis neighbors

Tag null:
System Id      Type Interface   IP Address      State Holdtime Circuit Id
R7             L1   Et0/2       2.2.27.7        UP    7        R7.04            
R8             L1   Et0/1       2.2.28.8        UP    9        R8.03            
R9             L1   Et0/0       2.2.29.9        UP    7        R9.01 

 

Database in consistent on all four routers

R2#show isis database

Tag null:
IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R2.00-00            * 0x0000001C   0x21DD        727               0/0/0
R7.00-00              0x00000011   0xF6EF        866               0/0/0
R7.04-00              0x00000007   0x5CD2        1117              0/0/0
R8.00-00              0x0000000B   0xD2EA        941               0/0/0
R8.01-00              0x00000006   0xF0C3        878               0/0/0
R8.03-00              0x00000006   0x7E39        805               0/0/0
R9.00-00              0x0000000B   0x4071        817               0/0/0
R9.01-00              0x00000006   0x8D2A        783               0/0/0
R9.03-00              0x00000006   0xE3CC        840               0/0/0

ISIS IPv6 RIB contains only local prefixes

 

R2#show isis ipv6 rib
IS-IS IPv6 process , local RIB
  2002:2:2::7/128
  2002:2:2:27::/64
  2002:2:2:78::/64
  2002:2:2:79::/64

 

 

IPv6 topology is not complete as if R8 and R9 were not in database

 

R2#show isis ipv6 topology 

Tag null:
IS-IS TID 2 paths to level-1 routers
System Id            Metric     Next-Hop             Interface   SNPA
R2                   --
R7                   10         R7                   Et0/2       0202.5a00.b120
R8                   **
R9                   **

 

A closer look at isis database:

 

R2#show isis database detail

Tag null:
IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R2.00-00            * 0x0000001D   0x1FDE        1004              0/0/0
  Area Address: 47.0002
  Topology:     IPv4 (0x0)
                IPv6 (0x2)
  NLPID:        0xCC 0x8E
  Hostname: R2
  IP Address:   2.2.0.2
  Metric: 10         IP 2.2.0.2/32
  Metric: 10         IP 2.2.29.0/24
  Metric: 10         IP 2.2.28.0/24
  Metric: 10         IP 2.2.27.0/24
  IPv6 Address: 2002:2:2::2
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:29::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:28::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:27::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2::2/128
  Metric: 10         IS-Extended R7.04
  Metric: 10         IS-Extended R8.03
  Metric: 10         IS-Extended R9.01
  Metric: 10         IS (MT-IPv6) R7.04
  Metric: 10         IS (MT-IPv6) R8.03
  Metric: 10         IS (MT-IPv6) R9.01
R7.00-00              0x00000012   0xF4F0        1187              0/0/0
  Area Address: 47.0002
  Topology:     IPv4 (0x0)
                IPv6 (0x2)
  NLPID:        0xCC 0x8E
  Hostname: R7
  IP Address:   2.2.0.7
  Metric: 10         IP 2.2.0.7/32
  Metric: 10         IP 2.2.78.0/24
  Metric: 10         IP 2.2.79.0/24
  Metric: 10         IP 2.2.27.0/24
  IPv6 Address: 2002:2:2::7
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:78::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:79::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:27::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2::7/128
  Metric: 10         IS-Extended R7.04
  Metric: 10         IS-Extended R8.01
  Metric: 10         IS-Extended R9.03
  Metric: 10         IS (MT-IPv6) R7.04
  Metric: 10         IS (MT-IPv6) R8.01
  Metric: 10         IS (MT-IPv6) R9.03
R7.04-00              0x00000007   0x5CD2        640               0/0/0
  Metric: 0          IS-Extended R7.00
  Metric: 0          IS-Extended R2.00
R8.00-00              0x0000000B   0xD2EA        464               0/0/0
  Area Address: 47.0002
  NLPID:        0xCC 0x8E
  Topology:     IPv4 (0x0)
                IPv6 (0x2)
  Hostname: R8
  IP Address:   2.2.0.8
  IPv6 Address: 2002:2:2::8
  Metric: 10         IS-Extended R8.01
  Metric: 10         IS-Extended R8.03
  Metric: 10         IP 2.2.0.8/32
  Metric: 10         IP 2.2.28.0/24
  Metric: 10         IP 2.2.78.0/24
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2::8/128
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:28::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:78::/64
R8.01-00              0x00000007   0xEEC4        1155              0/0/0
  Metric: 0          IS-Extended R8.00
  Metric: 0          IS-Extended R7.00
R8.03-00              0x00000006   0x7E39        328               0/0/0
  Metric: 0          IS-Extended R8.00
  Metric: 0          IS-Extended R2.00
R9.00-00              0x0000000C   0x3E72        1035              0/0/0
  Area Address: 47.0002
  NLPID:        0xCC 0x8E
  Topology:     IPv4 (0x0)
                IPv6 (0x2)
  Hostname: R9
  IP Address:   2.2.0.9
  IPv6 Address: 2002:2:2::9
  Metric: 10         IS-Extended R9.01
  Metric: 10         IS-Extended R9.03
  Metric: 10         IP 2.2.0.9/32
  Metric: 10         IP 2.2.29.0/24
  Metric: 10         IP 2.2.79.0/24
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2::9/128
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:29::/64
  Metric: 10         IPv6 (MT-IPv6) 2002:2:2:79::/64
R9.01-00              0x00000007   0x8B2B        1048              0/0/0
  Metric: 0          IS-Extended R9.00
  Metric: 0          IS-Extended R2.00
R9.03-00              0x00000007   0xE1CD        1091              0/0/0
  Metric: 0          IS-Extended R9.00
  Metric: 0          IS-Extended R7.00

 

I don't understand the following: Why R8 doesn't consider itself attached to Pseudonodes R8.01 and R8.03 in IPv6 topology? The same question about R9 and Pseudonodes R9.01 and R9.03 in IPv6 topology. R7 and R2 consider themselves as attached to Pseudonode R7.04, although R7.04 doesn't look much different from the rest of the Pseudonode LSPs in the database. This fact still doesn't allow them to calculate a correct RIB.

 

Am I missing something?

 

Configs of the devices is below:

 

######R2########

service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
vrf definition ABC
 rd 2:2
 !
 address-family ipv4
 route-target export 2:2
 route-target import 2:2
 route-target import 1002:2
 exit-address-family
!
!
!
!
!
no aaa new-model
clock timezone PST 0
ip source-route
ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.0.2 255.255.255.255
 ip router isis
 ipv6 address 2002:2:2::2/128
 ipv6 router isis
!
interface Ethernet0/0
 ip address 2.2.29.2 255.255.255.0
 ip router isis
 ipv6 address 2002:2:2:29::2/64
 ipv6 router isis
 mpls ip
!
interface Ethernet0/1
 ip address 2.2.28.2 255.255.255.0
 ip router isis
 ipv6 address 2002:2:2:28::2/64
 ipv6 router isis
 mpls ip
!
interface Ethernet0/2
 ip address 2.2.27.2 255.255.255.0
 ip router isis
 ipv6 address 2002:2:2:27::2/64
 ipv6 router isis
 mpls ip
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 vrf forwarding ABC
 ip address 172.2.142.2 255.255.255.0
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
router isis
 net 47.0002.0000.0000.0002.00
 is-type level-1
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
router rip
 version 2
 !
 address-family ipv4 vrf ABC
  redistribute bgp 2 metric 1
  network 172.2.0.0
  no auto-summary
  version 2
 exit-address-family
!
router bgp 2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2.2.0.9 remote-as 2
 neighbor 2.2.0.9 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  network 2.2.0.2 mask 255.255.255.255
  neighbor 2.2.0.9 activate
  neighbor 2.2.0.9 send-community
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 2.2.0.9 activate
  neighbor 2.2.0.9 send-community extended
  neighbor 2.2.0.9 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf ABC
  no synchronization
  redistribute rip
 exit-address-family
!
!
no ip http server
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

 

 

######R7########

 

service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R7
!
boot-start-marker
boot-end-marker
!
vrf definition ABC
 rd 2:2
 !
 address-family ipv4
 route-target export 2:2
 route-target import 2:2
 route-target import 1002:2
 exit-address-family
!
!
!
!
!
no aaa new-model
clock timezone PST 0
ip source-route
ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.0.7 255.255.255.255
 ip router isis
 ipv6 address 2002:2:2::7/128
 ipv6 router isis
!
interface Ethernet0/0
 ip address 2.2.78.7 255.255.255.0
 ip router isis
 ipv6 address 2002:2:2:78::7/64
 ipv6 router isis
 mpls ip
!
interface Ethernet0/1
 ip address 2.2.79.7 255.255.255.0
 ip router isis
 ipv6 address 2002:2:2:79::7/64
 ipv6 router isis
 mpls ip
!
interface Ethernet0/2
 ip address 2.2.27.7 255.255.255.0
 ip router isis
 ipv6 address 2002:2:2:27::7/64
 ipv6 router isis
 mpls ip
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 vrf forwarding ABC
 ip address 172.2.17.7 255.255.255.0
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100 vrf ABC
 log-adjacency-changes
 redistribute bgp 2 subnets
 network 172.2.0.0 0.0.255.255 area 0
!
router isis
 net 47.0002.0000.0000.0007.00
 is-type level-1
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
router bgp 2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2.2.0.9 remote-as 2
 neighbor 2.2.0.9 update-source Loopback0
 neighbor 2002:2:2::9 remote-as 2
 neighbor 2002:2:2::9 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  network 2.2.0.7 mask 255.255.255.255
  neighbor 2.2.0.9 activate
  neighbor 2.2.0.9 send-community
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 2.2.0.9 activate
  neighbor 2.2.0.9 send-community extended
 exit-address-family
 !
 address-family ipv6
  no synchronization
  network 2002:2:2::7/128
  neighbor 2002:2:2::9 activate
 exit-address-family
 !
 address-family ipv4 vrf ABC
  no synchronization
  redistribute ospf 100 vrf ABC
 exit-address-family
!
!
no ip http server
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

 

 

######R9########

hostname R9
telnet vrf default ipv4 server max-servers 100
username student
 group root-lr
 secret 5 $1$FJX6$23S1vUlkI7nuRNSFMWR8N0
!
aaa authentication login default local
cdp
vrf ABC
 address-family ipv4 unicast
  import route-target
   2:2
   1002:2
  !
  export route-target
   2:2
  !
 !
!
control-plane
 management-plane
  out-of-band
   interface MgmtEth0/0/CPU0/0
    allow Telnet
   !
  !
 !
!
interface Loopback0
 ipv4 address 2.2.0.9 255.255.255.255
 ipv6 address 2002:2:2::9/128
!
interface MgmtEth0/0/CPU0/0
 ipv4 address 10.0.8.129 255.255.255.0
!
interface GigabitEthernet0/2/1/0
 description uplink SW4
!
interface GigabitEthernet0/2/1/1
 description uplink R2, R5
!
interface GigabitEthernet0/2/1/1.29
 description - VLAN 29 (R2)
 ipv4 address 2.2.29.9 255.255.255.0
 ipv6 address 2002:2:2:29::9/64
 dot1q vlan 29
!
interface GigabitEthernet0/2/1/1.59
 description - VLAN 59 (R5)
 vrf ABC
 ipv4 address 172.2.59.9 255.255.255.0
 dot1q vlan 59
!
interface GigabitEthernet0/2/1/2
 description uplink R6, R7
!
interface GigabitEthernet0/2/1/2.69
 description - VLAN 69 (R6)
 ipv4 address 2.2.69.9 255.255.255.0
 ipv6 address 2002:2:2:69::9/64
 dot1q vlan 69
!
interface GigabitEthernet0/2/1/2.79
 description - VLAN 79 (R7)
 ipv4 address 2.2.79.9 255.255.255.0
 ipv6 address 2002:2:2:79::9/64
 dot1q vlan 79
!
interface GigabitEthernet0/2/1/3
 shutdown
!
interface GigabitEthernet0/2/1/4
 shutdown
!
interface POS0/2/0/0
 shutdown
!
interface POS0/2/0/1
 shutdown
!
interface POS0/2/0/2
 shutdown
!
interface POS0/2/0/3
 shutdown
!
route-policy default_policy_pass_all
  pass
end-policy
!
router static
 address-family ipv4 unicast
  2.2.69.6/32 GigabitEthernet0/2/1/2.69
 !
!
router isis abc
 is-type level-1
 net 47.0002.0000.0000.0009.00
 address-family ipv4 unicast
  metric-style wide
 !
 interface Loopback0
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/2/1/1.29
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/2/1/2.79
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
!
router bgp 2
 address-family ipv4 unicast
  network 2.2.0.9/32
 !
 address-family vpnv4 unicast
 !
 address-family ipv6 unicast
  network 2002:2:2::9/128
 !
 address-family vpnv6 unicast
 !
 neighbor 2.2.0.2
  remote-as 2
  update-source Loopback0
  address-family ipv4 unicast
   next-hop-self
  !
  address-family vpnv4 unicast
   route-reflector-client
  !
 !
 neighbor 2.2.0.7
  remote-as 2
  update-source Loopback0
  address-family ipv4 unicast
   next-hop-self
  !
  address-family vpnv4 unicast
   route-reflector-client
   next-hop-self
  !
  address-family ipv6 unicast
   next-hop-self
  !
  address-family vpnv6 unicast
   next-hop-self
  !
 !
 neighbor 2.2.0.8
  remote-as 2
  update-source Loopback0
  address-family ipv4 unicast
   next-hop-self
  !
  address-family vpnv4 unicast
   route-reflector-client
   next-hop-self
  !
 !
 neighbor 2.2.69.6
  remote-as 1002
  address-family ipv4 unicast
   route-policy default_policy_pass_all in
   route-policy default_policy_pass_all out
  !
  address-family vpnv4 unicast
   route-policy default_policy_pass_all in
   route-policy default_policy_pass_all out
  !
 !
 neighbor 2002:2:2::7
  remote-as 2
  update-source Loopback0
  address-family ipv6 unicast
   next-hop-self
  !
 !
 neighbor 2002:2:2:69::6
  remote-as 1002
  address-family ipv6 unicast
   route-policy default_policy_pass_all in
   route-policy default_policy_pass_all out
  !
 !
 vrf ABC
  rd 2:2
  address-family ipv4 unicast
   redistribute eigrp 100
  !
 !
!
mpls ldp
 router-id 2.2.0.9
 interface GigabitEthernet0/2/1/1.29
 !
 interface GigabitEthernet0/2/1/2.79
 !
!
router eigrp 100
 vrf ABC
  address-family ipv4
   default-metric 100000 10 250 1 1500
   autonomous-system 100
   redistribute bgp 2
   interface GigabitEthernet0/2/0/1.59
   !
   interface GigabitEthernet0/2/1/1.59
   !
  !
 !
!
end

######R8########

 

hostname R8
telnet vrf default ipv4 server max-servers 100
username student
 group root-lr
 secret 5 $1$Y39m$k.fAmjkI6OEFDmiIfSkGt1
!
aaa authentication login default local
cdp
vrf ABC
 address-family ipv4 unicast
  import route-target
   2:2
   1002:2
  !
  export route-target
   2:2
  !
 !
!
control-plane
 management-plane
  out-of-band
   interface MgmtEth0/0/CPU0/0
    allow Telnet
   !
  !
 !
!
interface Loopback0
 ipv4 address 2.2.0.8 255.255.255.255
 ipv6 address 2002:2:2::8/128
!
interface MgmtEth0/0/CPU0/0
 ipv4 address 10.0.8.128 255.255.255.0
!
interface GigabitEthernet0/2/1/0
 description uplink SW3
!
interface GigabitEthernet0/2/1/1
 description uplink R3, R7
!
interface GigabitEthernet0/2/1/1.38
 description - VLAN 38 (R3)
 vrf ABC
 ipv4 address 172.2.38.8 255.255.255.0
 dot1q vlan 38
!
interface GigabitEthernet0/2/1/1.78
 description - VLAN 78 (R7)
 ipv4 address 2.2.78.8 255.255.255.0
 ipv6 address 2002:2:2:78::8/64
 dot1q vlan 78
!
interface GigabitEthernet0/2/1/2
 description uplink R2, R15
!
interface GigabitEthernet0/2/1/2.28
 description - VLAN 28 (R2)
 ipv4 address 2.2.28.8 255.255.255.0
 ipv6 address 2002:2:2:28::8/64
 dot1q vlan 28
!
interface GigabitEthernet0/2/1/2.158
 description - VLAN 158 (R15)
 dot1q vlan 158
!
route-policy default_policy_pass_all
  pass
end-policy
!
router isis abc
 is-type level-1
 net 47.0002.0000.0000.0008.00
 address-family ipv4 unicast
  metric-style wide
 !
 interface Loopback0
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/2/1/1.78
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/2/1/2.28
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
!
router bgp 2
 address-family ipv4 unicast
  network 2.2.0.8/32
 !
 address-family vpnv4 unicast
 !
 neighbor 2.2.0.9
  remote-as 2
  update-source Loopback0
  address-family ipv4 unicast
   next-hop-self
  !
  address-family vpnv4 unicast
  !
 !
 vrf ABC
  rd 2:2
  address-family ipv4 unicast
   network 172.2.38.0/24
   allocate-label all
  !
  neighbor 172.2.38.3
   remote-as 123
   address-family ipv4 unicast
    route-policy default_policy_pass_all in
    route-policy default_policy_pass_all out
    as-override
    send-extended-community-ebgp
   !
  !
 !
!
mpls ldp
 router-id 2.2.0.8
 interface GigabitEthernet0/2/1/1.78
 !
 interface GigabitEthernet0/2/1/2.28
 !
!
end

RP/0/0/CPU0:R8#

 

1 REPLY 1
Rising star

Hello,Can you check on XR

Hello,

Can you check on XR that you have option of enabling metric-style wide under ipv6 address-family.I'm not sure but i suppose you will also need to configure metric-style wide under ipv6 address-family as you are using multi-topology .IOS default run single topology and XR run default multi-topology.only need to be sure that you are running same topology and metric-style same on all router,in transition process like from multi to single or changing metric-style you can use "metric-style transition" option..

 

Regards,

Ashish

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards