cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1575
Views
5
Helpful
2
Replies

Question regarding IPv6 to IPv4 NAT

paradeben
Level 1
Level 1

I'm trying to make something work with a Cisco ASA 5510 and am a bit lost on how and/or where to start. To make a long story short, we've got a server that publicly hosts a web application, and upper management has decided they want it to be addressed via IPv6. Due to a number of reasons, we're trying to avoid having to re-do our network to make this happen, so the goal currently is to see if we can keep the IPv4 addressing scheme on the server as it currently is, and put an ASA between the server and the network's edge device. The ASA would then translate the internal IPv4 address of the server to an IPv6 address that the public would see, and visa versa (have incoming connections send request to that IPv6 address, which the ASA would translate to IPv4 and route to the appropriate server).

I'm more of a systems guy than a network admin, but from the little bit of research I've done thus far, I'm guessing this can be done by either NAT64, NAT46, or some combination of the two, but I'm not entirely sure of how to start. Any help from you guys would be greatly appreciated!

2 Replies 2

Hi

 This series of videos explain what you intend to. They are using router instead firewall but the concept is the same. This scenario is easylly simulated in GNS3, so, you can try that and this can be a lot easier for you in production environment.

 

https://www.youtube.com/watch?v=CnJNDOI_JGg&t=84s 

Harold Ritter
Cisco Employee
Cisco Employee

Hi @paradeben ,

 

It is certainly possible to do that using the ASA.

 

Here's a sample configuration.

 

ciscoasa# sh running-config int gi0/0
!
interface GigabitEthernet0/0
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0

ciscoasa# sh running-config int gi0/1
!
interface GigabitEthernet0/1
nameif outside
security-level 0
no ip address
ipv6 address 2001:db8:12ff:1::1/64

ciscoasa# sh runn nat
nat (outside,inside) source dynamic any pat-pool ipv4-pool destination static subnet6 any

ciscoasa# sh running-config object
object network ipv4-pool
range 192.168.2.1 192.168.2.254
object network subnet6
subnet 2001:db8:12ff:2::/96

ciscoasa#

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: