cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Sample GOS IPV6 Configuration

634
Views
1
Helpful
6
Comments

Assumption is that you have read this article before coming to this, If not, please kindly visit there

NAT configurations for GOS external connectivity

Below is a quick reference for GOS IPV6 configuration in case you would like to extend from ipv4 to ipv6 for GOS connectivity

IOS Configuration:

config t

Ipv6 unicast-routing

interface GigabitEthernet2/2

no switchport

ip address 72.163.203.193 255.255.254.0

ip nat outside

ipv6 address 3001::1/64

Calabria_1#sh run int gi 0/1

!

interface GigabitEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ipv6 address 2001::1/64

ipv6 enable

end

Calabria_1#

Guest OS:

root@Calabria_1-GOS-1:/usr/include# cat /etc/network/interfaces

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface

auto lo

iface lo inet loopback

auto eth0

iface eth0 inet dhcp

iface eth0 inet6 static

pre-up modprobe ipv6

address 2001::2

netmask 64

gateway 2001::1

root@Calabria_1-GOS-1:/usr/include#

show the routing Table:

From CGR:

CGR1000#show ipv6 route
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, a - Application
C   2001::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2001::1/128 [0/0]
     via GigabitEthernet0/1, receive
C   3001::/64 [0/0]
     via GigabitEthernet2/1, directly connected
L   3001::1/128 [0/0]
     via GigabitEthernet2/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
CGR1000#

From GOS:

root@qemux86:~# /sbin/route -6     
Kernel IPv6 routing table
Destination                    Next Hop                   Flag Met Ref Use If
2001::/64                      ::                         U    256 0     1 eth0
fe80::/64                      ::                         U    256 0     0 eth0
::/0                           2001::1                    UG   1   0     0 eth0
::/0                           ::                         !n   -1  1    50 lo
::1/128                        ::                         Un   0   1     1 lo
2001::2/128                    ::                         Un   0   1    19 lo
fe80::c267:afff:fe0b:468c/128  ::                         Un   0   2     3 lo
ff00::/8                       ::                         U    256 0     0 eth0
::/0                           ::                         !n   -1  1    50 lo

Ping from Guest OS to Gig 2/2:

root@qemux86:~# ping6 3001::1
PING 3001::1(3001::1) 56 data bytes
64 bytes from 3001::1: icmp_seq=1 ttl=64 time=2.39 ms
64 bytes from 3001::1: icmp_seq=2 ttl=64 time=8.26 ms
^C
--- 3001::1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1009ms
rtt min/avg/max/mdev = 2.391/5.326/8.261/2.935 ms
root@qemux86:~# ping6 3001::2
PING 3001::2(3001::2) 56 data bytes
64 bytes from 3001::2: icmp_seq=1 ttl=63 time=2.57 ms
64 bytes from 3001::2: icmp_seq=2 ttl=63 time=2.57 ms
^C
--- 3001::2 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1008ms
rtt min/avg/max/mdev = 2.573/2.574/2.575/0.001 ms
root@qemux86:~#

Comments
Beginner

Does this allows the CGR 1000 series router to external internal connectivity? Is it possible for it configure it as modbus?

Cisco Employee

Hi,

CGR 1000 offers 2 serial ports. Traffic from one or both serial ports can be either handled by IOS or re-directed to the Guest OS.

CGR 1000 IOS doesn't provide protocol translation for ModBus (Modbus - Modbus/TCP), while supporting DNP3 - DNP3/IP, see http://www.cisco.com/c/dam/en/us/td/docs/routers/connectedgrid/cgr1000/ios/software/15_4_1_cg/OL-31250-01.pdf

Dependent of your objectives, either you could forward the Modbus traffic from Serial port to your Modbus server leveraging the IOS Raw Socket feature set, see http://www.cisco.com/c/dam/en/us/td/docs/routers/connectedgrid/cgr1000/ios/software/15_4_1_cg/OL-31251-01.pdf

or implement your own or 3rd party Modbus server or protocol translation on the Guest OS

Regards

Patrick

Beginner

Thank you very much for your reply. My application is modbus over tcp, does it still apply to this case as well ?

Cisco Employee

Hi,

In the case of Modbus TCP, the protocol already runs over IPv4. By default, I assume your attached Ethernet device communicates with a central server through the CGR 1000. In case of Guest OS, you may implement a Modbus application on the Yocto Linux. On the Modbus TCP device, you will have to set-up the IPv4 address of the Guest OS as the address of the application.

More details may be needed if you need a specific configuration.

Kind Regards

Patrick

Beginner

Yes, we have currently implement NAT inside at the GOS so that the GOS can now ping to the external device connect to the gigabitehternet of the CGR.  (the external device is just a voltage meter capable of modbus tcp communication via a ethernet cabLe).  The external device has already configured to do modbus succesfully. Currently, we are looking to implement "libmodbus" in the GOS side, so that they can talk to each other.

Is this a good approach ?

Cisco Employee

Hi,

Don't forget to configure

ipv6 cef


when activating IPv6, otherwise you will be process switched

Regards

Patrick

Content for Community-Ad
August's Community Spotlight Awards